X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to stop Firefox from auto-updating to 57?

Kuphostiwe

57 is completely nonfunctional for me, and I've already deleted and reinstalled 56 twice. But even after selecting 'never check for updates' and unchecking 'use a background service to install updates' it still gets pushed on me. How do I stop this from happening? I'm on Ubuntu 16.04.

57 is completely nonfunctional for me, and I've already deleted and reinstalled 56 twice. But even after selecting 'never check for updates' and unchecking 'use a background service to install updates' it still gets pushed on me. How do I stop this from happening? I'm on Ubuntu 16.04.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 27.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

Eminye Imininingwane

Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Going back : unfortunately 56.0.2 is no longer safe to use for every day use do to security issues, but 52.5.0 ESR is! It will continue to get security updates until May 2018, and you can download and install it from this page: https://www.mozilla.org/en-US/firefox/organizations/all/ Note : Legacy Extensions will be deleted or removed in any version update after May 2018.

Please let us know if this solved your issue or if need further assistance.

Going back : unfortunately 56.0.2 is no longer safe to use for every day use do to security issues, but 52.5.0 ESR is! It will continue to get security updates until May 2018, and you can download and install it from this page: https://www.mozilla.org/en-US/firefox/organizations/all/ Note : Legacy Extensions will be deleted or removed in any version update after May 2018. Please let us know if this solved your issue or if need further assistance.

Impendulo Ewusizo

Unsafe to use is still better than entirely UNABLE to use. 57 is nonfunctional. I had to download chrome and use that to re-download and install 56. What I want to know is how to STOP the auto update to 57.

Unsafe to use is still better than entirely UNABLE to use. 57 is nonfunctional. I had to download chrome and use that to re-download and install 56. What I want to know is how to STOP the auto update to 57.
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Sorry 56 is not supported. Go to the ESR version which is supported.

Sorry 56 is not supported. Go to the ESR version which is supported.

Impendulo Ewusizo

I don't care which version is supported or not, I just want Firefox to stop automatically updating!

I don't care which version is supported or not, I just want Firefox to stop automatically updating!
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Then go to ESR version and have till next May 2018. It will not update to 57. This is what you asked for, so was given.

Then go to ESR version and have till next May 2018. It will not update to 57. This is what you asked for, so was given.
W1shb0ne_Snap 0 izisombululo 2 izimpendulo
Kuphostiwe

I also refuse to upgrade to Firefox 57, in my case because Speed Dial is not available. I had to repearedly reinstall despite saying 'No' in all the Options.

I may have stumbled on the solution that stops Firefox upgrading. It turns out that Firefox Private Browsing has its own options !

In the Private Browsing window, repeat what you've done by switching off updates all over again. That has done the trick for me. I've not had to reinstall for a week now. I'm running 56.0.2, but hopefully it works for earlier versions.

I also refuse to upgrade to Firefox 57, in my case because Speed Dial is not available. I had to repearedly reinstall despite saying 'No' in all the Options. I may have stumbled on the solution that stops Firefox upgrading. It turns out that Firefox Private Browsing has its own options ! In the Private Browsing window, repeat what you've done by switching off updates all over again. That has done the trick for me. I've not had to reinstall for a week now. I'm running 56.0.2, but hopefully it works for earlier versions.
romehu2 0 izisombululo 1 izimpendulo
Kuphostiwe

This archived thread, which can no longer be posted to, solved this problem for me, specifically the answer by user 'mamabile':

https://support.mozilla.org/en-US/questions/1157765 >>> I agree that firefox continues to download when I have explicitly asked not to do this.

the easy fix is to modify the windows hosts file to add entries to stop the update: see below, as follows:

127.0.0.1 www.mozilla.org 127.0.0.1 download.cdn.mozilla.net 127.0.0.1 aus5.mozilla.org 127.0.0.1 download.mozilla.org

To know what entries to add. Have a look into the files in the C:\Users\<user name here>\AppData\Local\Mozilla\Updates to get the http:\\ URL entries. This will stop any future updates, even if you use the: menu => Help => About Firefox <<<

Note that I WAS NOT going to the Help > About menu, so Firefox simply ignores the "never update" checkbox. And that is really awful. I added the last 3 entries above to my hosts file and that seems to have stopped FF57 from reappearing. Huzzah!

And FYI, in Win10 (and maybe others), the "hosts" file is located in the C:\Windows\System32\drivers\etc folder.

FYI2: This change will prevent you from browsing to the downloads page in FF to get other versions, so get the version you want before updating the hosts file!

This archived thread, which can no longer be posted to, solved this problem for me, specifically the answer by user 'mamabile': https://support.mozilla.org/en-US/questions/1157765 >>> I agree that firefox continues to download when I have explicitly asked not to do this. the easy fix is to modify the windows hosts file to add entries to stop the update: see below, as follows: 127.0.0.1 www.mozilla.org 127.0.0.1 download.cdn.mozilla.net 127.0.0.1 aus5.mozilla.org 127.0.0.1 download.mozilla.org To know what entries to add. Have a look into the files in the C:\Users\<user name here>\AppData\Local\Mozilla\Updates to get the http:\\ URL entries. This will stop any future updates, even if you use the: menu => Help => About Firefox <<< Note that I WAS NOT going to the Help > About menu, so Firefox simply ignores the "never update" checkbox. And that is really awful. I added the last 3 entries above to my hosts file and that seems to have stopped FF57 from reappearing. Huzzah! And FYI, in Win10 (and maybe others), the "hosts" file is located in the C:\Windows\System32\drivers\etc folder. FYI2: This change will prevent you from browsing to the downloads page in FF to get other versions, so get the version you want before updating the hosts file!

Okulungisiwe ngu romehu2

FredMcD
  • Top 10 Contributor
4306 izisombululo 60469 izimpendulo
Kuphostiwe

First, Type about:preferences#advanced<enter> in the address bar. Under Advanced, Select Update.

[v56+] Type about:preferences#general<enter> in the address bar. Select Update.

Select Never Check For Updates.

Also turn off Use a background service to install updates


Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

First, Type '''about:preferences#advanced'''<enter> in the address bar. Under '''Advanced, ''' Select '''Update. ''' [v56+] Type '''about:preferences#general'''<enter> in the address bar. Select '''Update. ''' Select '''Never Check For Updates.''' Also turn off '''Use a background service to install updates''' --------------- [https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Install Older Version Of Firefox] {web link} Be sure to read everything here. If you still want to downgrade, look under; '''I still want to downgrade. ''' Click the '''Directory of other versions and languages''' link. Look for the directory of the version that you want. But, remember that '''old versions may have security issues. ''' You should also check out [https://www.mozilla.org/en-US/firefox/organizations/ Firefox; Extended Support Release] {web link} [https://www.mozilla.org/en-US/firefox/organizations/notes/ ESR Notes] [https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ System Requirements]
cor-el
  • Top 10 Contributor
  • Moderator
17680 izisombululo 159921 izimpendulo
Kuphostiwe

If you install Firefox in a location that requires root access (/usr/local/firefox)then Firefox won't be able to update automatically.

If you install Firefox in a location that requires root access (/usr/local/firefox)then Firefox won't be able to update automatically.