X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox developer edition - font smoothness in menu options

Kuphostiwe

After updating Firefox developer edition to version 51 (Windows 7, 64bit) I noticed some font rendering issues in the Options menu and Dev tools menu. The font is blured and not clear (looks like font smoothing is disabled). If I go to Safe mode (Restart with disabled addons) - the Options menu font is clear and good looking (readable) again, but in this mode the directwrite is disabled, of course.

In the normal Firefox (version 49, not Developer edition) the Options menu and Dev tools menu fonts are pretty fine - no issues at all.

I tried to refresh the Developer edition but the result is the same.

I checked my home laptop and it was the same - after updating Developer edition to version 51 - the Options menu/Devtools menu fonts sucks there, too.

So what could I do?

After updating Firefox developer edition to version 51 (Windows 7, 64bit) I noticed some font rendering issues in the Options menu and Dev tools menu. The font is blured and not clear (looks like font smoothing is disabled). If I go to Safe mode (Restart with disabled addons) - the Options menu font is clear and good looking (readable) again, but in this mode the directwrite is disabled, of course. In the normal Firefox (version 49, not Developer edition) the Options menu and Dev tools menu fonts are pretty fine - no issues at all. I tried to refresh the Developer edition but the result is the same. I checked my home laptop and it was the same - after updating Developer edition to version 51 - the Options menu/Devtools menu fonts sucks there, too. So what could I do?
Ama-screenshot ananyekiwe

Okulungisiwe ngu miroslavgeorgiev

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • Shockwave Flash 23.0 r0

Isisebenziso

  • Firefox 51.0a2
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/51.0a2/WINNT/en-US/

Izandiso

  • Adblock Plus 2.7.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • FlyWeb 1.0.0 (flyweb@mozilla.org)
  • Form Autofill 1.0 (formautofill@mozilla.org)
  • LiveReload 2.1.1 (livereload@livereload.com)
  • Multi-process staged rollout 1.4 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: AMD Radeon HD 7560D
  • adapterDescription2:
  • adapterDeviceID: 0x9904
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 100
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17568
  • driverDate: 8-3-2015
  • driverDate2:
  • driverVersion: 15.200.1062.1004
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Compositing', u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Direct3D9 Compositing', u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Direct2D', u'name': u'DIRECT2D'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'ApzWheelInput': 1}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webgl2Renderer: Google Inc. -- ANGLE (AMD Radeon HD 7560D Direct3D11 vs_5_0 ps_5_0)
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7560D Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
ideato 893 izisombululo 6250 izimpendulo
Kuphostiwe

Hi, any luck if you change the :

  • gfx.font_rendering.cleartype_params.rendering_mode > 2

thank you

Hi, any luck if you change the : * gfx.font_rendering.cleartype_params.rendering_mode > 2 thank you

Umnikazi wombuzo

Hi, Ideato,

Thanks for yor answer! You mean to remove the directwrite and set GDI with this option, right? I tried it a couple of days ago, until browsing the net for solutions - but it is the same, again - no change at all.

Hi, Ideato, Thanks for yor answer! You mean to remove the directwrite and set GDI with this option, right? I tried it a couple of days ago, until browsing the net for solutions - but it is the same, again - no change at all.
ideato 893 izisombululo 6250 izimpendulo
Kuphostiwe

Hi, layers.allow-d3d9-fallback to false ?

thanks

Hi, '''layers.allow-d3d9-fallback''' to false ? thanks

Impendulo Ewusizo

Hi,

Nope - it is still the same.

Hi, Nope - it is still the same.
spdgnzls 2 izisombululo 37 izimpendulo
Kuphostiwe

Somewhere at mozilla pages I found it has to do with these css rendering settings for the app: font-smooth: auto; font-smooth: never; font-smooth: always; but I could not find where those app css settings are (not in the profile folder which I full-text searched).

Somewhere at mozilla pages I found it has to do with these css rendering settings for the app: font-smooth: auto; font-smooth: never; font-smooth: always; but I could not find where those app css settings are (not in the profile folder which I full-text searched).
spdgnzls 2 izisombululo 37 izimpendulo
Kuphostiwe

bad font smoothing came with v52.0a2 while it was mostly clear (in the app, not all webpages) in v51.0a2

and again, like in a dictatorship, !someone! just dumped in on users, instead of first asking, or making it an !option!...how about that...or at least explaining where it can be !adjusted!

(
bad font smoothing came with v52.0a2 while it was mostly clear (in the app, not all webpages) in v51.0a2 and again, like in a dictatorship, !someone! just dumped in on users, instead of first asking, or making it an !option!...how about that...or at least explaining where it can be !adjusted! :(