X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Since upgrading to Firefox 33, The open sans font did not display correctly when specified by a website.

Kuphostiwe

Some of the vertical lines in the fonts are double width like a mixture of bold and normal font weight. I have hardware accellaration disabled. The problem is not fixed when I change default font settings. The problem is not resolved be resetting zoom to 0.

Inspect Element identifies the problem happens when the website selects open Sans. If I stop sites selecting fonts and force the defaults I don not get the problem. Therefore the problem is with Firefox 33.1 rendering certain fonts specified by websites.

My machine is windows vista and Open Sans is not shown in the font list. However this was not a problem with previous versions of Firefox.

I did need to do a reset of firefox parameters during the upgrade to 33 so maybe ther eis some other parameter which needs changing to help render fonts which are not loaded on the machine?

Some of the vertical lines in the fonts are double width like a mixture of bold and normal font weight. I have hardware accellaration disabled. The problem is not fixed when I change default font settings. The problem is not resolved be resetting zoom to 0. Inspect Element identifies the problem happens when the website selects open Sans. If I stop sites selecting fonts and force the defaults I don not get the problem. Therefore the problem is with Firefox 33.1 rendering certain fonts specified by websites. My machine is windows vista and Open Sans is not shown in the font list. However this was not a problem with previous versions of Firefox. I did need to do a reset of firefox parameters during the upgrade to 33 so maybe ther eis some other parameter which needs changing to help render fonts which are not loaded on the machine?

Isisombululo esikhethiwe

Is the operating system using font smoothing or cleartype? That makes a difference.

Funda le mpendulo ngokuhambisana nalesi sihloko 2

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 15.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Citrix Online App Detector Plugin
  • VLC media player Web Plugin 2.1.3
  • Nokia Suite Enabler Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Isisebenziso

  • Firefox 33.1.1
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.0; rv:33.0) Gecko/20100101 Firefox/33.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/33.1.1/WINNT/en-GB/

Izandiso

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Anti-Banner 13.0.1.4401 (anti_banner@kaspersky.com) (Akusebenzi)
  • Dangerous Websites Blocker 13.0.1.4401 (content_blocker@kaspersky.com) (Akusebenzi)
  • Kaspersky URL Advisor 13.0.1.4401 (url_advisor@kaspersky.com) (Akusebenzi)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Akusebenzi)
  • Safe Money 13.0.1.4401 (online_banking@kaspersky.com) (Akusebenzi)
  • Virtual Keyboard 13.0.1.4401 (virtual_keyboard@kaspersky.com) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Mobile Intel(R) 965 Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a02
  • adapterDeviceID2:
  • adapterDrivers: igdumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 7.0.6002.18392
  • driverDate: 2-11-2008
  • driverDate2:
  • driverVersion: 7.14.10.1437
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedDriver']
  • numTotalWindows: 1
  • webglRendererMessage: [u'blockedDriver']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.frecency_experiment: 4
  • browser.places.smartBookmarksVersion: 7
  • browser.search.update: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141113143407
  • browser.startup.homepage: https://www.google.co.uk/?gws_rd=ssl
  • browser.startup.homepage_override.buildID: 20141113143407
  • browser.startup.homepage_override.mstone: 33.1.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 33.1.1
  • font.name.sans-serif.x-western: Tahoma
  • font.name.serif.x-western: Tahoma
  • font.size.fixed.x-western: 14
  • font.size.variable.x-western: 17
  • general.autoScroll: False
  • gfx.direct2d.disabled: True
  • layers.acceleration.disabled: True
  • media.gmp-gmpopenh264.lastUpdate: 1415826698
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1416420250
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1416416512
  • places.history.expiration.transient_current_max_pages: 53418
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1415831087

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha

Impendulo Ewusizo

Here is a screenshot:

Here is a screenshot:
cor-el
  • Top 10 Contributor
  • Moderator
17573 izisombululo 158952 izimpendulo
Kuphostiwe

Try to disable OMTC and leave hardware acceleration in Firefox enabled.

Do other fonts have the same issue?

You can do a font test to see if you can identify corrupted font(s).

Try to disable OMTC and leave hardware acceleration in Firefox enabled. *<b>about:config</b> page: layers.offmainthreadcomposition.enabled = false *http://kb.mozillazine.org/about:config Do other fonts have the same issue? You can do a font test to see if you can identify corrupted font(s). *http://browserspy.dk/fonts-flash.php?detail=1

Umnikazi wombuzo

Thanks Cor-el. I've re-enabled hardware acceleration and disabled OMTC. No sign of the dragons. I've also downloaded and installed the Open Sans font family. None of these change the display in Firefox.

the font test shows open sans as bad but others such as myriad pro look a bit strange. I printed the test to a pdf. The print preview screen has the problem but acrobat renders the fonts correctly. So does IE8.

I thought about trying to output the whole set of parameters from about:config but at the moment havnt seen how to do that. Anyway this site doesnt let me upload a pdf.

Any more ideas welcome.

Thanks Cor-el. I've re-enabled hardware acceleration and disabled OMTC. No sign of the dragons. I've also downloaded and installed the Open Sans font family. None of these change the display in Firefox. the font test shows open sans as bad but others such as myriad pro look a bit strange. I printed the test to a pdf. The print preview screen has the problem but acrobat renders the fonts correctly. So does IE8. I thought about trying to output the whole set of parameters from about:config but at the moment havnt seen how to do that. Anyway this site doesnt let me upload a pdf. Any more ideas welcome.
finitarry 251 izisombululo 3421 izimpendulo
Kuphostiwe

You could try this setting in about:config: gfx.use_text_smoothing_setting -> true

It works for me.

You could try this setting in about:config: gfx.use_text_smoothing_setting -> true It works for me.

Umnikazi wombuzo

Thanks Finitarry. I've trid that change but the problem still exists. Maybe it is one of the other rendering parameters or now firefox wants cleartype fonts while my vist machine only has trutype and opentype. No doubt I will have learned something about fots by the time this is solved.

Thanks Finitarry. I've trid that change but the problem still exists. Maybe it is one of the other rendering parameters or now firefox wants cleartype fonts while my vist machine only has trutype and opentype. No doubt I will have learned something about fots by the time this is solved.
finitarry 251 izisombululo 3421 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Is the operating system using font smoothing or cleartype? That makes a difference.

Is the operating system using font smoothing or cleartype? That makes a difference.

Umnikazi wombuzo

Ive gone through control panel to windows appearance and effects. There I enabled cleartype and behold the problem is solved.

Presumably acrobat didnt have the problem because it is for print and doesnt use cleartype. And maybe IE8 didnt need or rely on cleartype because it is old.

The other settings changes suggested above are still in place and so may be contributing to the solution.

Many Thanks Finitarry

Ive gone through control panel to windows appearance and effects. There I enabled cleartype and behold the problem is solved. Presumably acrobat didnt have the problem because it is for print and doesnt use cleartype. And maybe IE8 didnt need or rely on cleartype because it is old. The other settings changes suggested above are still in place and so may be contributing to the solution. Many Thanks Finitarry