Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

v33 now using search suggestions in integrated home page

more options

Firefox updated itself to v33 last night and now the integrated home page with the Google entry box is no longer using autocomplete, but instead is using search suggestions. I do not want to use search suggestions, or else I would set Google as my home page.

How do I revert this to the prior behavior with autocomplete?

Isisombululo esikhethiwe

That was a helpful kick. I looked at the option but thought it was only for search suggestions.

Here's the real thing--the autocomplete history is gone.

The new search uses autocomplete AND suggestions together. Since autocomplete history is gone, its no longer showing the autocomplete data so it appeared to be using suggestions only. Once I did a couple of searches, they showed up in autocomplete and suggestions together.

Disabling suggestions simply turns off the network drill-down, as it should. Autocomplete continues to function in both ways. Its just the autocomplete history is gone.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (2)

more options

I suspect that my be related to the new "faster and snappier searches" feature in Firefox 33. http://msujaws.wordpress.com/2014/08/01/faster-and-snappier-searches-now-in-firefox-aurora/ Yes, the example provided there is totally different then what you are talking about, but ...

See if Show search suggestions in the Search Bar > Manage Search Engines... List is check-marked. With the massive number of consolidation steps that Firefox has seen over the past 5 or 6 versions to "search" functionality, that pref just may also be controlling what you are seeing on the default Homepage.

more options

Isisombululo Esikhethiwe

That was a helpful kick. I looked at the option but thought it was only for search suggestions.

Here's the real thing--the autocomplete history is gone.

The new search uses autocomplete AND suggestions together. Since autocomplete history is gone, its no longer showing the autocomplete data so it appeared to be using suggestions only. Once I did a couple of searches, they showed up in autocomplete and suggestions together.

Disabling suggestions simply turns off the network drill-down, as it should. Autocomplete continues to function in both ways. Its just the autocomplete history is gone.