Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Internet connection works but Firefox does not load pages

  • 5 uphendule
  • 11 zinale nkinga
  • 52675 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Internet connection works on Win7 desktop (Windows updates, Google Earth works etc) but Firefox & IE do not load web pages. Laptop (Vista) that uses same router runs Firefox just fine.

Have run various AV software like Malwarebytes etc with no problems found. Did re-install of Win 7 Tried these solutions https://www.youtube.com/watch?v=JK7oYj2YPNQ http://en.kioskea.net/forum/affich-19117-internet-connected-but-can-t-browse and other similar. Am sending from laptop as WIn7 PC does not allow me to connect and use Troubleshooting software

Isisombululo esikhethiwe

Thanks for reply but I found the solution. Many forum answers suggest changing Network settings but that doesn't work either. The combination that did solve the problem was to run "SuperAntiSpyware" which found virus, that Norton did not block. AND to uninstall and reinstall my copy of Norton 360.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (5)

more options

There are two things to check

Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

Type about:preferences<Enter> in the address bar.

Select Advanced > Network. Look for Configure How Firefox Connects and press the Settings button. Check the settings.

more options

Isisombululo Esikhethiwe

Thanks for reply but I found the solution. Many forum answers suggest changing Network settings but that doesn't work either. The combination that did solve the problem was to run "SuperAntiSpyware" which found virus, that Norton did not block. AND to uninstall and reinstall my copy of Norton 360.

more options

Most anti-virus can't detect mal-ware. Use these once in a while


Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

Please flag your last post as Solved Problem so other will know.