搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

I have selected "never remember my history" but everytime I start firefox and open a new tab, websites I visited the previous day are all displayed there.

  • 1 回覆
  • 2 有這個問題
  • 47 次檢視
  • 最近回覆由 cor-el

more options

Under Options I have selected "Firefox will never remember my history." Nevertheless, even after I have closed my browser and restarted my computer, Firefox does remember my browsing history. If I "clear all current history" it gets wiped out, but all browsing after that is remembered and is visible in "show all history" and when I open a new tab and there is a tiled display of previous websites visited. Is it not enough to say "never remember history?" Is there something else I need to do to not have this information saved?

P.S. I do have Firefox sync and one other device, a smart phone. Do I have to adjust settings in the browser on that? It doesn't seem to offer the same options.

所有回覆 (1)

more options

That is weird as you seem to be running Firefox in Private Browsing mode:

  • browser.privatebrowsing.autostart: True

Does this only happen after you reboot the computer or also if you reopen Firefox immediately?


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem