X
點擊此處開啟此網站的行動版。

技術支援討論區

When I go back to Google search results page, it takes me to a blank Google screen

已張貼

For example, I click on one link after doing a Google search, then I decide to go back & check one of the other links. When I go back instead of seeing my Google results screen again, I have a blank Google screen. Then I have to put my search terms in all over again. This does not happen using Internet Explorer. Thanks for any help

For example, I click on one link after doing a Google search, then I decide to go back & check one of the other links. When I go back instead of seeing my Google results screen again, I have a blank Google screen. Then I have to put my search terms in all over again. This does not happen using Internet Explorer. Thanks for any help

被選擇的解決方法

I've been having the same problem, and looked for help on the Mozillazine.org site. No help there either, but I have found that when you get the blank screen, clicking on REFRESH, brings back the page you want.

Another solution for this issue is available here: https://support.mozilla.org/questions/970863?page=2#answer-485663

Added 'another solution' as per the request of jscher2000

從原來的回覆中察看解決方案 6

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.8 r800
  • Google Update
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.3.133
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

更多資訊

trublupmill 0 個解決方法 1 個答案

有幫助的回覆

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) Double-click the browser.sessionhistory.max_total_viewers preference and change it to 0 (that's a zero).

THIS is the correct answer! Works a treat, very many thanks for sorting out an annoying problem. T.

''(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. ''(2) In the search box above the list, type or paste sess and pause while the list is filtered'' ''(3) Double-click the browser.sessionhistory.max_total_viewers preference and change it to 0 (that's a zero). '' '' THIS is the correct answer! Works a treat, very many thanks for sorting out an annoying problem. T.

由 trublupmill 於 修改

Taiko 0 個解決方法 6 個答案

Been working fine sine I made the change to: browser.sessionhistory.max_total_viewers.

Been working fine sine I made the change to: browser.sessionhistory.max_total_viewers.
noneedtoregistertoaskaquestion 0 個解決方法 6 個答案

This same problem is happening on all my computers, all systems and all browsers and it is even worse in the MSIE, which I never use as it is such a slow junk. I also am disgusted that Google several years ago removed cached text colouration. Google does not seem to care, so I am quickly as I can moving us to DuckDuckGo and Bing.

This same problem is happening on all my computers, all systems and all browsers and it is even worse in the MSIE, which I never use as it is such a slow junk. I also am disgusted that Google several years ago removed cached text colouration. Google does not seem to care, so I am quickly as I can moving us to DuckDuckGo and Bing.
RaceDay 0 個解決方法 1 個答案

To the Mozilla development team: for the love of all that is holy, I would ask that the "browser.sessionhistory.max_total_viewers" tweak be included in the next update of Firefox. I have had the aforementioned problem (Back button leads to a blank Google search) for three months now, and the "browser.sessionhistory" tweak seems to have completely fixed the problem. I don't know who submitted this workaround (jscher2000 perhaps?), but this person deserves a six pack (which I can provide) and even a hug (which someone of the fairer gender can provide).

To the Mozilla development team: for the love of all that is holy, I would ask that the "browser.sessionhistory.max_total_viewers" tweak be included in the next update of Firefox. I have had the aforementioned problem (Back button leads to a blank Google search) for three months now, and the "browser.sessionhistory" tweak seems to have completely fixed the problem. I don't know who submitted this workaround (jscher2000 perhaps?), but this person deserves a six pack (which I can provide) and even a hug (which someone of the fairer gender can provide).
Mr.Handyman 0 個解決方法 6 個答案

Yep, the "browser.sessionhistory" worked for me, also. Thanks to all who came up with this and posted it here. I just wonder how many people have the Back Blank Page problem, and have not found this answer, yet? Could be in the Many-Millions using Firefox.

I would like to add, like "noneedtoregistertoaskaquestion" (Wow, what a name!) had to say about Google removing its Cached Text link. I used this option many times when searching web pages. There is a cached search still available on a limited number of returned search results, and its a little tricky to find and activate it. Why did Google remove such an easy way to search web pages for selected words? But, at least for now, I no longer go Back to a Blank Page. I too, may move away from Google. I just updated another computer, using Internet Explorer, and, Microsoft uses all sorts of tricks to push its Bing search engine. Thanks again for the help here.

Yep, the "browser.sessionhistory" worked for me, also. Thanks to all who came up with this and posted it here. I just wonder how many people have the Back Blank Page problem, and have not found this answer, yet? Could be in the Many-Millions using Firefox. I would like to add, like "noneedtoregistertoaskaquestion" (Wow, what a name!) had to say about Google removing its Cached Text link. I used this option many times when searching web pages. There is a cached search still available on a limited number of returned search results, and its a little tricky to find and activate it. Why did Google remove such an easy way to search web pages for selected words? But, at least for now, I no longer go Back to a Blank Page. I too, may move away from Google. I just updated another computer, using Internet Explorer, and, Microsoft uses all sorts of tricks to push its Bing search engine. Thanks again for the help here.
ajchicago 1 個解決方法 13 個答案

Same thing happened to me recently. Applied the "browser.sessionhistory.max_total_viewers set to zero" fix and all is well. Thanks all!

Same thing happened to me recently. Applied the "browser.sessionhistory.max_total_viewers set to zero" fix and all is well. Thanks all!
jscher2000
  • Top 10 Contributor
8770 個解決方法 71712 個答案

Hi noneedtoregistertoaskaquestion, you wrote:

I also am disgusted that Google several years ago removed cached text colouration. Google does not seem to care, so I am quickly as I can moving us to DuckDuckGo and Bing.

In part, this is a side effect of using a secure connection: Google does not pass the query terms from the HTTPS results page to the cache page to avoid leaking them. If you don't mind a little leakage, I have a Greasemonkey userscript that adds them to the cache link so the highlighting works again.

Google Cache Highlight Search Query Terms for HTTPS

Please be cautious in installing scripts from the site, as recently many scripts have been copied and reposted with code to manipulate your Facebook account.

Hi noneedtoregistertoaskaquestion, you wrote: <blockquote>I also am disgusted that Google several years ago removed cached text colouration. Google does not seem to care, so I am quickly as I can moving us to DuckDuckGo and Bing.</blockquote> In part, this is a side effect of using a secure connection: Google does not pass the query terms from the HTTPS results page to the cache page to avoid leaking them. If you don't mind a little leakage, I have a Greasemonkey userscript that adds them to the cache link so the highlighting works again. [http://userscripts.org/scripts/show/154167 Google Cache Highlight Search Query Terms for HTTPS] ''Please be cautious in installing scripts from the site, as recently many scripts have been copied and reposted with code to manipulate your Facebook account.''
LaughingJohn 0 個解決方法 1 個答案

Post deleted because I was talking rubbish! :)

Post deleted because I was talking rubbish! :)

由 LaughingJohn 於 修改

chromatic 0 個解決方法 2 個答案

The about:config -- And setting browsermaxsession value from the integer -1 to zero (0) -- is the fix.

When typing about:config in browser.. you only need to type in sess

no need to type pause or anything else..

You will see the listed variable about the session,.. you simply make sure it's the right one as listed above, and put a 0 -- and you are done, problem solved.

Funny how we go to such lengths with complicated "work arounds" when the solution is usually something incredibly quick and easy.

Mozilla needs to default this in their future updates... This problem has been annoying me for months -- Thank god someone finally found a fix.

I am in your debt, sir.

The about:config -- And setting browsermaxsession value from the integer -1 to zero (0) -- is the fix. When typing about:config in browser.. you only need to type in sess no need to type pause or anything else.. You will see the listed variable about the session,.. you simply make sure it's the right one as listed above, and put a 0 -- and you are done, problem solved. Funny how we go to such lengths with complicated "work arounds" when the solution is usually something incredibly quick and easy. Mozilla needs to default this in their future updates... This problem has been annoying me for months -- Thank god someone finally found a fix. I am in your debt, sir.
chromatic 0 個解決方法 2 個答案

I have to quote another person here because Mozilla REALLY needs to put this simple fix into their next update.

"To the Mozilla development team: for the love of all that is holy, I would ask that the "browser.sessionhistory.max_total_viewers" tweak be included in the next update of Firefox. I have had the aforementioned problem (Back button leads to a blank Google search) for three months now, and the "browser.sessionhistory" tweak seems to have completely fixed the problem. I don't know who submitted this workaround (jscher2000 perhaps?), but this person deserves a six pack (which I can provide) and even a hug (which someone of the fairer gender can provide). "

If I and others here have had this problem for months.. and the fix is changing the integer from -1 to 0 .. without any other ill results from that change.. I bet Mozilla devs would be making tens of thousands, if not hundreds of thousands or more people who have this same problem and just don't really bother to look for a fix.. or there searches returned no solutions.

Mozilla - Implement "browser.sessionhistory.max_total_viewers set to 0" In update please for all the Firefox users on the planet who use google. Thanks.

I have to quote another person here because Mozilla REALLY needs to put this simple fix into their next update. "To the Mozilla development team: for the love of all that is holy, I would ask that the "browser.sessionhistory.max_total_viewers" tweak be included in the next update of Firefox. I have had the aforementioned problem (Back button leads to a blank Google search) for three months now, and the "browser.sessionhistory" tweak seems to have completely fixed the problem. I don't know who submitted this workaround (jscher2000 perhaps?), but this person deserves a six pack (which I can provide) and even a hug (which someone of the fairer gender can provide). " If I and others here have had this problem for months.. and the fix is changing the integer from -1 to 0 .. without any other ill results from that change.. I bet Mozilla devs would be making tens of thousands, if not hundreds of thousands or more people who have this same problem and just don't really bother to look for a fix.. or there searches returned no solutions. Mozilla - Implement "browser.sessionhistory.max_total_viewers set to 0" In update please for all the Firefox users on the planet who use google. Thanks.
JonathanSKwiat 0 個解決方法 1 個答案

Okay the solution that is at the end of this thread works for me too. The one that starts with about:config int the address bar and then has me swear on my immortal soul that I know what I am doing and goes onto sess in the search and sets -1 to 0.

Two things:

1) Please just include this in future updates.

2) Clean up this thread! Or else repost the solution somehow so that it ranks ahead of this thread in Google. Some of the earlier "solutions" included disabling Google features for crying out loud! Can't this solution go to the top of the thread? I am just glad I found this example in computer software fragility interesting enough that I continued reading the post, especially since hitting the refresh button was highlighted as the solution.

Okay the solution that is at the end of this thread works for me too. The one that starts with about:config int the address bar and then has me swear on my immortal soul that I know what I am doing and goes onto sess in the search and sets -1 to 0. Two things: 1) Please just include this in future updates. 2) Clean up this thread! Or else repost the solution somehow so that it ranks ahead of this thread in Google. Some of the earlier "solutions" included disabling Google features for crying out loud! Can't this solution go to the top of the thread? I am just glad I found this example in computer software fragility interesting enough that I continued reading the post, especially since hitting the refresh button was highlighted as the solution.
Andrew
  • Moderator
321 個解決方法 4047 個答案

JonathanSKwait, I have edited the chosen solution accordingly. Please let me know if there's anything else.

JonathanSKwait, I have edited the chosen solution accordingly. Please let me know if there's anything else.
jscher2000
  • Top 10 Contributor
8770 個解決方法 71712 個答案
Hi feer56, I think the link would be: https://support.mozilla.org/en-US/questions/970863?page=2#answer-485663
Andrew
  • Moderator
321 個解決方法 4047 個答案

My apologies jscher2000.

My apologies jscher2000.
lsanders99 0 個解決方法 5 個答案

The "browser.sessionhistory.max_total_viewers set to 0" works for this diehard XP user also! Many thanks!

The "browser.sessionhistory.max_total_viewers set to 0" works for this diehard XP user also! Many thanks!
Ginger 0 個解決方法 10 個答案

I completely agree! I am getting sooooo tired of Mozilla either passing the buck or expecting the user to come up with ways of working around THEIR problems that they are too busy (read lazy) to fix. The protection shield is another issue that is also driving me insane, having to CONTINUALLY turn it off when I can't use sites properly & frankly, in spite of not liking IE, I'm about ready to give up on Mozilla & go back to using it. It ain't worth the headaches any more!!!

I completely agree! I am getting sooooo tired of Mozilla either passing the buck or expecting the user to come up with ways of working around THEIR problems that they are too busy (read lazy) to fix. The protection shield is another issue that is also driving me insane, having to CONTINUALLY turn it off when I can't use sites properly & frankly, in spite of not liking IE, I'm about ready to give up on Mozilla & go back to using it. It ain't worth the headaches any more!!!
jscher2000
  • Top 10 Contributor
8770 個解決方法 71712 個答案

Hi GingerH, regarding the "protection shield" issue, is this the shield that requires you to approved mixed active content, as described in this article: Mixed content blocking in Firefox

Firefox 25 should remember your instruction to trust a site for as long as your session lasts, i.e., until you fully exit Firefox. But it isn't remembered between sessions, so using that button could be a daily occurrence for you.

If you want to turn the feature off completely, you can do that in the about:config preferences editor. The above article describes why that isn't recommended, but I don't want you to lose your mind, so here are the steps:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste mixed and pause while the list is filtered

(3) Double-click the security.mixed_content.block_active_content preference to switch it from true to false.

You can close the tab now.

If that change doesn't stick, this article might have the explanation: How to fix preferences that won't save.

Hi GingerH, regarding the "protection shield" issue, is this the shield that requires you to approved mixed active content, as described in this article: [[How does content that isn't secure affect my safety?]] Firefox 25 should remember your instruction to trust a site for as long as your session lasts, i.e., until you fully exit Firefox. But it isn't remembered between sessions, so using that button could be a daily occurrence for you. If you want to turn the feature off completely, you can do that in the about:config preferences editor. The above article describes why that isn't recommended, but I don't want you to lose your mind, so here are the steps: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''mixed''' and pause while the list is filtered (3) Double-click the '''security.mixed_content.block_active_content''' preference to switch it from true to false. You can close the tab now. If that change doesn't stick, this article might have the explanation: [[How to fix preferences that won't save]].
05Glide 0 個解決方法 7 個答案

I also use multiple PC's with different versions of Windows and see the same problem on all of them.

It just seems to me this is a Google "knowing what's best for us" issue.

I also use multiple PC's with different versions of Windows and see the same problem on all of them. It just seems to me this is a Google "knowing what's best for us" issue.
Mr.Handyman 0 個解決方法 6 個答案

Hey 05Glide, using your multiple PCs with different Windows versions (and mine have different Firefox versions also) have you noticed the problem seems to come and go. One day, going back to Google search results in blank page. And then the next day, going back works fine, going back to initial search results. I did the change value to 0 fix, and it worked fine for few days, but then went back to blank page. When it does this, I simply Left Click the Back button and select the Google Search I started. After a few times doing this, it seems to stop giving the blank page and goes to working like it used to. I give up.

Hey 05Glide, using your multiple PCs with different Windows versions (and mine have different Firefox versions also) have you noticed the problem seems to come and go. One day, going back to Google search results in blank page. And then the next day, going back works fine, going back to initial search results. I did the change value to 0 fix, and it worked fine for few days, but then went back to blank page. When it does this, I simply Left Click the Back button and select the Google Search I started. After a few times doing this, it seems to stop giving the blank page and goes to working like it used to. I give up.
05Glide 0 個解決方法 7 個答案

I should have mentioned I haven't upgraded FF on one of my PC's., same issue.

To answer your question... No, the problem is the same from one day to another. I can't pin it down to a particular time, FF update etc. (I don't think it's a FF or even a browser issue).

As long as were on the subject of Google, has anyone else noticed Google is now adding it's URL prior to being sent to a site after doing a search and clicking the link? And lately anytime I go to Google [the bookmark is http://www.google.com/], but the address bar shows https://www.google.com/. And no way I'm going to sign-in just to do a search. I've also type just "www.google.com" and it gets changed to https://www.google.comas well. I assume Google will tell us it's some security feature....

I should have mentioned I haven't upgraded FF on one of my PC's., same issue. To answer your question... No, the problem is the same from one day to another. I can't pin it down to a particular time, FF update etc. (I don't think it's a FF or even a browser issue). As long as were on the subject of Google, has anyone else noticed Google is now adding it's URL prior to being sent to a site after doing a search and clicking the link? And lately anytime I go to Google [the bookmark is http://www.google.com/], but the address bar shows https://www.google.com/. And no way I'm going to sign-in just to do a search. I've also type just "www.google.com" and it gets changed to https://www.google.comas well. I assume Google will tell us it's some security feature....