搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Simultaneously, my "Display driver stops responding" & Firefox crashs. Any relationship between these 2 events?

  • 11 回覆
  • 16 有這個問題
  • 17591 次檢視
  • 最近回覆由 boris1959

more options

Every day or two, when I wake my Windows 8 laptop up from the screensaver, the screen stays dark, sometimes for several minutes or so, and then it comes back and displays a message: "Display driver stopped responding and has recovered. Display driver Intel graphics accelerator driver for windowos 8(r) stopped responding and has successfully recovered." After googling it, I see I am far from alone in receiving this message.

But ALSO, when the screen finally does wake up, Firefox has crashed (most of the time).

So what's going on here? Which is the causative problem? Or are they both results of something else? It can't be just coincidence that they occur together, can it?

被選擇的解決方法

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

從原來的回覆中察看解決方案 👍 1

所有回覆 (11)

more options

Try updating your graphics drivers. Faulty, outdated, or corrupt drivers can cause Firefox (and other programs) to crash.

more options

Thanks for that, but I've done that, and it didn't make any difference.

more options

選擇的解決方法

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

Try to disable hardware acceleration in Firefox.

more options

That's terrific! Hardware acceleration disabled. About to restart Firefox. Since this is an intermittent problem, it may be a few days before I know if it works. Thanks very much, have a great weekend, and I'll report back.

more options

That's terrific! Hardware acceleration disabled. About to restart Firefox. Since this is an intermittent problem, it may be a few days before I know if it works. Thanks very much, have a great weekend, and I'll report back.

more options

Well, ... fingers crossed and all, ... but the last few times the graphics accelerator crashed it did not take Firefox with it! Yay! So thanks again, and I'll be back if posting this jinxes it. :^)

more options

I have similar problem. Win7 x64. I tried x64 Firefox (nightly build version) as well as portable PaleMoon x64 (based on v.24 of firefox). In both cases I get "display driver stopped working and recovered" at least once a hour. I have the latest AMD/ATI driver, I switched off hardware accelleration, I also increased TRDdelay in registry to 8sec - nothing helped. I even bought a new video card that had more videoRam - still have a problem. Eventually, after 3-4 crashes of firefox/palemoon my whole system blue-screens. However, I am runnign waterfox x64 portable (based on Firefox v26) and it works just fine. No problems of any sorts, no error messages in a couple of weeks. And the hardware accelleration is turned on. So, obviosuly this does not conclusively prove that something is wrong with Firefox or paleMoon, but for some reason Waterfox solves this issue for me. [I understand that I cannot draw any conclusions on a sample size of 1 :-)]. I hope someone in firefox dev community can figure this out.

Thank you.

--Boris

more options

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.


Do a malware check with some malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.
All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

HI -- Thank you for your advice, but as it turns out all I had to do was to change to screensaver from the default to a simpler one.

more options

Screensaver? That is an easy change. In my case I did not see any obvious correlation since screensaver seemingly was not involved when the problems happened. But stranger things have happened, so I will try this.

Also, I use a couple of programs suggested by co-rel, but will try to run them all (this is a bit more time consuming than chaging screensaver).

Running is safe mod also a bit harder since it runs in low res mode, but I will try that too. I also found out that lowering color from 32 bit to 16 bit makes the problem a touch better - the message/crashes still occur but not nearly as often.

Thanks everyone for your help/suggestions.

--Boris