搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Default search won't work properly

  • 5 回覆
  • 2 有這個問題
  • 5 次檢視
  • 最近回覆由 Yousef

more options

I recently installed iMesh, and it changed my default "new tab" and "search" settings.

I have tried to uninstall the search etc and it still won't work.


I have went through about:config and changed the keyword.url to google and the browser.newtab etc as well, but none of it works. I've been able to remove the new-tab addon from "search-results" and it's back to normal.

My problem is when I'm on the firefox start page, and I type in something, it comes up using the search-results website, instead of google. But as you can see in the troubleshooting information provided below, the keyword.url is set to google, but it won't work for me.

Any ideas?

I recently installed iMesh, and it changed my default "new tab" and "search" settings. I have tried to uninstall the search etc and it still won't work. I have went through about:config and changed the keyword.url to google and the browser.newtab etc as well, but none of it works. I've been able to remove the new-tab addon from "search-results" and it's back to normal. My problem is when I'm on the firefox start page, and I type in something, it comes up using the search-results website, instead of google. But as you can see in the troubleshooting information provided below, the keyword.url is set to google, but it won't work for me. Any ideas?

被選擇的解決方法

It sounds like you have a third party program that has taken over your search engine, home page, and/or the default new tab page. Fortunately, this can be remedied easily:

  1. At the top of the Firefox window, click on the Firefox button (Tools menu in Windows XP), and then click Add-ons. The Add-ons Manager tab will open.
  2. In the Add-ons Manager tab, select the Extensions panel.
  3. Select the toolbar you wish to remove.
  4. Click the remove button.
  5. Click "Restart now" if it pops up. Your tabs will be saved and restored after the restart.

After Firefox restarts, install the Search Reset Tool. This will remove the rest of the traces of this program from your Firefox.

For further information, please read Remove a toolbar that has taken over your Firefox search or home page.

Did this fix the problem? Let us know!

從原來的回覆中察看解決方案 👍 2

所有回覆 (5)

more options

選擇的解決方法

It sounds like you have a third party program that has taken over your search engine, home page, and/or the default new tab page. Fortunately, this can be remedied easily:

  1. At the top of the Firefox window, click on the Firefox button (Tools menu in Windows XP), and then click Add-ons. The Add-ons Manager tab will open.
  2. In the Add-ons Manager tab, select the Extensions panel.
  3. Select the toolbar you wish to remove.
  4. Click the remove button.
  5. Click "Restart now" if it pops up. Your tabs will be saved and restored after the restart.

After Firefox restarts, install the Search Reset Tool. This will remove the rest of the traces of this program from your Firefox.

For further information, please read Remove a toolbar that has taken over your Firefox search or home page.

Did this fix the problem? Let us know!

more options

Thank you very much. Will that addon need to be kept on ? (the search reset)? Or can I remove it afterwards?

My problem is now fixed.

more options

It should have uninstalled itself. If it didn't, you can remove it.

more options

Ok. Well thank you very much, it has now been cleared and everything is back to normal.

Thank you for replying/helping. A mod can now close this.

more options

If the answer has solved your problem, then mark the question as "Solved". This way you will help others in a similar situation.