X
點擊此處開啟此網站的行動版。

技術支援討論區

Yahoo has hijacked my web browser from Firefox and I can't get rid of it.

已張貼

I have tried every way to change it, and my settings say Firefox is still my default browser yet it opens with AT&T/Yahoo as my search engine. I hate AT&T and have eliminated them completely from my life and don't want them as my search engine. I am currently running a virus extractor as I read that could be the problem, but if that doesn't work, any other suggestions?

I have tried every way to change it, and my settings say Firefox is still my default browser yet it opens with AT&T/Yahoo as my search engine. I hate AT&T and have eliminated them completely from my life and don't want them as my search engine. I am currently running a virus extractor as I read that could be the problem, but if that doesn't work, any other suggestions?

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (iPad; CPU OS 6_1_2 like Mac OS X) AppleWebKit/536.26 (KHTML, like Gecko) Version/6.0 Mobile/10B146 Safari/8536.25

更多資訊

Andrew
  • Moderator
322 個解決方法 4071 個答案

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!

Certain Firefox problems can be solved by performing a ''Clean reinstall''. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps: '''Note:''' You might want to print these steps or view them in another browser. #Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer. #After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu). #Delete the Firefox installation folder, which is located in one of these locations, by default: #*'''Windows:''' #**C:\Program Files\Mozilla Firefox #**C:\Program Files (x86)\Mozilla Firefox #*'''Mac:''' Delete Firefox from the Applications folder. #*'''Linux:''' If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see [[Installing Firefox on Linux]]. If you downloaded and installed the binary package from the [http://www.mozilla.org/firefox#desktop Firefox download page], simply remove the folder ''firefox'' in your home directory. #Now, go ahead and reinstall Firefox: ##Double-click the downloaded installation file and go through the steps of the installation wizard. ##Once the wizard is finished, choose to directly open Firefox after clicking the Finish button. Please report back to see if this helped you!
jscher2000
  • Top 10 Contributor
8797 個解決方法 71955 個答案

Firefox has different settings for different search methods:

  • Dedicated search box/search bar (usually on the right end of the Navigation toolbar)
  • URL bar search -- Search the web from the address bar
  • Firefox built-in home page search box

If you have a Yahoo! add-on, it may reset these to Yahoo! every time you restart Firefox, so the first step is to check for that and remove or disable it.

Open the Extensions page using:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

If you find unwanted, unrecognized, or otherwise nonessential extensions, I suggest disabling them, then restarting Firefox. In most cases, you won't miss them.

Next, restoring your preferred search engine depends on what has been changed. I posted about reverting from AVG to Google in the following thread, and I suspect the steps for Yahoo! are basically the same: I need to change the search engine that the Firefox homepage search bar uses.

Any luck?

Firefox has different settings for different search methods: * Dedicated search box/search bar (usually on the right end of the Navigation toolbar) * URL bar search -- [[Search the web from the Address Bar]] * Firefox built-in home page search box If you have a Yahoo! add-on, it may reset these to Yahoo! every time you restart Firefox, so the first step is to check for that and remove or disable it. Open the Extensions page using: orange Firefox button (or Tools menu) > Add-ons > Extensions category If you find unwanted, unrecognized, or otherwise nonessential extensions, I suggest disabling them, then restarting Firefox. In most cases, you won't miss them. Next, restoring your preferred search engine depends on what has been changed. I posted about reverting from AVG to Google in the following thread, and I suspect the steps for Yahoo! are basically the same: [https://support.mozilla.org/en-US/questions/939717 I need to change the search engine that the Firefox homepage search bar uses]. Any luck?
cor-el
  • Top 10 Contributor
  • Moderator
17583 個解決方法 159079 個答案

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

If you do not keep changes after a restart then see:

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes\ If you do not keep changes after a restart then see: *http://kb.mozillazine.org/Preferences_not_saved

由 cor-el 於 修改

提出問題者

Thanks so much for your quick response, although it did not work for me. I will have to wait for my computer wizard son to come over and clean up this mess. I ran a virus extractor because I read that malware was causing the problem, but no luck. Thanks again.

Thanks so much for your quick response, although it did not work for me. I will have to wait for my computer wizard son to come over and clean up this mess. I ran a virus extractor because I read that malware was causing the problem, but no luck. Thanks again.
cor-el
  • Top 10 Contributor
  • Moderator
17583 個解決方法 159079 個答案

What exactly did you do?

Try to use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder

You can try to reset Firefox.

If you reset Firefox then a new profile is created and some of your data (bookmarks, passwords, cookies, form data) is automatically imported and your current profile will be moved to the desktop (Old Firefox Data).

You can recover more data from the old profile (be cautious with doing that).

What exactly did you do? Try to use the SearchReset extension to reset some preferences to the default values. *https://addons.mozilla.org/firefox/addon/searchreset/ Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons). You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder ---- You can try to reset Firefox. *https://support.mozilla.org/kb/reset-firefox-easily-fix-most-problems If you reset Firefox then a new profile is created and some of your data (bookmarks, passwords, cookies, form data) is automatically imported and your current profile will be moved to the desktop (Old Firefox Data). You can recover more data from the old profile (be cautious with doing that). *https://support.mozilla.org/kb/Recovering+important+data+from+an+old+profile

提出問題者

I just couldn't leave it alone so I did more digging and all I ended up needing to do was; in Firefox, go to tools, options, general, home page and change back to Firefox. Still stymied as to why it happened in the first place, but at least I gave my computer a good cleansing!

I just couldn't leave it alone so I did more digging and all I ended up needing to do was; in Firefox, go to tools, options, general, home page and change back to Firefox. Still stymied as to why it happened in the first place, but at least I gave my computer a good cleansing!
Sazerac7 0 個解決方法 2 個答案

有幫助的回覆

My browser was hijacked to switct to Bing. If you have a similar problem, try this:

1- download & run "Hijack This"
2- check to see if there are any entries that mention "sweet" or  "Sweetbacks"  
3- delete any entry that says "sweet" of "sweetback"
4- open browser’s "Settings"
5- open “set pages”
6- delete all entries with "sweet" or "sweetbacks" backs in them
7- check all the browsers listed under "set pages" for malware or just a  
   bad reputation
8- reboot immediately

If sweetbacks was the problem, your browser should be back to normal and it should work the same for all browsers

My browser was hijacked to switct to Bing. If you have a similar problem, try this: 1- download & run "Hijack This" 2- check to see if there are any entries that mention "sweet" or "Sweetbacks" 3- delete any entry that says "sweet" of "sweetback" 4- open browser’s "Settings" 5- open “set pages” 6- delete all entries with "sweet" or "sweetbacks" backs in them 7- check all the browsers listed under "set pages" for malware or just a bad reputation 8- reboot immediately If sweetbacks was the problem, your browser should be back to normal and it should work the same for all browsers

由 Sazerac7 於 修改

iamjayakumars 492 個解決方法 5972 個答案

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

Hello, The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: ''This will cause you to lose any Extensions, Open websites, and some Preferences.'' To Reset Firefox do the following: #Go to Firefox > Help > Troubleshooting Information. #Click the "Reset Firefox" button. #Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish. #Firefox will open with all factory defaults applied. Further information can be found in the [[Reset Firefox – easily fix most problems]] article. Did this fix your problems? Please report back to us! Thank you.
maestro101 0 個解決方法 7 個答案

Hi there,

My firefox has been totally hijacked by yahoo (address bar search, home page etc)

I tried the recommended advice above. I also tried uninstalling the firefox prog and all files. But when I reinstall firefox the address bar search defaults to yahoo .

Can anyone help?

(ps Yahoo if you're reading this.....this kind of highjacking makes me never want to use you again!)

Hi there, My firefox has been totally hijacked by yahoo (address bar search, home page etc) I tried the recommended advice above. I also tried uninstalling the firefox prog and all files. But when I reinstall firefox the address bar search defaults to yahoo . Can anyone help? (ps Yahoo if you're reading this.....this kind of highjacking makes me never want to use you again!)
kobe 441 個解決方法 5048 個答案
  • Click the Firefox button at the top left, then click the Help menu and select Troubleshooting Information from the submenu. If you don't have a Firefox button, click the Help menu at the top and select Troubleshooting Information from the menu.

Now, a new tab containing your troubleshooting information should open.

*Click the Firefox button at the top left, then click the ''Help'' menu and select ''Troubleshooting Information'' from the submenu. If you don't have a Firefox button, click the Help menu at the top and select ''Troubleshooting Information'' from the menu. Now, a new tab containing your troubleshooting information should open. *At the middle of the page, you should see a button that says "Open DIrectory". Click it. * Now a Folder should show, delete any file named user.js * For more info refer to https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save#w_user-js-file-overriding-preferences
maestro101 0 個解決方法 7 個答案

Thanks for recommendation. Have loaded a new tab with troubleshooting information. However I don't see the open "Open Directory" button in the middle of the page.

Thanks for recommendation. Have loaded a new tab with troubleshooting information. However I don't see the open "Open Directory" button in the middle of the page.
kobe 441 個解決方法 5048 個答案

It should say profile directory - Open Directory as shown here

It should say profile directory - Open Directory as shown here
John99 971 個解決方法 13138 個答案

Some users my have actually installed a version of Firefox from Yahoo,if so consider installing an ordinary genuine copy of Firefox instead.

Others with problems with Yahoo or other toolbars and search problems please read this article (and if necessary follow further links from that).

Some users my have actually installed a version of Firefox from Yahoo,if so consider installing an ordinary genuine copy of Firefox instead. * http://www.mozilla.org/en-US/firefox/new/?from=getfirefox *[[Install Firefox on Windows]] **also [[Install Firefox on Mac]], [[Install Firefox on Linux]], [[How do I install Firefox on an Android device?]] Others with problems with Yahoo or other toolbars and search problems please read this article (and if necessary follow further links from that). *[[Remove a toolbar that has taken over your Firefox search or home page]] ** and note the one-off use of <br />https://addons.mozilla.org/en-US/firefox/addon/searchreset/ <br />may help AFTER any software/extensions have been removed
maestro101 0 個解決方法 7 個答案

Thanks again. Apologies I am on a mac so the terminology was a little different. I have read the instructions recommended in your link and gone into my profile folder but there is no file there which says user.js.

And on the link page recommended it mentions:

4. Open the file user.js with a text editor (like TextEdit).

If there is no user.js file, these steps won't help you.
Thanks again. Apologies I am on a mac so the terminology was a little different. I have read the instructions recommended in your link and gone into my profile folder but there is no file there which says user.js. And on the link page recommended it mentions: 4. Open the file user.js with a text editor (like TextEdit). If there is no user.js file, these steps won't help you.
maestro101 0 個解決方法 7 個答案

Thanks again. Apologies I am on a mac so the terminology was a little different. I have read the instructions recommended in your link and gone into my profile folder but there is no file there which says user.js.

And on the link page recommended it mentions:

4. Open the file user.js with a text editor (like TextEdit).

If there is no user.js file, these steps won't help you.

Thanks again. Apologies I am on a mac so the terminology was a little different. I have read the instructions recommended in your link and gone into my profile folder but there is no file there which says user.js. And on the link page recommended it mentions: 4. Open the file user.js with a text editor (like TextEdit). If there is no user.js file, these steps won't help you.
kobe 441 個解決方法 5048 個答案

In order to be able to find the correct solution to your problem, we require some more non-personal information from you. Please do the following:

  • Click the Firefox button at the top left, then click the Help menu and select Troubleshooting Information from the submenu. If you don't have a Firefox button, click the Help menu at the top and select Troubleshooting Information from the menu.

Now, a new tab containing your troubleshooting information should open.

  • At the top of the page, you should see a button that says "Copy text to clipboard". Click it.
  • Now, go back to your forum post and click inside the reply box. Press Ctrl+V to paste all the information you copied into the forum post.

If you need further information about the Troubleshooting information page, please read the article Use the Troubleshooting Information page to help fix Firefox issues.

Thanks in advance for your help!

In order to be able to find the correct solution to your problem, we require some more non-personal information from you. Please do the following: *Click the Firefox button at the top left, then click the ''Help'' menu and select ''Troubleshooting Information'' from the submenu. If you don't have a Firefox button, click the Help menu at the top and select ''Troubleshooting Information'' from the menu. Now, a new tab containing your troubleshooting information should open. *At the top of the page, you should see a button that says "Copy text to clipboard". Click it. *Now, go back to your forum post and click inside the reply box. Press Ctrl+V to paste all the information you copied into the forum post. If you need further information about the Troubleshooting information page, please read the article [[Use the Troubleshooting Information page to help fix Firefox issues]]. Thanks in advance for your help!
maestro101 0 個解決方法 7 個答案

Application Basics

       Name
       Firefox
       Version
       22.0
       User Agent
       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0
       Build Configuration
         about:buildconfig
 Extensions
       Name
       Version
       Enabled
       ID
       Adobe Acrobat - Create PDF
       1.1
       false
       web2pdfextension@web2pdf.adobedotcom
 Important Modified Preferences
     Name
     Value
       browser.cache.disk.capacity
       358400
       browser.cache.disk.smart_size_cached_value
       358400
       browser.cache.disk.smart_size.first_run
       false
       browser.cache.disk.smart_size.use_old_max
       false
       browser.places.smartBookmarksVersion
       4
       browser.startup.homepage_override.buildID
       20130618035212
       browser.startup.homepage_override.mstone
       22.0
       dom.mozApps.used
       true
       extensions.lastAppVersion
       22.0
       gfx.blacklist.webgl.msaa
       4
       network.cookie.prefsMigrated
       true
       places.history.expiration.transient_current_max_pages
       104858
       plugin.disable_full_page_plugin_for_types
       application/pdf
       plugin.importedState
       true
       privacy.sanitize.migrateFx3Prefs
       true
 Graphics
       Device ID
       0x 166
       GPU Accelerated Windows
       10/10 OpenGL
       Vendor ID
       0x8086
       WebGL Renderer
       NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine
       AzureCanvasBackend
       quartz
       AzureContentBackend
       none
       AzureFallbackCanvasBackend
       none
 JavaScript
       Incremental GC
       true
 Accessibility
       Activated
       false
       Prevent Accessibility
       0
 Library Versions
       Expected minimum version
       Version in use
       NSPR
       4.9.6
       4.9.6
       NSS
       3.14.3.0 Basic ECC
       3.14.3.0 Basic ECC
       NSSSMIME
       3.14.3.0 Basic ECC
       3.14.3.0 Basic ECC
       NSSSSL
       3.14.3.0 Basic ECC
       3.14.3.0 Basic ECC
       NSSUTIL
       3.14.3.0
       3.14.3.0
Application Basics Name Firefox Version 22.0 User Agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0 Build Configuration about:buildconfig Extensions Name Version Enabled ID Adobe Acrobat - Create PDF 1.1 false web2pdfextension@web2pdf.adobedotcom Important Modified Preferences Name Value browser.cache.disk.capacity 358400 browser.cache.disk.smart_size_cached_value 358400 browser.cache.disk.smart_size.first_run false browser.cache.disk.smart_size.use_old_max false browser.places.smartBookmarksVersion 4 browser.startup.homepage_override.buildID 20130618035212 browser.startup.homepage_override.mstone 22.0 dom.mozApps.used true extensions.lastAppVersion 22.0 gfx.blacklist.webgl.msaa 4 network.cookie.prefsMigrated true places.history.expiration.transient_current_max_pages 104858 plugin.disable_full_page_plugin_for_types application/pdf plugin.importedState true privacy.sanitize.migrateFx3Prefs true Graphics Device ID 0x 166 GPU Accelerated Windows 10/10 OpenGL Vendor ID 0x8086 WebGL Renderer NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine AzureCanvasBackend quartz AzureContentBackend none AzureFallbackCanvasBackend none JavaScript Incremental GC true Accessibility Activated false Prevent Accessibility 0 Library Versions Expected minimum version Version in use NSPR 4.9.6 4.9.6 NSS 3.14.3.0 Basic ECC 3.14.3.0 Basic ECC NSSSMIME 3.14.3.0 Basic ECC 3.14.3.0 Basic ECC NSSSSL 3.14.3.0 Basic ECC 3.14.3.0 Basic ECC NSSUTIL 3.14.3.0 3.14.3.0
kobe 441 個解決方法 5048 個答案

Have you used the SearchReset addon as John99 said? https://addons.mozilla.org/en-us/firefox/addon/searchreset/

Have you used the SearchReset addon as John99 said? https://addons.mozilla.org/en-us/firefox/addon/searchreset/
maestro101 0 個解決方法 7 個答案

Yes I have. And a big thanks, it's resolved the yahoo issue.

There's only 1 thing that remains which I hope you can shed some light on. When I try a search in the address bar with a world like say 'organised' it defaults me to a optimum.net page instead of a google one:

http://domainnotfound.optimum.net/cablevassist/dnsassist/main/?domain=organised

It reverts me to the optimum.net page for a lot of search words.

Is this normal? I still feel like I'm being hijacked.

Thanks in advance for any light you can shed on this one last issue.

Yes I have. And a big thanks, it's resolved the yahoo issue. There's only 1 thing that remains which I hope you can shed some light on. When I try a search in the address bar with a world like say 'organised' it defaults me to a optimum.net page instead of a google one: http://domainnotfound.optimum.net/cablevassist/dnsassist/main/?domain=organised It reverts me to the optimum.net page for a lot of search words. Is this normal? I still feel like I'm being hijacked. Thanks in advance for any light you can shed on this one last issue.
kobe 441 個解決方法 5048 個答案
  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.
  3. At the top of the page, enter keyword.url , double click the first result and a new window should show. Copy and paste http://www.google.com/search?ie=UTF-8&oe=utf-8&q= in the box in the window.

Refer to

for further details

# In the [[Location bar autocomplete|Location bar]], type '''about:config''' and press '''Enter'''. The about:config "''This might void your warranty!''" warning page may appear. # Click '''I'll be careful, I promise!''', to continue to the about:config page. # At the top of the page, enter '''keyword.url''' , double click the first result and a new window should show. Copy and paste '''http://www.google.com/search?ie=UTF-8&oe=utf-8&q=''' in the box in the window. Refer to * http://kb.mozillazine.org/Location_Bar_Search *http://kb.mozillazine.org/Keyword.url for further details

由 kobe 於 修改