X
點擊此處開啟此網站的行動版。
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

技術支援討論區

Firefox Not Prompting To Remember Passwords

已張貼

Firefox is not saving passwords. It's not even giving me a prompt to save them. Going through support forums, I have already...

Checked Security Settings Checked to ensure Firefox was not in permanent private mode Tested in Safe Mode (problem still persists) Reset Firefox

Firefox is not saving passwords. It's not even giving me a prompt to save them. Going through support forums, I have already... Checked Security Settings Checked to ensure Firefox was not in permanent private mode Tested in Safe Mode (problem still persists) Reset Firefox

被選擇的解決方法

You did also check for problems caused by hardware acceleration?

It is possible that there is a problem with the key3.db and signons.sqlite files that store the encrypted names and passwords in Firefox.
Rename the key3.db and signons.sqlite files in the Firefox profile folder.
You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action.
You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost.
If that has worked then you can remove the renamed files that are no longer needed.

See:


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

You can also try to reset Firefox:

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.5 r502
  • Shockwave Flash 11.4 r402
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • VLC media player Web Plugin 2.0.2
  • 4.1.10329.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

更多資訊

Firefox 17.0.1
Windows 7 SP1
Acer Aspire V3-551

philipp
  • Top 25 Contributor
  • Moderator
5348 個解決方法 23617 個答案

有幫助的回覆

hello Fitzstewart, where is it happening? sites can define that the browser shouldn't save passwords in their source-code, see Usernames and passwords are not saved

you could use an addon like the following to circumvent such restrictions: https://addons.mozilla.org/firefox/addon/remember-passwords

hello Fitzstewart, where is it happening? sites can define that the browser shouldn't save passwords in their source-code, see [[Usernames and passwords are not saved]] you could use an addon like the following to circumvent such restrictions: https://addons.mozilla.org/firefox/addon/remember-passwords

提出問題者

Every and any website where a user name and password is used. It's a universal problem, it has never prompted to save, on any website.

Every and any website where a user name and password is used. It's a universal problem, it has never prompted to save, on any website.

提出問題者

Tried the add on, still no prompt to save passwords

Tried the add on, still no prompt to save passwords
cor-el
  • Top 10 Contributor
  • Moderator
17859 個解決方法 161599 個答案

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy: Use custom settings for history
  • Deselect: [ ] "Always use private browsing mode"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
Make sure that you do not run Firefox in (permanent) Private Browsing mode. *https://support.mozilla.org/kb/Private+Browsing *Tools > Options > Privacy: Use custom settings for history *Deselect: [ ] "Always use private browsing mode" ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do not click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

提出問題者

As stated at the beginning, I've already done those. Repeatedly at this point.

As stated at the beginning, I've already done those. Repeatedly at this point.
cor-el
  • Top 10 Contributor
  • Moderator
17859 個解決方法 161599 個答案

選擇的解決方法

You did also check for problems caused by hardware acceleration?

It is possible that there is a problem with the key3.db and signons.sqlite files that store the encrypted names and passwords in Firefox.
Rename the key3.db and signons.sqlite files in the Firefox profile folder.
You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action.
You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost.
If that has worked then you can remove the renamed files that are no longer needed.

See:


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

You can also try to reset Firefox:

You did also check for problems caused by hardware acceleration? It is possible that there is a problem with the key3.db and signons.sqlite files that store the encrypted names and passwords in Firefox.<br /> Rename the key3.db and signons.sqlite files in the Firefox profile folder.<br /> You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action.<br /> You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost.<br /> If that has worked then you can remove the renamed files that are no longer needed.<br /> See: * "Troubleshooting" in http://kb.mozillazine.org/Password_Manager ---- Create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox You can also try to reset Firefox: *https://support.mozilla.org/kb/Basic+Troubleshooting

提出問題者

Renaming key3.db and signons.sqlite did the trick! FF is now finally saving logon credentials!

Renaming key3.db and signons.sqlite did the trick! FF is now finally saving logon credentials!