搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Frefox keeps using https for a website after a typo

  • 5 回覆
  • 3 有這個問題
  • 2768 次檢視
  • 最近回覆由 johnwerneken

more options

First time I visited a website, I followed a link, which had https instead of http as a protocol. The website is throwing error when I try to access it via https procotoc, so I have to delete the "s" letter manually every time. Even if I type the website name without protocol, Firefox adds https himself throwing me again on the error page.

I tried clearing cache, history, deleting mention of the website in the tips (shift+del after typing part of the url).

被選擇的解決方法

You can try to check the history drop down list of the location bar to see if you can bring up that URL.
If that is the case then highlight that entry and press the Delete key to remove that typo.

Use these steps to remove saved (form) data from a drop down list:

  1. Click the (empty) input field on the web page to open the drop down list
  2. Highlight an entry in the drop down list
  3. Press the Delete key (on Mac: Shift+Delete) to remove it.

You can remove all stored data from a specific domain via "Forget About This Site" in the right-click context menu of an history entry (Show All History or History sidebar) or via the about:permissions page.

Using "Forget About This Site" will remove everything like bookmarks, cookies, passwords, cache, history, and exceptions from that domain, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.
You can't recover from that "forget" unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

從原來的回覆中察看解決方案 👍 3

所有回覆 (5)

more options

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

more options

選擇的解決方法

You can try to check the history drop down list of the location bar to see if you can bring up that URL.
If that is the case then highlight that entry and press the Delete key to remove that typo.

Use these steps to remove saved (form) data from a drop down list:

  1. Click the (empty) input field on the web page to open the drop down list
  2. Highlight an entry in the drop down list
  3. Press the Delete key (on Mac: Shift+Delete) to remove it.

You can remove all stored data from a specific domain via "Forget About This Site" in the right-click context menu of an history entry (Show All History or History sidebar) or via the about:permissions page.

Using "Forget About This Site" will remove everything like bookmarks, cookies, passwords, cache, history, and exceptions from that domain, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.
You can't recover from that "forget" unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

Using "Forget About This Site" helped get rid of the issue, thanks a lot!

more options

Did all of the suggestions above. Nothing did the trick for me. https keeps coming back.

Chrome has the same issue btw...

more options

chrome and fox are almost clones afaik. The untrusted/trusted connection stuff in particular