搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 15 JavaScript Debugger closes immediately

  • 17 回覆
  • 10 有這個問題
  • 576 次檢視
  • 最近回覆由 patrickdw

more options

The new JavaScript debugger in Firefox 15 closes immediately when I try to open it.

The Firefox application does not crash. Just the debugger.

Within a fraction of a second, the bottom of the screen shows and then closes a panel.

I tried disabling all extensions, but it didn't help.

I tried the "Reset Firefox" button, but it didn't help.

Issue is in Firefox 15.0.1 on Ubuntu Linux 12.04 on a Compaq Presario CQ62 that has an AMD processor.

My other Ubuntu 12.04 installation on a Macbook Pro does not have this issue.

被選擇的解決方法

Issue appears to be fixed in Firefox 17.

從原來的回覆中察看解決方案 👍 0

所有回覆 (17)

more options

May be related to this issue. Seems that it's a known bug that has been assigned.

由 patrickdw 於 修改

more options

Did you try to disable your extensions as a test to see if that makes the Debugger work?

more options

Thanks, yes as I noted in my OP, I tried disabling all extensions.

Also tried the "Reset Firefox" button.

Neither worked. I'll give "safe mode" a try.

EDIT: I'm now in "safe mode", and the issue persists.

由 patrickdw 於 修改

more options

The bug report mentions some specific extensions that cause scripts not to get loaded or otherwise interfere.

Your system details list doesn't show any of the extensions mentioned in the bug report, so in your case it might be something different.

Do you see any errors in the Web Developer > Error Console (Ctrl+Shift+J) related to this?

You can hide the usual CSS errors that show up.

more options

Ah yes. I had the wrong console open at first. I had Ctrl+Shift+K.

In the Error console, I get:

09/11/2012 04:50:36 PM

[Exception... "Component returned failure code: 0x80470002 (NS_BASE_STREAM_CLOSED) [nsIOutputStream.write]" nsresult: "0x80470002 (NS_BASE_STREAM_CLOSED)" location: "JS frame :: chrome://global/content/devtools/dbg-transport.js :: DT_onOutputStreamReady :: line 94" data: no]

chrome://global/content/devtools/dbg-transport.js Line: 94

more options

It looks that Firefox is trying to set up for remote debugging.

Do you have any of the devtools.debugger.* prefs set to a user set (i.e. not default) value?

  • devtools.debugger.remote-enabled

由 cor-el 於 修改

more options

I don't believe I have changed any such settings. How would one check that?

I previously had Firebug and YSlow installed. Could it be that one of those would have changed a setting?

I'm checking right now.

由 patrickdw 於 修改

more options

devtools.debugger.remote-enabled is false

I'll look for other remote settings.

All the devtools.debugger settings have the default setting applied.

由 patrickdw 於 修改

more options

Still not working.

My latest attempt was to do the following...

  • sudo apt-get remove firefox
  • mv ~/.mozilla ~/.mozilla_old
  • whereis firefox (and rm -r the found directories)
  • whereis mozilla (and rm -r the found directories)
  • sudo apt-get install firefox

I would think this would give me an entirely clean installation, but it didn't solve the issue.

more options

Did you try to install Firefox from the Mozilla server instead of via the repositories of your Linux distribution?

You can find the latest Firefox release in all languages and for all Operating Systems here:

由 cor-el 於 修改

more options

Good idea. I'll give that a try in the morning. Strange that my other Linux installation works.

more options

Unfortunately, the non-repo Firefox behaved the same way.

Since my MacBook Pro Linux installation works, I have a feeling there must either be some software or driver on this machine causing the issue.

I'm going to install Linux in VirtualBox on this same machine, and see if I experience the same problem.

Thanks for your help thus far!

more options

I can't replicate the issue in another installation.

I've a feeling there's just something deep in the bowels of my Linux install that is fubar'd. I may just need to clean install my system.

more options

I have exactly the same issue on my Windows 7 machine with Firefox 16.0.1. Any leads on how to fix it?

more options

Unfortunately no. I haven't been able to resolve this, and I can't replicate it on another machine, so I've given up.

If you come across a solution, please let me know!

more options

I'm having the same problem in Firefox 16.0.2 on Ubuntu 12.04. Whenever I try to start the debugger the following error appears in the error console.

Timestamp: 11/16/2012 08:39:20 PM Error: [Exception... "Component returned failure code: 0x80470002 (NS_BASE_STREAM_CLOSED) [nsIOutputStream.write]" nsresult: "0x80470002 (NS_BASE_STREAM_CLOSED)" location: "JS frame :: chrome://global/content/devtools/dbg-transport.js :: DT_onOutputStreamReady :: line 94" data: no] Source File: chrome://global/content/devtools/dbg-transport.js Line: 94

more options

選擇的解決方法

Issue appears to be fixed in Firefox 17.