X
點擊此處開啟此網站的行動版。
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

技術支援討論區

The fonts suddenly changed to Italic version...

已張貼

I was just using my computer just like any other day but then the fonts suddenly changed from the normal none-italic to italic, even this question I'm currently typing is in italics. This happened for a few days now but it's getting really irritating... Please help...

I was just using my computer just like any other day but then the fonts suddenly changed from the normal none-italic to italic, even this question I'm currently typing is in italics. This happened for a few days now but it's getting really irritating... Please help...

額外的系統細節

這發生了

每當開啟 Firefox 的時候

問題發生於...

I open up Firefox

已安裝的外掛程式

  • Shockwave Flash 11.3 r300
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • Nexon Game Controller
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • 4.1.10329.0
  • Pando Web Plugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • iTunes Detector Plug-in
  • Unity Player 3.4.1f5
  • NPWLPG
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • Office Live Update v1.3
  • np-mswmp
  • Office Plugin for Netscape Navigator

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

更多資訊

提出問題者

I know a lot of other people also have asked this question but I feel like it's easier for me to understand if told to me

I know a lot of other people also have asked this question but I feel like it's easier for me to understand if told to me
cor-el
  • Top 10 Contributor
  • Moderator
17846 個解決方法 161524 個答案

有幫助的回覆

This can be a problem with the font that is used to display the text.

You can use this extension to see which fonts are used for selected text.

You can do a font test to see if you can identify corrupted font(s).

This can be a problem with the font that is used to display the text. You can use this extension to see which fonts are used for selected text. *fontinfo: https://addons.mozilla.org/firefox/addon/fontinfo/ You can do a font test to see if you can identify corrupted font(s). *http://browserspy.dk/fonts-flash.php?detail=1 *https://support.mozilla.org/kb/Changing+fonts+and+colors
Monty @ DesignRapid.com 0 個解決方法 2 個答案

Yoo can check this by right click and selecting "inspect element" , web pages would be shown as italic if it is set to italic mode in background

(link to blog removed by Moderator)

Yoo can check this by right click and selecting "inspect element" , web pages would be shown as italic if it is set to italic mode in background ''(link to blog removed by Moderator)''

由 cor-el 於 修改

有幫助的回覆

It says "Arial Italic", using the Font Info. add-on, but when I checked my Fonts settings (under Firefox>Options>Content>etc.) there wasn't any font that I chose or chosen by default that is close to being Italic...

It says "Arial Italic", using the Font Info. add-on, but when I checked my Fonts settings (under Firefox>Options>Content>etc.) there wasn't any font that I chose or chosen by default that is close to being Italic...

提出問題者

I right-clicked and didn't see any "Inspect Element"...

I right-clicked and didn't see any "Inspect Element"...
cor-el
  • Top 10 Contributor
  • Moderator
17846 個解決方法 161524 個答案

Firefox 9 doesn't have the inspector.

Any particular reason why you haven't update to the current Firefox 14.0.1 release?

It is important to update to the latest version of Firefox and add-ons to get the latest bug fixes and security updates.


What is the current default font setting?

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"

If you have identified the not working font then you need to reinstall that font.

Firefox 9 doesn't have the inspector. Any particular reason why you haven't update to the current Firefox 14.0.1 release? It is important to update to the latest version of Firefox and add-ons to get the latest bug fixes and security updates. *https://support.mozilla.org/kb/update-firefox-latest-version ---- What is the current default font setting? You can try different default fonts and temporarily disable website fonts to test the selected default font. *Tools > Options > Content : Fonts & Colors > Advanced *[ ] "Allow pages to choose their own fonts, instead of my selections above" If you have identified the not working font then you need to reinstall that font.
pinaar 0 個解決方法 1 個答案

Hi cor-el,

I tried it. That didn't do it for me. I'm using Firefox 15 under Windows 7 and it still changes font sizes randomly while I'm typing an message on the Yahoo webmail interface.

- Art

Hi cor-el, I tried it. That didn't do it for me. I'm using Firefox 15 under Windows 7 and it still changes font sizes randomly while I'm typing an message on the Yahoo webmail interface. - Art
cor-el
  • Top 10 Contributor
  • Moderator
17846 個解決方法 161524 個答案

This thread is not about font sizes, but about a different font being used, in this case an italic font.
If the font size changes then this is more likely caused by coding errors in the Yahoo! text editor or you use the cursor keys and get out of the current size formatting paragraph or span or you are deleting formatting code.

This thread is not about font sizes, but about a different font being used, in this case an italic font.<br /> If the font size changes then this is more likely caused by coding errors in the Yahoo! text editor or you use the cursor keys and get out of the current size formatting paragraph or span or you are deleting formatting code.

提出問題者

Nope, updated my Firefox and the font is still italic, even this reply I'm typing. And thanks for letting me know that there's an update, I wasn't aware. Asking another question here but how can I check which version of Firefox am I using?

Nope, updated my Firefox and the font is still italic, even this reply I'm typing. And thanks for letting me know that there's an update, I wasn't aware. Asking another question here but how can I check which version of Firefox am I using?

提出問題者

It's no long in italic if I uncheck the box "Allow pages to choose their own fonts, instead of my selections above". That is if I use OTHER fonts rather than all the Arial variants, right now I'm using Verdana which I kind of like. But hey, this is the least I could ask for... Thanks for your help!

It's no long in italic if I uncheck the box "Allow pages to choose their own fonts, instead of my selections above". That is if I use OTHER fonts rather than all the Arial variants, right now I'm using Verdana which I kind of like. But hey, this is the least I could ask for... Thanks for your help!
cor-el
  • Top 10 Contributor
  • Moderator
17846 個解決方法 161524 個答案

If it is the Arial font that isn't working properly then you need to reinstall that font.

If it is the Arial font that isn't working properly then you need to reinstall that font.
ishiiboy 0 個解決方法 1 個答案

I'm not sure that the problem is a corrupt font, since all other browsers (Safari and Chrome in my case) appear to display the fonts correctly.

I'm not sure that the problem is a corrupt font, since all other browsers (Safari and Chrome in my case) appear to display the fonts correctly.
Tahoua 0 個解決方法 3 個答案

I had the same problem for over a year. Fonts were fine in Google Chrome but not in Firefox. You might also try MS Word. My Arial font was always italic in MS Word too.

Are you running windows 7 on an HP computer by any chance? It seems this is a common problem on HP computers. If so the probem is most likely an Arial font problem. Your arial font folder probably has the bold and italicis fonts but no longer has the regular font. You need to restore arial.ttf.

Either use your restore disk or get this download from microsoft: http://www.microsoft.com/en-us/download/details.aspx?id=16083

I had the same problem for over a year. Fonts were fine in Google Chrome but not in Firefox. You might also try MS Word. My Arial font was always italic in MS Word too. Are you running windows 7 on an HP computer by any chance? It seems this is a common problem on HP computers. If so the probem is most likely an Arial font problem. Your arial font folder probably has the bold and italicis fonts but no longer has the regular font. You need to restore arial.ttf. Either use your restore disk or get this download from microsoft: http://www.microsoft.com/en-us/download/details.aspx?id=16083