X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox does not play netflix

已張貼

Firefox used to play netflix. Now it doesn't. Chrome plays netflix. Silverlight current. What's up?

Firefox used to play netflix. Now it doesn't. Chrome plays netflix. Silverlight current. What's up?

被選擇的解決方法

We're still trying to nail down this issue but I'm pretty sure if you run Firefox in 32-bit mode, Netflix will work. To do that:

  1. Quit Firefox. Go to the Firefox menu and select Quit.
  2. Open your Applications folder
  3. Find Firefox in the Applications folder and click it once to select it. Then press command + i on your keyboard. An information window will open up.
  4. In the Firefox information window, check the box next to Open in 32-bit mode
  5. Close the info window and restart Firefox
從原來的回覆中察看解決方案 4

額外的系統細節

這發生了

每當開啟 Firefox 的時候

問題發生於...

Firefox was updated

已安裝的外掛程式

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Facebook Video Calling by Skype
  • Octoshape Streaming Services web integration browser plug-in
  • Shockwave Flash 11.1 r102
  • 5.0.61118.0
  • Java Plug-In 2 for NPAPI Browsers
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Coupons Inc., Coupon Printing FireFox Plugin
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • npmnqmp 071706000001
  • DivX Web Player version 2.0.0.263
  • iPhoto6

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

更多資訊

Michael Verdi 128 個解決方法 857 個答案

選擇的解決方法

We're still trying to nail down this issue but I'm pretty sure if you run Firefox in 32-bit mode, Netflix will work. To do that:

  1. Quit Firefox. Go to the Firefox menu and select Quit.
  2. Open your Applications folder
  3. Find Firefox in the Applications folder and click it once to select it. Then press command + i on your keyboard. An information window will open up.
  4. In the Firefox information window, check the box next to Open in 32-bit mode
  5. Close the info window and restart Firefox
We're still trying to nail down this issue but I'm pretty sure if you run Firefox in 32-bit mode, Netflix will work. To do that: #Quit Firefox. Go to the Firefox menu and select Quit. #Open your Applications folder #Find Firefox in the Applications folder and click it once to select it. Then press command + i on your keyboard. An information window will open up. #In the Firefox information window, check the box next to '''Open in 32-bit mode''' #Close the info window and restart Firefox

有幫助的回覆

That did it! Thanks so much.

That did it! Thanks so much.
janehere 0 個解決方法 6 個答案

有幫助的回覆

I have the same problem with Firefox 9.0.1 and Silverlight.plugin 5.0.61118.0. But I can play Netflix OK with Safari, which I don't use otherwise. I'd rather not change the settings in Firefox since I have no idea what bits are or how the change would affect other sites. Is this going to get fixed in Firefox? Anytime soon?

I have the same problem with Firefox 9.0.1 and Silverlight.plugin 5.0.61118.0. But I can play Netflix OK with Safari, which I don't use otherwise. I'd rather not change the settings in Firefox since I have no idea what bits are or how the change would affect other sites. Is this going to get fixed in Firefox? Anytime soon?

由 janehere 於 修改

CaptHuffnpuff 0 個解決方法 3 個答案

Some additional info:

This is what I've discovered. It does seem to be related to Firefox 9.0.1 64 bit mode but add-ons do not seem to be the problem.

(MAC OS X 10.6.8, Snow Leopard)

Safari 5.0.1 (latest release) does work with Silverlight 5.06.61118.0. (All extensions turned off; I only use Safari when a site doesn't work with my Firefox setup)

NETFLIX does NOT work with Firefox 9.0.1 and Silverlight 5.06.61118.0 in 64 bit mode even when I disabled all the add-ons including Ghostery, Add-block, Flash Block.

It does work in 9.0.1 in 32 bit mode with all add-ons enabled.

I reinstalled 8.0.1 (auto update turned OFF) from my old Firefox 8 DMG and it works both in 64 and 32 bit mode, all add-ons enabled.

In each case I had pop-up blocker turned off. I accept all cookies. The only exceptions to Ghostery are Twitter and Facebook.

Some additional info: This is what I've discovered. It does seem to be related to Firefox 9.0.1 64 bit mode but add-ons do not seem to be the problem. (MAC OS X 10.6.8, Snow Leopard) Safari 5.0.1 (latest release) does work with Silverlight 5.06.61118.0. (All extensions turned off; I only use Safari when a site doesn't work with my Firefox setup) NETFLIX does NOT work with Firefox 9.0.1 and Silverlight 5.06.61118.0 in 64 bit mode even when I disabled all the add-ons including Ghostery, Add-block, Flash Block. It does work in 9.0.1 in 32 bit mode with all add-ons enabled. I reinstalled 8.0.1 (auto update turned OFF) from my old Firefox 8 DMG and it works both in 64 and 32 bit mode, all add-ons enabled. In each case I had pop-up blocker turned off. I accept all cookies. The only exceptions to Ghostery are Twitter and Facebook.

由 CaptHuffnpuff 於 修改

CaptHuffnpuff 0 個解決方法 3 個答案

Firefox 10 seems to have solved the Netflix problem with Silverlight 5.06.61118.0. on OS X Lion 7.2.

Firefox 10 seems to have solved the Netflix problem with Silverlight 5.06.61118.0. on OS X Lion 7.2.
justanotherokie 0 個解決方法 1 個答案

Problem was solved by disabling FlashBlock Addin.

Netflix provided black screen.

Installed new Silverlight to no avail.


Firefox Mac 10.0.2 Silverlight Plugin 5.0.6.1118.0

'''Problem was solved by disabling FlashBlock Addin.''' Netflix provided black screen. Installed new Silverlight to no avail. Firefox Mac 10.0.2 Silverlight Plugin 5.0.6.1118.0
blewvelvet 0 個解決方法 2 個答案

That 32 bit mode...used to work..up till a few days ago. I updated to Firefox 13.01. I installed Silverlight...didn't help.

I get this page from Netflix (see attached) when I try to click on any movie. Safari doesn't have this problem.


Also..I've lost the use of the Open New TAB button on my toolbar..among other toolbar buttons.

That 32 bit mode...used to work..up till a few days ago. I updated to Firefox 13.01. I installed Silverlight...didn't help. I get this page from Netflix (see attached) when I try to click on any movie. Safari doesn't have this problem. Also..I've lost the use of the Open New TAB button on my toolbar..among other toolbar buttons.
Skeptical Bright 0 個解決方法 17 個答案

I was having the same problems with Silverlight on Lion 10.7.4. Within the last few weeks, when I tried Netflix it said the plugin was down level and directed me to the site to download the DMG. I now have Silverlight at

"Sliverlight Plug-in 5.1.10411.0"

and I am not having any problems with Netflix.

Firefox 13.0.1, MacBook Air (mid 2012), Lion OS X 10.7.4

I was having the same problems with Silverlight on Lion 10.7.4. Within the last few weeks, when I tried Netflix it said the plugin was down level and directed me to the site to download the DMG. I now have Silverlight at "Sliverlight Plug-in 5.1.10411.0" and I am not having any problems with Netflix. Firefox 13.0.1, MacBook Air (mid 2012), Lion OS X 10.7.4