搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

New FF4 install, back/forwards and refresh buttons not working - help!

  • 6 回覆
  • 49 有這個問題
  • 5 次檢視
  • 最近回覆由 fermat

more options

Since new install of FF4.0 the back/forward and refresh buttons have been unoperational. They do not function.

I have tried:

restarting reinstalling starting in safe mode removing places.sqlite and restarting

All to no avail. Any ideas anyone?

Since new install of FF4.0 the back/forward and refresh buttons have been unoperational. They do not function. I have tried: restarting reinstalling starting in safe mode removing places.sqlite and restarting All to no avail. Any ideas anyone?

被選擇的解決方法

Create a new profile as a test to check if your current profile is causing the problems. See:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins"

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)
See:


If that doesn't help then do a clean reinstall.

  • Uninstall your current Firefox version and remove the Firefox program folder before installing that copy of the Firefox installer.
  • Do not remove personal data if you uninstall the current version.
  • It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.

Your bookmarks and other profile data are stored elsewhere (not in the Firefox program folder) and won't be affected by a reinstall, but make sure that you do not select to remove personal data if you uninstall Firefox.

從原來的回覆中察看解決方案 👍 1

所有回覆 (6)

more options

選擇的解決方法

Create a new profile as a test to check if your current profile is causing the problems. See:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins"

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)
See:


If that doesn't help then do a clean reinstall.

  • Uninstall your current Firefox version and remove the Firefox program folder before installing that copy of the Firefox installer.
  • Do not remove personal data if you uninstall the current version.
  • It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.

Your bookmarks and other profile data are stored elsewhere (not in the Firefox program folder) and won't be affected by a reinstall, but make sure that you do not select to remove personal data if you uninstall Firefox.

more options

Bingo! Creating a new profile has done the trick. I need to move stuff over from the old profile now, but with the new profile the buttons are active as expected.

Thank you for your help, it is much appreciated.

more options

I'm finding that Firefox is one step behind with the URL so initially, when I first fire up my broswer, I get 'go to a website' where the URL usually is, plus no functionality with the back/forwards and refresh. If I then load a second site, it gives me the URL of the previous site. Weirdly, refreshing the page does not update the URL.

more options

Try going to about:config and change browser.sessionhistory.max_entries 0 to browser.sessionhistory.max_entries 999

more options

Spot on cor-el. New profile worked a treat on XP.

(Did some experimenting and found that copying either pluginreg.dat or prefs.js recreated the problem.)