搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 4 no longer displays "Arial Black" as a font-family in CSS.

  • 10 回覆
  • 204 有這個問題
  • 44 次檢視
  • 最近回覆由 gojsse

more options

Example line in CSS: font-family: "Arial Black",Gadget,sans-serif; after upgrading to FF4 no longer displays as Arial Black now it displays as Arial.

Example line in CSS: font-family: "Arial Black",Gadget,sans-serif; after upgrading to FF4 no longer displays as Arial Black now it displays as Arial.

所有回覆 (10)

more options

There's a similar thread here: http://support.mozilla.com/bs/questions/795314

more options

I have found some what of a fix. I went into about:config and set gfx.direct2d.disable to true and arial black showed back up in FF using that font right now. Also forgot to say Im using the 64 bit 10.0a1 nightly release

由 eman17j 於 修改

more options

You need to add font-weight:900 to make Firefox use Arial Black

  • bug 644385 – Arial Narrow, Arial Black fonts do not show on page (comment 8)
more options

I realize I have to add font-weight... but this is not a solution and they continue not to properly fix it. There have been several generations of Firefox with this bug now, without a fix... almost ready to leave for Chrome.

more options

The problem is that in Window 7 the Arial fonts are placed in one Arial font group and you need extra selectors to select a specific member in that group or Firefox chooses the first member in that group. The same happens for other fonts that are placed in their own group.

more options

Interesting, but Firefox still has that bug then and have neglected to update their broken code. More and more typography houses are doing what you describe because of the nature of opentype. Will Firefox ignore them as well? Still not a solution and wish FF would solve it.

more options

I did not need to add font weight or anything to make arial black show up. It showed up when I set gfx.direct2d.disable to true. I did not add any font weight or anything else. And I over ride web fonts and use my own fonts in web pages and I am using arial black and have not set font weight to 900

more options

eman17j: I think your solution is fine for you but I cannot give these instructions to everyone that views a site that my company creates. This remains a bug in FF that they are unwilling to fix.

more options

quit using arial black then

more options

You can always make a new @font-face property. Try font-squirrel and upload arial black. It will add about 50k of weight to your page though and isn't the best workaround.