搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Suddenly today, on youtube, I have audio but no video

  • 11 回覆
  • 237 有這個問題
  • 14 次檢視
  • 最近回覆由 stomperz

more options

Suddenly after Firefox updated this evening, the video on youtube clips is black. The audio part remains perfect but the film does not start. The clip screen remains black.

所有回覆 (11)

more options

Go to control panel ,display,settings advance,troubleshoot, then turn off harware acceleration.........Then close your browser and you should be back to normal....................

more options

Uh, Beatles, while any "work-around" is appreciated, turning off hardware acceleration is hardly "back to normal"!

I tried it, and it worked, but keeping hardware acceleration turned off is NOT a SOLUTION!

I would like to know what Firefox did to screw up youtube viewing again.

If they are going to do this, they should have a setting which puts us in a compatibility mode for youtube ONLY.

For other information, all other Flash sites seem to work fine, including viewing Hulu videos. It's just youtube, which has sound but no video.

Anyone know what can be done to actually fix this issue?

more options

Problem is related to Flash and Video drivers. Try updating your video drivers first of all.

As a temporary workaround try hovering your cursor over the place where the pop-out button should be below the YouTube video screen, then left click there. The video will then display in the pop-out screen.

more options

The problem started after the last Firefox automatic update.

Prior to that I had installed the latest Adobe Flash and all was well.

It is on Firefox's end.

More and more firefox is like a virus on my computer. Sometimes I have to go to task manager to turn it truly off, as too many times it just wants to hang around. My computer is clean regarding viruses or malware. It is the Firefox itself.

Never thought I'd say it, but it looks like it is time to try Chrome or some other browser.

Coigach, thanks for the workaround. It does work and is better than nothing.

But really, at this stage of the game should something like this even be an issue?

I used IE 8 for the first time in a while to access YouTube with no problems today.

Maybe Firefox has had its day, has had its run.

more options

BoutDone, you have a good point, that at this stage something like this shouldn't even be an issue.

But you know what's even more astonishing? Firefox had an almost identical problem a couple of years ago! It hammered Youtube playback during an upgrade, which cookies would fix temporarily but you couldn't sign in. It wasn't such a big problem back then because I didn't have any videos of my own, so I almost forgot it.

But now, the problem is back. There's no way this should have come back, with mozilla's experience at the game.

Shame.

more options

I found this in a google search:

http://www.google.com/support/forum/p/youtube/thread?tid=55e53fe4230a7935&hl=en

When you're at the last stage in exceptions you click block.

This does allow you to watch videos on YouTube without using the pop-out workaround above.

However, you can't log in if you have an account there.

I'll be using IE 8. Thought to post what I found.

more options

It seems like all the work-arounds are temporary fixes. Someone else suggested to clear cookies & cache, which I did, and that solved the problem. Then, this morning, Firefox did another automatic "upgrade" and now again, I cannot see the youtube videos. I'm tired of this. I agree with others that Firefox is causing the problem and is experienced enough to know how to fix it without causing everyone else inconvenience. To have to re-sign in to all my sites every single day? No thanks, Firefox.

more options

its not a settings problem its a 3.6.15 problem the work around is get rid of it ! go back to 3.6.12 (google and you can find sites with free download) or use another browser until someday when mozill fixes this once great browser (hopefully will be fixed before cows learn to fly)

more options

just get older version (flash player) than 10.2.152.32 I tried withe 10.1.102.64 and the problem Dissolved to get older version go to (http://kb2.adobe.com/cps/142/tn_14266.html)

由 mozillame 於 修改

more options

ITS NOT FIREFOX THAT IS THE PROBLEM! Its the adobe flash update! I hadn't updated my Firefox when this problem happened to me. I updated after to try and fix it. Then I saw mozillame's post, I felt kind of silly for not thinking about this..okay a lot silly! Just follow the directions in mozillame's post and it will work great again. Also on one last note just in case, remember to use adobe's uninstall program they tell you about first thing. Great job mozillame!

Cheers and laughs to all you good folks!

more options

I have just experienced this - YouTube Audio fine but absolutely no picture. I tried many of the suggestions re hardware acceleration, older flash players, update drivers etc but no joy. This morning I tried advice from http://support.mozilla.com/en-US/questions/713600

I did the about:config; search dom.ipc and changed dom.ipc.plugins.enabled to false

My Firefox and youtube is now fine. I wish I had found that link first!!