Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

FF not showing table border style

  • 7 回覆
  • 38 有這個問題
  • 1 次檢視
  • 最近回覆由 cbrundage

more options

I have a webpage with css table border style dotted. It shows up in IE but there is just a line around the table in FF. Is there a way to make it show up? Many thanks.

table.mytable { border-width: 6px; padding: 15px; border-style: dotted; border-color: #88aa96;}

I have a webpage with css table border style dotted. It shows up in IE but there is just a line around the table in FF. Is there a way to make it show up? Many thanks. table.mytable { border-width: 6px; padding: 15px; border-style: dotted; border-color: #88aa96;}

被選擇的解決方法

^ Good catch. There's another spurious closing bracket 6 lines below the one you found.

background-color:#e8e5da;}

從原來的回覆中察看解決方案 👍 1

所有回覆 (7)

more options

It looks like only IE8 reads your code for that border. Firefox, Opera, Chromium, and Safari don't get it. Browsers display the authors intentions better when the coding used is valid.
http://validator.w3.org/check?uri=http://www.cbrundage.net/cleeve/nature.htm
Browsers are displaying that page in the Quirks Mode.
http://en.wikipedia.org/wiki/Quirks_Mode

See this for help with the code you are using.
http://www.w3.org/TR/CSS2/box.html#border-properties

If you need more help with that issue, try posting at the Web Development / Standards Evangelism forum at MozillaZine. The helpers over there are more knowledgeable about web page development issues with Firefox.
http://forums.mozillazine.org/viewforum.php?f=25
You'll need to register and login to be able to post in that forum.

more options

You have a spurious } in your CSS code, just remove that line and it should work.

a:hover {color:#E1E0AF}
}
table.mytable {


a:hover {color:#E1E0AF}

table.mytable {
more options

選擇的解決方法

^ Good catch. There's another spurious closing bracket 6 lines below the one you found.

background-color:#e8e5da;}

more options

That is not a spurious } , but a needed one to end that rule.

table.mytable {
 border-width: 6px;
 padding: 15px;
 border-style: dotted;
 border-color: #88aa96;
 background-color:#e8e5da;
}

.back td{
 background-color:#e8e5da;
}

img#bg { .... }
more options

Thank you all so much! That solved the problem - I really thought it was a browser problem!!! Christina

more options

You need that } after background-color:#e8e5da;

By removing it you introduced another error:

Warning: Expected declaration but found '.'. Skipped to next declaration. Source File: http://www.cbrundage.net/cleeve/nature.htm Line: 33


table.mytable {
border-width: 6px;
	padding: 15px;
	border-style: dotted;
	border-color: #88aa96;
	background-color:#e8e5da; /* missing } /*

.back td{background-color:#e8e5da;
	}

Instead of background-size you probably mean background-position:

Warning: Unknown property 'background-size'. Declaration dropped. Source File: http://www.cbrundage.net/cleeve/nature.htm Line: 15


background-attachment:fixed; background-size: 100% 100%;
more options

I put the "}" back but it had worked anyway and the background stayed fixed too. But thank you for getting my coding fixed! I really appreciate it. Christina