搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Tried downloading Firefox 4 beta for Tiger 10.4. saved to applications but then Firefox would not open! Had to remove and re-laod Firefox 3.6.

more options

Is anyone having problems getting Firefox 4beta to work on Tiger?

This happened

Every time Firefox opened

Downloaded beta Firefox 4

User Agent

Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_4_11; en) AppleWebKit/533.16 (KHTML, like Gecko) Version/4.1 Safari/533.16

所有回覆 (9)

more options

click Firefox, no response, even crashed my laptop once.

same agent info

more options

Firefox Beta 4 is not compiled properly for Tiger, and refuses to start up because it expects a leopard library:

Symbol not found: _open$UNIX2003

 Referenced from: /Applications/Firefox.app/Contents/MacOS/libnspr4.dylib
 Expected in: /usr/lib/libSystem.B.dylib

A possible solution, posted somewhere on the net, is to pass this option on compile: -mmacosx-version-min=10.4

In addition to linking against the 10.4 sdk

Hope this helps!

more options

Would have appreciated if the system requirements were updated. It's saying it works on tiger but apparently, it does not work!

more options

please make the final version compatible with Tiger... there's still a big bunch of us still using the most stable OS ever.

more options

Agreed - many machines out there in use limited to Tiger OS / 10.4.

Please compile with flags set for 10.4 !!!!!

in interim, can the sys requirements be updated?

Best of luck and thanks for great job - running great on my Leopard PPC.

more options

Tiger please!!!

more options

Indeed please update the system requirements link which links to the current release version system requirements page (v3.6.6).

http://www.mozilla.com/en-US/firefox/4.0b1/releasenotes/

And please, if at all possible compile for 10.4.11

more options

See: Bug 577256 – all-beta claims Firefox 4 is compatible with MacOS 10.4+, should say 10.5+ Bug 577290 – We need a system requirements page for ff4.0b1

(please do not comment in bug reports)

more options

+1 for 10.4.11 PPC support (for final, stable release)

edit: even though it looks grim https://bugzilla.mozilla.org/show_bug.cgi?id=577290#c3