搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox keeps asking to reinstall. It fails to check for updates. I have Windows 11 and Firefox 124.0.2

  • 2 回覆
  • 1 有這個問題
  • 最近回覆由 Paul

more options

I have Windows 11 and Firefox 124.0.2. Firefox keeps asking to reinstall. I think it is because I keep getting the message that it fails to check for updates. I don't know if I have installed the Microsoft Firefox or the direct Mozilla Firefox downloaded. Maybe that is the problem, but I am not tech savvy. I have used Firefox for many years and like it. I am also too old (83) to deal with these problems. Help!

I have Windows 11 and Firefox 124.0.2. Firefox keeps asking to reinstall. I think it is because I keep getting the message that it fails to check for updates. I don't know if I have installed the Microsoft Firefox or the direct Mozilla Firefox downloaded. Maybe that is the problem, but I am not tech savvy. I have used Firefox for many years and like it. I am also too old (83) to deal with these problems. Help!

所有回覆 (2)

more options

Hey Tom! Thanks for reporting this. It's not your fault but appears to be caused by NordVPN. You might have this program installed. If you do, you need to disable a feature it uses called "Web Protection".

Thanks for making us aware of your age & I hate to make you fiddle with options!

But if you could try to follow this screenshot, you will find the area you need to turn off Web Protection: https://i.imgur.com/UshEkTL.png

I apologize if your NordVPN does not look exactly like the above photo. They constantly redesign and change the look of their program. So try to focus on just finding the words "Threat Protection" and "Web Protection".

Step by step instructions:

  • Open the NordVPN program (The desktop shortcut will be similar to this: Screenshot)
  • Click on the Shield icon on the left side of the program
  • You should be in a area called "Threat Protection"
  • Click the circle button on Threat Protection to turn it off
  • If there's a circle button on Web Protection, click it as well to turn it off
  • If a popup box appears saying "Reconnect to VPN to apply Settings", click the Reconnect button
  • Open Firefox & look to see if anymore update errors appear

Please let us know if this fixed your problem. Apologies in advance if you do not have NordVPN installed.


Credit to who solved this issue A user reported NordVPN was blocking Firefox updates since March 23rd: https://www.reddit.com/r/firefox/comments/1bly9xz/firefox_suddenly_unable_to_auto_update/ Solution: "Figured it out. When NordVPN "Web Protection" is on, it fails to check for updates from the About menu as well. When "Web Protection" is off, it correctly checks for updates. I surmise that when Firefox fails to check, it assumes that I need an update and gives the original annoying message."

有幫助嗎?

more options

Hi

We believe that NordVPN have fixed their Web Protection feature and you should find that if you turn this back on, the issue is now resolved.

If you find that it is still not working correctly, please let us know and we can try to follow up with NordVPN.

Thank you.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題