搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

500 undefined

  • 14 回覆
  • 1 有這個問題
  • 73 次檢視
  • 最近回覆由 Sue

more options

I went to Finance.Yahoo.com to try to look up a fund. After I enter any fund symbol, I get consistently "500 undefined". I used Safari with no problems. Why is Firefox doing this and how to get around this? Thanks.

I went to Finance.Yahoo.com to try to look up a fund. After I enter any fund symbol, I get consistently "500 undefined". I used Safari with no problems. Why is Firefox doing this and how to get around this? Thanks.

所有回覆 (14)

more options

What locale does this Yahoo website detect in case this detected locale isn't supported? You can try to select a different locale/language.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings), click the padlock icon (Clear cookies and site data) for the domain in the selected tab.

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages like blocked content.

有幫助嗎?

more options

Thanks, cor-el. I do not know what the "locale" is, but what 's strange is that the home page comes up. However, as soon as I enter a ticker symbol, I get the 500 error message.

I checked (and turned off and on) the Enhanced Tracking Protection, but it didn't make any difference.

The rest is too much for me. I will take the easy way out and use Safari. Hopefully someone else will figure this out and fix it.

有幫助嗎?

more options

It would be helpful to provide the symbol...

有幫助嗎?

more options

Sure. I used VDIGX, VGHCX and a few others. It happens with each that I tried with Firefox.

有幫助嗎?

more options

Does it still happen in a private window (Command+Shift+P)?

Does it still happen in Troubleshoot Mode?

有幫助嗎?

more options

Thanks, zeronight. Yes, it does happen in troubleshoot mode.

However, now I am more confused than before. First time I tried today, I didn't get the error message. Then the error was displayed as soon as I entered finance.yahoo.com.

有幫助嗎?

more options

Only issue for me with Yahoo was a maxed out cpu, but the vanguard pages work for me. see screenshots

有幫助嗎?

more options

Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection" and in Connection Settings change "Use system proxy settings" to "No proxy".

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

有幫助嗎?

more options

I appreciate you spending time trying to help, zeroknight. However, most people are not at your or cor-el's "level". I am just a plain, old, end user and want to use software that works, not to debug it and fix it. What some of you experts mentions many times is way above my head and not useful. Lately I have been using Safari and that works, no problems. If and when Firefox fixes the issues, I might return. Sorry, neither do I have the time, ambition nor the know-how for doing what you suggest. Everybody is not a software expert and it SHOULD NOT be. Thanks, regardless.

有幫助嗎?

more options

What is the first of the preferred languages for webpages?

The second language setting in Settings is about the preferred languages for webpages.

有幫助嗎?

more options

I am sorry, cor-el, what exactly are you looking for? The first language is English. Why are you asking?

有幫助嗎?

more options

Some websites only support a limited set of languages for their appearance and try to provide you with button labels in your preferred language, if this preferred language isn't supported then you can see errors.

Did you try to start Firefox in Troubleshoot Mode? Try to start Firefox in Troubleshoot Mode to see if that works.

Do you have extensions installed that could be causing problems?

有幫助嗎?

more options

Cor-el, you are really trying to help and I appreciate it. I do not have extensions causing problems. I gave up on this website with Firefox. I do not have what it takes to to do what you suggest. As I said, Safari does the job. Maybe the next update will help.

有幫助嗎?

more options

I cleared the cache (and lost cookies I would have liked to keep). For a few hours Yahoo worked as expected. Now it went back to the 500 error. I am mentioning it in case this helps someone fix the problem.

This version of Firefox has plenty of bugs. After clearing the cache I had major very strange issues logging back into Comcast email.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題