搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 119 doesn’t use system (/usr/share/fonts) or user’s (~/.local/share/fonts) fonts for rendering

  • 5 回覆
  • 0 有這個問題
  • 86 次檢視
  • 最近回覆由 zeroknight

more options

I use Kubuntu 23.04 with Firefox from mozillateam/ppa apt repository, got update to FF 119 today (package 119.0+build1-0ubuntu0.23.04.1~mt1) and after the update Firefox stopped using system-wide installed fonts (either from /usr/share/fonts or from ~/.local/share/fonts).

So for example fc-list finds Gentium Plus (/usr/share/fonts), Iosevka and Junicode (~/.local/share/fonts) on my system: % fc-list -f '%{family}: %{file}\n' | rg -i 'gentium plus:' Gentium Plus: /usr/share/fonts/truetype/gentiumplus/GentiumPlus-Italic.ttf Gentium Plus: /usr/share/fonts/truetype/gentiumplus/GentiumPlus-BoldItalic.ttf Gentium Plus: /usr/share/fonts/truetype/gentiumplus/GentiumPlus-Bold.ttf Gentium Plus: /usr/share/fonts/truetype/gentiumplus/GentiumPlus-Regular.ttf % fc-list -f '%{family}: %{file}\n' | rg -i 'iosevka:' Iosevka: /home/silmeth/.local/share/fonts/iosevka/iosevka.ttc Iosevka: /home/silmeth/.local/share/fonts/iosevka/iosevka.ttc Iosevka: /home/silmeth/.local/share/fonts/iosevka/iosevka.ttc Iosevka: /home/silmeth/.local/share/fonts/iosevka/iosevka.ttc % fc-list -f '%{family}: %{file}\n' | rg -i 'junicode:' Junicode: /home/silmeth/.local/share/fonts/junicode/otf/Junicode-Bold.otf Junicode: /home/silmeth/.local/share/fonts/junicode/otf/Junicode-Regular.otf Junicode: /home/silmeth/.local/share/fonts/junicode/otf/Junicode-Italic.otf Junicode: /home/silmeth/.local/share/fonts/junicode/otf/Junicode-BoldItalic.otf

but when I try to apply the style `font-family: Gentium Plus`, `font-family: Iosevka`, or `font-family: Junicode` to an element, Firefox doesn’t use those fonts and instead in the element inspector I see Noto Serif is being used instead.

Before the update the appropriate system fonts were being chosen for rendering by Firefox.

I use Kubuntu 23.04 with Firefox from mozillateam/ppa apt repository, got update to FF 119 today (package 119.0+build1-0ubuntu0.23.04.1~mt1) and after the update Firefox stopped using system-wide installed fonts (either from /usr/share/fonts or from ~/.local/share/fonts). So for example fc-list finds Gentium Plus (/usr/share/fonts), Iosevka and Junicode (~/.local/share/fonts) on my system: % fc-list -f '%{family}: %{file}\n' | rg -i 'gentium plus:' Gentium Plus: /usr/share/fonts/truetype/gentiumplus/GentiumPlus-Italic.ttf Gentium Plus: /usr/share/fonts/truetype/gentiumplus/GentiumPlus-BoldItalic.ttf Gentium Plus: /usr/share/fonts/truetype/gentiumplus/GentiumPlus-Bold.ttf Gentium Plus: /usr/share/fonts/truetype/gentiumplus/GentiumPlus-Regular.ttf % fc-list -f '%{family}: %{file}\n' | rg -i 'iosevka:' Iosevka: /home/silmeth/.local/share/fonts/iosevka/iosevka.ttc Iosevka: /home/silmeth/.local/share/fonts/iosevka/iosevka.ttc Iosevka: /home/silmeth/.local/share/fonts/iosevka/iosevka.ttc Iosevka: /home/silmeth/.local/share/fonts/iosevka/iosevka.ttc % fc-list -f '%{family}: %{file}\n' | rg -i 'junicode:' Junicode: /home/silmeth/.local/share/fonts/junicode/otf/Junicode-Bold.otf Junicode: /home/silmeth/.local/share/fonts/junicode/otf/Junicode-Regular.otf Junicode: /home/silmeth/.local/share/fonts/junicode/otf/Junicode-Italic.otf Junicode: /home/silmeth/.local/share/fonts/junicode/otf/Junicode-BoldItalic.otf but when I try to apply the style `font-family: Gentium Plus`, `font-family: Iosevka`, or `font-family: Junicode` to an element, Firefox doesn’t use those fonts and instead in the element inspector I see Noto Serif is being used instead. Before the update the appropriate system fonts were being chosen for rendering by Firefox.
附加的畫面擷圖

由 Benedykt Jaworski 於 修改

被選擇的解決方法

Fingerprinting protection has been added to Strict Tracking Protection in Firefox 119 which limits the visibility of user-installed fonts. You can switch to Custom mode and disable "Suspected fingerprinters" if fonts are more of a priority.

從原來的回覆中察看解決方案 👍 3

所有回覆 (5)

more options

選擇的解決方法

Fingerprinting protection has been added to Strict Tracking Protection in Firefox 119 which limits the visibility of user-installed fonts. You can switch to Custom mode and disable "Suspected fingerprinters" if fonts are more of a priority.

有幫助嗎?

more options

zeroknight said

Fingerprinting protection has been added to Strict Tracking Protection in Firefox 119 which limits the visibility of user-installed fonts. You can switch to Custom mode and disable "Suspected fingerprinters" if fonts are more of a priority.

Thanks! That was the issue indeed. And nice to see FF enhancing protection against fingerprints.

It makes the settings a bit confusing though – because in the default font settings (Settings → General → Fonts) the UI allows you to choose any fonts installed on your system, but the setting doesn’t work at all by default without any hint why it’s, seemingly, broken.

有幫助嗎?

more options

There is a general warning about website breakage in the Tracking Protection settings:

Heads up! This setting may cause some websites to not display content or work correctly. If a site seems broken, you may want to turn off tracking protection for that site to load all content.

有幫助嗎?

more options

Yeah, but not in the Fonts menu (I’d expect something like “These settings might not work with Strict Tracking Protection on” (or maybe the menu should only allow you to choose from the allowed fonts).

How does FF decide which fonts are allowed, btw? The 119 beta release notes say “restricted to system fonts and language pack fonts” – but what does “system fonts” mean here? It does not allow fonts from /usr/share/fonts (like Gentium Plus above).

有幫助嗎?

more options

It uses a hard-coded list of standard fonts for each OS:

https://searchfox.org/mozilla-central/source/gfx/thebes/StandardFonts-linux.inc

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題