Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Custom font no longer working as of Firefox Nightly update today (8th September 2023)

  • 6 回覆
  • 2 有這個問題
  • 165 次檢視
  • 最近回覆由 zeroknight

more options

I use Iosevka font as my preferred custom font for websites, I really like this Firefox feature (actually one of the main reasons why I swapped from Chromium browsers), and as of updating my Firefox Nightly to "Nightly 119.0a1 (20230908094535)" version this feature no longer works on all websites, and only seems to work on the search bar when I open a new tab.

Image 1: Settings (unchanged since previous version when this feature worked) Image 2: Search bar in new tab is using Iosevka font correctly Image 3: An example of another website where the font is not being loaded where it did in the previous version.

Thanks.

I use Iosevka font as my preferred custom font for websites, I really like this Firefox feature (actually one of the main reasons why I swapped from Chromium browsers), and as of updating my Firefox Nightly to "Nightly 119.0a1 (20230908094535)" version this feature no longer works on all websites, and only seems to work on the search bar when I open a new tab. Image 1: Settings (unchanged since previous version when this feature worked) Image 2: Search bar in new tab is using Iosevka font correctly Image 3: An example of another website where the font is not being loaded where it did in the previous version. Thanks.
附加的畫面擷圖

被選擇的解決方法

Fingerprint protection has been added to Strict Tracking Protection in Nightly 119 which limits visibility of user-installed fonts. You can switch to Custom and disable "Suspected fingerprinters" if fonts are more of a priority.

從原來的回覆中察看解決方案 👍 4

所有回覆 (6)

more options

Note that you should be careful about disabling "Allow pages to choose their own fonts, instead of your selections above" as this will cause issues with iconic fonts used by webpages to display small icons (you may see text labels instead of icons).

This is only the default font for Latin, so of pages that do not use this encoding you will see the font for that encoding.

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. If the Fonts tab is hidden, click the down arrow at the right end.

more options

選擇的解決方法

Fingerprint protection has been added to Strict Tracking Protection in Nightly 119 which limits visibility of user-installed fonts. You can switch to Custom and disable "Suspected fingerprinters" if fonts are more of a priority.

more options

zeroknight said

Fingerprint protection has been added to Strict Tracking Protection in Nightly 119 which limits visibility of user-installed fonts. You can switch to Custom and disable "Suspected fingerprinters" if fonts are more of a priority.

Apologies if I'm misunderstanding this but do custom fonts allow websites to fingerprint you? How does that work? I thought it was just a filter applied after a page has been loaded.

more options

Websites can see all the fonts you have installed on your system which can make you easy to fingerprint. This protection hides user-installed fonts which means they cannot be used, even for overriding fonts.

more options

Urgh. How does a site fingerprint font usage? Can't you find some way to let us use the fonts we want without revealing that to the site? This change broke one of my forum sites and made it very difficult to read.

由 Colin 't Hart 於 修改

more options

You can still use any of the standard OS fonts plus those from language packs.

You can disable font protections specifically by going to about:config and changing privacy.fingerprintingProtection.overrides to -FontVisibilityBaseSystem,-FontVisibilityLangPack.