On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Automatically Logged Out of Websites Post-Authentication

more options

I first thought this issue was contained to a single website and was the fault of their IT, but I have begun to experience this issue on other websites, and it does not occur on other devices also using Firefox. It is difficult to explain given that I don't have any idea what is actually happening, but hopefully I can make it clear enough.

For some websites that require a username and password, I will correctly login and pass authentication but then I will be booted back to the initial login screen, almost like the login failed. I only know that it is technically a log out, not a failure, because I have briefly seen the URL change like I'm logging out. I have tried uninstalling and reinstalling Firefox fresh multiple times on my Windows 11 laptop, but the same issue occurs consistently.

This happened when I was trying to login to the student portal for my university and when I was trying to login to my apartment's resident portal. Changing cookie settings or going into a private browser has not helped at all. I cannot tell if this is a bug with Firefox (maybe just on Windows 11?) or if there is some background setting that needs to be adjusted, but it is very frustrating. If this keeps happening, I would have to switch to a different browser, which would not be ideal.

Does anyone have any idea of steps that I could take for troubleshooting or any experience with similar issues? Any help would be greatly appreciated.

I first thought this issue was contained to a single website and was the fault of their IT, but I have begun to experience this issue on other websites, and it does not occur on other devices also using Firefox. It is difficult to explain given that I don't have any idea what is actually happening, but hopefully I can make it clear enough. For some websites that require a username and password, I will correctly login and pass authentication but then I will be booted back to the initial login screen, almost like the login failed. I only know that it is technically a log out, not a failure, because I have briefly seen the URL change like I'm logging out. I have tried uninstalling and reinstalling Firefox fresh multiple times on my Windows 11 laptop, but the same issue occurs consistently. This happened when I was trying to login to the student portal for my university and when I was trying to login to my apartment's resident portal. Changing cookie settings or going into a private browser has not helped at all. I cannot tell if this is a bug with Firefox (maybe just on Windows 11?) or if there is some background setting that needs to be adjusted, but it is very frustrating. If this keeps happening, I would have to switch to a different browser, which would not be ideal. Does anyone have any idea of steps that I could take for troubleshooting or any experience with similar issues? Any help would be greatly appreciated.

被選擇的解決方法

I think I may have fixed my issue, though I still don't know exactly how. I believe it may have been a bug on my new Windows 11 laptop in which it would be assigned to the wrong time zone. I had to go into Safe Mode and adjust it to reflect my actual time zone. Upon a restart, everything seems to be working as expected. I assumed these were separate issues, but it all seems fixed by chance. Maybe there is some sort of authentication server on these websites that flagged me when I had Firefox's privacy protections and the wrong time zone at the same time? I didn't have this issue when testing on Chrome, but it seems to be fixed now. How strange. Thank you for your assistance!

從原來的回覆中察看解決方案 👍 0

所有回覆 (3)

more options

Hi Jake, one recent change in Firefox that affects cross-site cookies is "Total Cookie Protection." This is a subset of Enhanced Tracking Protection so if a site is not working correctly, and it's a site you trust, you can try disabling Enhanced Tracking Protection by clicking the shield icon at the left end of the address bar -- it's generally purplish in color when something is blocked -- to open the panel and click the slider switch to turn it off for the site. Presumably you need to do this both on the main page and on the sign in pages that may be on different servers, but I haven't tested that myself.

More info: Inviting Users to Total Cookie Protection in Standard Mode

Any improvement?

有幫助嗎?

more options

選擇的解決方法

I think I may have fixed my issue, though I still don't know exactly how. I believe it may have been a bug on my new Windows 11 laptop in which it would be assigned to the wrong time zone. I had to go into Safe Mode and adjust it to reflect my actual time zone. Upon a restart, everything seems to be working as expected. I assumed these were separate issues, but it all seems fixed by chance. Maybe there is some sort of authentication server on these websites that flagged me when I had Firefox's privacy protections and the wrong time zone at the same time? I didn't have this issue when testing on Chrome, but it seems to be fixed now. How strange. Thank you for your assistance!

有幫助嗎?

more options

Interesting. Maybe the cookies included an expiration time? No idea why the results would be different between browsers.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題