搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Gmail stopping working in Firefox (NS_BINDING_ABORTED)

more options

Hello, this did not happen in past. Tonight Gmail again says "not connected" with a countdown. When looking at the Network tool I can see that each POST request ends with NS_BINDING_ABORTED error code. It seems that those requests are aborted before a single packet is sent over network. Is there any permanent solution? Last time I got around the problem by restarting the browser. But I am not happy to do that over and over again because the Firefox is bugged.

Hello, this did not happen in past. Tonight Gmail again says "not connected" with a countdown. When looking at the Network tool I can see that each POST request ends with NS_BINDING_ABORTED error code. It seems that those requests are aborted before a single packet is sent over network. Is there any permanent solution? Last time I got around the problem by restarting the browser. But I am not happy to do that over and over again because the Firefox is bugged.

所有回覆 (9)

more options

This could be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data = false on the about:config page to disable this feature until this is fixed by Google or Mozilla to see if that helps.

See also:

more options

Thank you. I have disabled the feature as you described. As I cannot reproduce the problem, only time will tell if this helped. I shall get back should this tweak not help.

more options

I'm curious, are you running Firefox in compatibility mode as the possible cause for the tagging a Windows 7 ?

Check that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

more options

No compatibility mode. I genuinely run Windows 7. Thus I may encounter problems that don't happen with Windows 10.

more options

Win7 support ended in 2020 so that could be why you also getting those security issues.

more options

cor-el said

This could be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data = false on the about:config page to disable this feature until this is fixed by Google or Mozilla to see if that helps. See also:

Hello. That setting did not help. I experience a different problem/bug. And today I noticed this important detail in the dev console (see image). It seems that the DevTools cause this issue. After this happened Gmail could not be loaded in a new tab at all.

more options

"Blocked by DevTools" can be a placeholder used in cases where it isn't clear for what reason a request is blocked.

  • 1603805 - Decide how to surface the "unknown reason" blocked case in the UI

(please do not comment in bug reports
https://https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options

Thanks for your effort. But it does not help me. That bug report has low priority and nobody is working on it.

I seriously doubt that my Windows 7 is to blame. But frankly, can you tell if Firefox is officially supported on it or not? You know, the OS still has extended support from MS.

more options

I am sorry but this bug is driving me insane. Tonight I tried to repond to an email. Everything looked fine. Until I clicked on the send button. Then the bug surfaced to UI again. I had to restart Fifefox, type master password, login again here and there create my email anew...