搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Stop Firefox from downloading PDFs

  • 6 回覆
  • 1 有這個問題
  • 13 次檢視
  • 最近回覆由 Terry

more options

Hi,

I looking to get Firefox to open up a PDF in the browser WITHOUT downloading the file. The reason for this is because I want to bookmark the PDF allowing access to an up-to-date version of a document.

I have selected the option to ask where to the save file in the settings. I have also set the application settings for PDF to 'always ask'. So, when I open the link, I get a window prompt asking me to select 1 of 3 options: view in Firefox, view in selected application, or save. I select view in Firefox and it still downloads and opens the file.

I definitely know Firefox used to open up PDFs AS links because I have some bookmarked. Any suggestions on why this is and how to fix would be greatly appreciated.

Thanks in advance.

Hi, I looking to get Firefox to open up a PDF in the browser WITHOUT downloading the file. The reason for this is because I want to bookmark the PDF allowing access to an up-to-date version of a document. I have selected the option to ask where to the save file in the settings. I have also set the application settings for PDF to 'always ask'. So, when I open the link, I get a window prompt asking me to select 1 of 3 options: view in Firefox, view in selected application, or save. I select view in Firefox and it still downloads and opens the file. I definitely know Firefox used to open up PDFs AS links because I have some bookmarked. Any suggestions on why this is and how to fix would be greatly appreciated. Thanks in advance.
附加的畫面擷圖

所有回覆 (6)

more options

There are two ways to check a file. The first is to download it. This way you can look at it all you want until you remove it.

The second is to ‘view’ the file. In this case, the file is still downloaded but to temporary storage. Note that sooner or later, all temp files will be removed by the system.

You can, however, save the temp file via the Save option.


https://www.mozilla.org/en-US/firefox/98.0/releasenotes/ Firefox has a new optimized download flow . . . .

https://support.mozilla.org/en-US/kb/manage-downloads-preferences-using-downloads-menu Changes to how file downloads are handled in Firefox version 98

  • Firefox no longer asks what to do for each file by default
  • Downloads panel automatically opens
  • Downloaded files are saved to disk
  • Set a default app to open a file type
  • "Always Open Similar Files" option from the Downloads panel
  • Frequently asked questions


You can set this pref to false on the about:config page to prevent opening the download panel on each download.

  • browser.download.alwaysOpenPanel = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

有幫助嗎?

more options

If you select Open in Firefox rather than Always ask, evidently the pdf will be saved to your cache folder. The drawback is that it may open in the same tab; a fix for that may happen in version 101. You can bookmark the file from the link.

有幫助嗎?

more options

@FredMcD - The issue however is evening viewing the file still downloads and opens a copy from the downloads folder. Firefox does not even consider putting a copy in the temp folder. Again, no link in the address bar.

@Terry - I have selected Open in Firefox, it still downloads a copy into my downloads folder, of course this time it does not even ask what I want to do with the file.

有幫助嗎?

more options

No, select Open in Firefox in Settings > General > Applications (NOT the dialogue).

有幫助嗎?

more options

@Terry, like this? Still downloads then opens the file.

有幫助嗎?

more options

OK. I have seen reports that it behaves as I mentioned. I'll forget them.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題