搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Default font is replacing all fonts everywhere

more options

The Firefox desktop browser default font is replacing all fonts on some websites, only title fonts on some others, and then leaving others unchanged. It seems random, and I can't stop the default font from taking over randomly on most websites no matter what I do. This was not happening until today, and no browsers or general MacBook Air preferences were changed between today and yesterday when I last used the browser on desktop.

Under Firefox Preferences » Fonts » Advanced, I've made sure to check the box to "Allow pages to choose their own fonts instead of your selections above", and I've unchecked it, and I've re-checked it, and the default is still overriding fonts on most websites.

I've quit and restarted Firefox 3 times.

Help!

The Firefox desktop browser default font is replacing all fonts on some websites, only title fonts on some others, and then leaving others unchanged. It seems random, and I can't stop the default font from taking over randomly on most websites no matter what I do. This was not happening until today, and no browsers or general MacBook Air preferences were changed between today and yesterday when I last used the browser on desktop. Under Firefox Preferences » Fonts » Advanced, I've made sure to check the box to "Allow pages to choose their own fonts instead of your selections above", and I've unchecked it, and I've re-checked it, and the default is still overriding fonts on most websites. I've quit and restarted Firefox 3 times. Help!

被選擇的解決方法

Sites have a variety of approaches for specifying their preferred and fallback fonts. For example:

  • let the browser decide everything (do not specify a font-family; Firefox uses the default serif font)
  • use the browser's default sans-serif font [ font-family: sans-serif; ]
  • specify a desired system font [ font-family: Arial; ]
  • specify a downloadable font [ font-family: Roboto; ]
  • preferred with fallbacks [ font-family: Roboto, Arial, sans-serif; ]

If you are seeing an unusual default font in more places than usual, one possible reason is if web fonts are blocked. There is an obscure built-in preference for this that most people do not change (gfx.downloadable_fonts.enabled) and some add-ons block "remote" fonts.

從原來的回覆中察看解決方案 👍 0

所有回覆 (1)

more options

選擇的解決方法

Sites have a variety of approaches for specifying their preferred and fallback fonts. For example:

  • let the browser decide everything (do not specify a font-family; Firefox uses the default serif font)
  • use the browser's default sans-serif font [ font-family: sans-serif; ]
  • specify a desired system font [ font-family: Arial; ]
  • specify a downloadable font [ font-family: Roboto; ]
  • preferred with fallbacks [ font-family: Roboto, Arial, sans-serif; ]

If you are seeing an unusual default font in more places than usual, one possible reason is if web fonts are blocked. There is an obscure built-in preference for this that most people do not change (gfx.downloadable_fonts.enabled) and some add-ons block "remote" fonts.