搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Proble with saving files

  • 4 回覆
  • 1 有這個問題
  • 21 次檢視
  • 最近回覆由 Gmiącik

more options

Was Firefox broken last time or something? I thought i have troubles only with my Firefox at my job, but on my private laptop it the same... I was always saving downloaded files on my desktop, but some files i was only reading, like PDF files. Downloading straight into Adobe Reader, not saving on desktop or anywhere else (well, im aware, that files were saved in temp folder). Since, i dont know, few days, two weeks maximum, EVERY PDF file that i want ONLY READ is saving on my desktop (even if i open them in firefox directly). WHY? Its so annoying. I dont want them on my desktop. How to turn it off? Files tht i want to download and save HAVE to be saved on my desktop, files i want to only read cant be saved on desktop.

Was Firefox broken last time or something? I thought i have troubles only with my Firefox at my job, but on my private laptop it the same... I was always saving downloaded files on my desktop, but some files i was only reading, like PDF files. Downloading straight into Adobe Reader, not saving on desktop or anywhere else (well, im aware, that files were saved in temp folder). Since, i dont know, few days, two weeks maximum, EVERY PDF file that i want ONLY READ is saving on my desktop (even if i open them in firefox directly). WHY? Its so annoying. I dont want them on my desktop. How to turn it off? Files tht i want to download and save HAVE to be saved on my desktop, files i want to only read cant be saved on desktop.

所有回覆 (4)

more options

https://www.mozilla.org/en-US/firefox/98.0/releasenotes/ Firefox has a new optimized download flow . . . .

https://support.mozilla.org/en-US/kb/manage-downloads-preferences-using-downloads-menu Changes to how file downloads are handled in Firefox version 98

  • Firefox no longer asks what to do for each file by default
  • Downloads panel automatically opens
  • Downloaded files are saved to disk
  • Set a default app to open a file type
  • "Always Open Similar Files" option from the Downloads panel
  • Frequently asked questions


You can set this pref to false on the about:config page to prevent opening the download panel on each download.

  • browser.download.alwaysOpenPanel = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

The preference to reverse the change will only work temporarily.

https://support.mozilla.org/en-US/questions/1370494

If you want to select the folder where the download is saved, try changing the preference in bold in the quote below from searchfox .org.

browser.download.useDownloadDir - bool True - Save files directly to the folder configured via the browser.download.folderList preference. False - Always ask the user where to save a file and default to browser.download.lastDir when displaying a folder picker dialog https://support.mozilla.org/en-US/kb/about-config-editor-firefox

You could instead use the method outlined in the link below (remove the blank space in the link).

https://www.reddit. com/r/firefox/comments/trnirr/a_work_around_for_open_with_option_for_downloads/

more options

I dont care for any "optimized download", its a shit now. I want it like it was before. I want download panel for each download (with the exception of few formats i set to download every time), the panel is not the problem. Problem is that files i select to 'open with... (Otwórz za pomocą...)' are saving to my desktop and then opening instead of directly opening without saving.

more options

solution from reddit is not a solution for me