On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox Theme "switches" after startup

  • 5 回覆
  • 1 有這個問題
  • 6 次檢視
  • 最近回覆由 L

more options

I have this theme installed in my firefox browser (95.0.2). https://addons.mozilla.org/en-US/firefox/addon/arctic-nord-theme/

When the browser starts, the theme works for a second, then swithes to some darker theme automatically. If I go to Preferences and disable, then enable the theme again, it work as expectet. I have set `layout.css.prefers-color-scheme.content-override` to `1` hoping that it would pin the light theme, but it has no effect on the issue.

How can I make firefox not change to some dark theme on startup?

I have this theme installed in my firefox browser (95.0.2). https://addons.mozilla.org/en-US/firefox/addon/arctic-nord-theme/ When the browser starts, the theme works for a second, then swithes to some darker theme automatically. If I go to Preferences and disable, then enable the theme again, it work as expectet. I have set `layout.css.prefers-color-scheme.content-override` to `1` hoping that it would pin the light theme, but it has no effect on the issue. How can I make firefox not change to some dark theme on startup?

所有回覆 (5)

more options

Not able to replicate the issue with my distro version of Firefox. see screenshot I was able to restart the browser and the theme was still there. Have you tried running Firefox in Safe Mode and trying the same steps? Try downloading another copy of Firefox and run it from the folder. Do not sign into your Firefox account and see if you have the same issue.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

由 jonzn4SUSE 於 修改

more options

Are you in Wayland or X11?

Operating System: openSUSE Tumbleweed 20220107 KDE Plasma Version: 5.23.4 KDE Frameworks Version: 5.89.0 Qt Version: 5.15.2 Kernel Version: 5.15.12-1-default (64-bit) Graphics Platform: X11 Processors: 4 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

由 jonzn4SUSE 於 修改

more options

I am using Wayland. The problem seems to be related do the Profile, it does not reproduce on a fresh profile. My browser is never logged in.

more options

So it works on the Firefox that you downloaded? Can you try the same steps in X11 with the Distro version and the downloaded version?

more options

No, it works on the Distro version with a fresh profile.