搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

My search box doesn't work after firefox upgraded yesterday

  • 8 回覆
  • 5 有這個問題
  • 38 次檢視
  • 最近回覆由 fasteredie

more options

When I go to do a search, as soon as I type in a letter, it jumps up to the address bar exposing past searches and all, and makes me do my search in the address bar, with my history exposed to everyone in the room which invades my privacy. How can I correct this to the way it used to be that when I searched it stayed in the search box unless I needed to used the url when I wanted to. Very surprised this started happening with the new upgrade. Can I go back to the last upgrade?

被選擇的解決方法

You can turn it off by going to about:config and switching browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar to false.

從原來的回覆中察看解決方案 👍 3

所有回覆 (8)

more options

I too am seeing this behaviour, and I sure hope that it's a bug and not an ill-advised intentional redesign behaviour to force people to search with the address bar.

If this is intentional, aside from the obvious privacy issue mentioned by OP, I sure wish that the Firefox UI developers can appreciate that their browser is used by old folks and non tech-savvy people, who, and I can vouch for this since I am supporting such persons, will only see the aspect of: "When I try to type text in one field, it jumps to another field. This is not what I want and it is very confusing for someone who was used to performing search using the *friendly* big search field in the middle of the default browse page".

So please please please, either fix this or provide us with the ability to disable this behaviour, as, IMO, this is a very unnecessary and ill-advised UI change, when you do consider that there exist a non negligible percentage of Firefox users who will see the action of jumping away from the field currently selected as a very unfriendly and confusing change, no matter how much the Firefox UI team may feel like promoting the fact that the address bar can be used for search.

Or, in case this is needed, can I refer the Firefox UI team to the "Principle of least astonishment" (https://en.wikipedia.org/wiki/Principle_of_least_astonishment), because if jumping *away* from the currently selected field isn't astonishing behaviour, then I don't know what is...

由 Pete Batard 於 修改

more options

選擇的解決方法

You can turn it off by going to about:config and switching browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar to false.

more options

It's already set on false.

more options

Changing handoffToAwesomebar to false worked for me. But since it appears this handoff is intentional (and again breaks the principle of least astonishment) I would really like the Firefox UI team to reconsider having its default set to true. You *ARE* going to confuse a lot of users and make life miserable for people who are trying to help non tech-savvy people for whom this behaviour will be bewildering.

Please consider how you would react if, when filling a form, focus randomly switched away from the currently selected field. And whereas you will of course argue that, in this case, either field performs the same function, random field focusing is what many will *perceive* Firefox to be doing. So I hope you can try to weigh in the pros and cons of the current handoffToAwesomebar defaults.

more options

It worked today for some reason. Wow. So happy. There was one written above the one I tried 2 days ago. Amazing.

more options

Thanks to Ty and Pete.

more options

Where is this wonderful about:config place? I've had this issue for several months. Soon as I type anything or paste it comes up in the URL bar. I am not tech savvy at all, I tried to look for this beautiful about:config place but can't find it. Really sorry if this is a goofball question for you guys, but here is a beginner in action. Thank you!

more options

fasteredie said

Where is this wonderful about:config place? I've had this issue for several months. Soon as I type anything or paste it comes up in the URL bar. I am not tech savvy at all, I tried to look for this beautiful about:config place but can't find it. Really sorry if this is a goofball question for you guys, but here is a beginner in action. Thank you!

OK, I figured it out.

1-While in Firefox, you enter into the address bar: about:config click go or return... and 2-you get a window with a warning:

Proceed with Caution Changing advanced configuration preferences can impact Firefox performance or security. Warn me when I attempt to access these preferences

3-You accept or agree by clicking the box.

4-Then, into a field that becomes available, you paste: browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar

5-Magically, a thing appears with that text in BOLD and the word "true" behind it. To the right there's a symbol that I guess represents ON/OFF or TRUE/FALSE switch or something of the kind.

!-You click that, and now the word "true" replaces "false"

Then you open another new tab with the DuckDuckGo search bar like you've been used to. Search for what you're searching for (I was looking for my local post office hours of operation because I'm a middle-aged guy and that's what we do). And BAM!!! The sweet smell of success.

This feels good. I guess I'm a tech wizard now. Putting that on my resume! Good luck.