搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

FF 88/widevine bug with Amazon prime videos not playing HD 1080p

  • 9 回覆
  • 1 有這個問題
  • 229 次檢視
  • 最近回覆由 arugula

more options

Whenever I play a video on amazon prime thru FF 88 it is SD. When I go to the options for video it says HD is unavailable even if best is selected. When the video first plays the HD icon will come up for about a second, but faded, than go away right after. Usually when it does that it becomes solid white and shows HD at 1080. I'm using Win 10 64-bit Pro 20H2.

When I try watching the same videos in Chrome I have no issues and the content plays fine in HD 1080p.

I tried removing all history, refreshing FF, uninstalling and re-installing my NVIDIA drivers but same issue. I am on 88.0. No add ons or themes. Just default FF after refresh. Nothing helps.

I have seen other reports of widevine crashing but I dont have that issue. FF just wont play Amazon video in HD anymore.

Edit:

After trying some things and completely uninstalling firefox from system and all folders I finally got Amazon to play HD 1080p content again, but only a short while.

For some reason on refreshed or completely new installs of FF 88 amazon would have issues and only play SD. Even if all folders were deleted before install. When I installed the previous version of FF to 87 content was once again playing back at HD 1080p. I than updated to 88 and it was ok but only for a bit.

Even though FF 87 installed and updated widevine, FF version 88 would update it again a short while later but the version numbers of widevine (4.10.2209.1) stayed the same. Whatever version 88 is doing to widevine it seems to cause a conflict preventing Amazon from playing videos in HD content.

Edit 2:

From my other computer which had not updated to 88 yet had widevine version 4.10.1582. I took all those files and replaced the ones in the folder for 4.10.2209.1. I have updates disabled for widevine now and Amazon is playing HD 1080p once again with no issues. So whatever the update did with widevine it is definitely causing a conflict with playing back HD 1080p content on Amazon Prime video.

由 arugula 於 修改

被選擇的解決方法

Hi there. Just an update here on the above conversation.

It looks like a fix for this is going into a dot release 88.0.1 which is set to release on the 5th. Give that a try once it is live and see if it resolves the issue for you.

從原來的回覆中察看解決方案 👍 0

所有回覆 (9)

more options

hello ar,

this pluggin has been like a firestorm of complaints by other users as yourself.

i believe that the people that create widevine have decided to change things, perhaps due to the ever evolving digitial world's.

below is a link to a thread on this pluggin.

please take a look and see if it helps you to reconcile your system and or your opinions.

and then please let me know what your resolution is and or conclusion.

https://support.mozilla.org/en-US/questions/1333571?page=1

有幫助嗎?

more options

Yea, I saw those and replied to the thread that had all the links to the others. Which also included the one you gave. If you read my last edit above I was able to fix it and seems ok for now.

由 arugula 於 修改

有幫助嗎?

more options

thanks for the additional info !

dont forget to disable the updating of FF in order to retain that version and the version of Widevine locked in with the version of o.s. you have.

thanks again for proving the resolution works (at least for now)  :-)

有幫助嗎?

more options

Could be this bug:

  • 1705138 - Firefox 88 with Widevine CDM 4.10.2209.1 fails to playback encrypted content when license enforcing HDCPv1

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

有幫助嗎?

more options

cor-el said

Could be this bug:
  • 1705138 - Firefox 88 with Widevine CDM 4.10.2209.1 fails to playback encrypted content when license enforcing HDCPv1
(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Glad to see its been confirmed and a fix is in the works!

有幫助嗎?

more options

選擇的解決方法

Hi there. Just an update here on the above conversation.

It looks like a fix for this is going into a dot release 88.0.1 which is set to release on the 5th. Give that a try once it is live and see if it resolves the issue for you.

有幫助嗎?

more options

Thank you sir! We will pass the word. :-)

有幫助嗎?

more options

SUMOsJR said

Hi there. Just an update here on the above conversation. It looks like a fix for this is going into a dot release 88.0.1 which is set to release on the 5th. Give that a try once it is live and see if it resolves the issue for you.

Thank you sir. We will pass the word!

有幫助嗎?

more options

SUMOsJR said

Hi there. Just an update here on the above conversation. It looks like a fix for this is going into a dot release 88.0.1 which is set to release on the 5th. Give that a try once it is live and see if it resolves the issue for you.

The most recent widevine version is now working with 88.0.1. HD content is playing as it should. Thanks!

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題