搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Can one hide the Minimize button on the header bar.

  • 2 回覆
  • 1 有這個問題
  • 778 次檢視
  • 最近回覆由 Gpx45

more options

Hello everyone, I'm working on customizing the Firefox experience for users within my organization.

I have to really limit their access. One of those requests were to prevent users from minimizing their active Firefox window.

I've found articles like the one below that show how to hide all the buttons: https://support.mozilla.org/en-US/questions/906698

However it does not suit the purpose. since it removes all of them and only on full screen.

Is there a way I can just hide the minimize button so that the user can just hide the minimize button?

Any help would be greatly appreciated.

Hello everyone, I'm working on customizing the Firefox experience for users within my organization. I have to really limit their access. One of those requests were to prevent users from minimizing their active Firefox window. I've found articles like the one below that show how to hide all the buttons: https://support.mozilla.org/en-US/questions/906698 However it does not suit the purpose. since it removes all of them and only on full screen. Is there a way I can just hide the minimize button so that the user can just hide the minimize button? Any help would be greatly appreciated.

被選擇的解決方法

Note that even if you hide the buttons (what you may be able to do via userChrome.css if the title bar is hidden and the buttons appear on the Tab bar) this likely still leaves the system menu (Alt+Space) to access these items.


Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

.titlebar-min {display:none!important;}
.titlebar-max {display:none!important;}
.titlebar-restore {display:none!important;}
.titlebar-close {display:none!important;}

從原來的回覆中察看解決方案 👍 1

所有回覆 (2)

more options

選擇的解決方法

Note that even if you hide the buttons (what you may be able to do via userChrome.css if the title bar is hidden and the buttons appear on the Tab bar) this likely still leaves the system menu (Alt+Space) to access these items.


Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

.titlebar-min {display:none!important;}
.titlebar-max {display:none!important;}
.titlebar-restore {display:none!important;}
.titlebar-close {display:none!important;}

more options

Thank you for this solution, it worked phenomenally after I restarted the user session. Thank you.