搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

New windows open on the wrong monitor

  • 2 回覆
  • 1 有這個問題
  • 1668 次檢視
  • 最近回覆由 cor-el

more options

When I have my computer plugged into an external monitor, I want new browser windows to open on the external monitor, but they always open on the computer's monitor. I have gone through the entire process at https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems (clearing cache etc., trying safe mode, creating a new profile, refreshing Firefox, reinstalling Firefox) and the problem persists. This happens if I manually select "New Tab," "New Window," or "New Private Window" from the File menu with no existing windows open. It also happens if I use the key commands for any of these menu items. It happens if I use the menu bar on the computer's monitor or the menu bar on the external monitor. Opening a window and dragging it from the computer's monitor to the external monitor does not change anything. I've also tried using Divvy (https://mizage.com/divvy/) to move the browser window between windows with a key command, but after moving it this way nothing changes—new windows continue to open on the computer's monitor. How do I set which monitor Firefox will use for displaying new windows and/or get it to remember my preference?

System details:

MacBook Pro (15-inch, Late 2016) macOS Catalina, Version 10.15.2 Firefox 72.0.2 LG HDR 4K external monitor (Model 27UK850) CalDigit TS3 Plus Thunderbolt dock Computer connected to the dock with Thunderbolt 3 LG external monitor connected to the dock with DisplayPort 1.2

被選擇的解決方法

Someone on reddit offered a trick for this that seems to have fixed the problem for me!

> In Firefox, make a new window, drag it to the monitor where you want new windows to be, make it full screen by clicking the little green icon in the top-left of the window, make it non-full screen by clicking that same thing again, and close the window. Now, when you make a new window, it should open on that monitor.

Credit to /u/electric75 on reddit.

從原來的回覆中察看解決方案 👍 0

所有回覆 (2)

more options

選擇的解決方法

Someone on reddit offered a trick for this that seems to have fixed the problem for me!

> In Firefox, make a new window, drag it to the monitor where you want new windows to be, make it full screen by clicking the little green icon in the top-left of the window, make it non-full screen by clicking that same thing again, and close the window. Now, when you make a new window, it should open on that monitor.

Credit to /u/electric75 on reddit.

more options

In a long past we used to offer these steps:

由 cor-el 於 修改