X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox won't open locally saved pdf, instead downloads it again

已張貼

Hi, Today i tried opening an PDF, but instead of opening the PDF the page is just blank and it downloads another copy of the PDF. even though the address bar is this: file:///C:/Users/[redacted]/Downloads/[redacted].pdf I tried pasting the address into microsoft edge and there it works fine. I also restarted firefox in safe mode but it has the same problem. I have my windows configured to open PDF's with firefox.exe by default, but clicking on the file in windows file explorer gives the same problem. Does anyone know how to solve this?

Hi, Today i tried opening an PDF, but instead of opening the PDF the page is just blank and it downloads another copy of the PDF. even though the address bar is this: file:///C:/Users/[redacted]/Downloads/[redacted].pdf I tried pasting the address into microsoft edge and there it works fine. I also restarted firefox in safe mode but it has the same problem. I have my windows configured to open PDF's with firefox.exe by default, but clicking on the file in windows file explorer gives the same problem. Does anyone know how to solve this?

被選擇的解決方法

RobertJ said

Hello Tjeu, Try an easy fix first. On your local pdf file, change the Open With... to another app like Adobe Reader or Edge. Double-click the file to open in that app. Close the app and change the Open With... back to Firefox. Then, see if it opens in Firefox.

Hi, Thank you for the response!

I changed it to microsoft edge in file properties, hit apply. tested it and opened in edge fine. then changed it back in file properties to open with firefox. Sadly after this i still have the same problem. I tried opening multiple different PDF files and they all suffer from this.

After this i started looking into the firefox settings and saw that under general>applications>content type: PDF was set to action: save file

I changed the action to "always ask" and then when opening the PDF selected "open with firefox", this caused an new tab to open that again downloaded another version of the file. then i changed action to preview in firefox. Then it does open fine.

So i think my problem is solved, thank you for the help!

從原來的回覆中察看解決方案 0
引用

額外的系統細節

應用程式

  • Firefox 72.0.1
  • 使用者代理:Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/72.0.1/WINNT/en-US/

擴充套件

  • Amazon.com 1.1 (amazondotcom@search.mozilla.org)
  • Bing 1.0 (bing@search.mozilla.org)
  • DuckDuckGo 1.0 (ddg@search.mozilla.org)
  • eBay 1.0 (ebay@search.mozilla.org)
  • Google 1.0 (google@search.mozilla.org)
  • Twitter 1.0 (twitter@search.mozilla.org)
  • Wikipedia (en) 1.0 (wikipedia@search.mozilla.org)
  • Blur 8.1.2491 (donottrackplus@abine.com) (Inactive)
  • Cookie Manager 1.5 (cookie-manager@robwu.nl) (Inactive)
  • Dark Reader 4.8.6 (addon@darkreader.org) (Inactive)
  • FontsInfos 1.2 (info@paris-web.it) (Inactive)
  • HTTPS Everywhere 2019.11.7 (https-everywhere@eff.org) (Inactive)
  • Marktplaats zonder spam 2.2.0 (mza@tagpulse.nl) (Inactive)
  • Privacy Badger 2020.1.13 (jid1-MnnxcxisBPnSXQ@jetpack) (Inactive)
  • uBlock Origin 1.24.2 (uBlock0@raymondhill.net) (Inactive)
  • uMatrix 1.4.0 (uMatrix@raymondhill.net) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Intel(R) Q45/Q43 Express Chipset (Microsoft Corporation - WDDM 1.1)
  • adapterDescription2:
  • adapterDeviceID: 0x2e12
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: 0
  • adapterRAM2: 0
  • adapterSubsysID: 3646103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 1.8 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
  • contentUsesTiling: False
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: {u'key': u'blocked-gfx-card'}
  • directWriteEnabled: True
  • directWriteVersion: 10.0.18362.476
  • driverDate: 3-11-2013
  • driverDate2:
  • driverVendor:
  • driverVendor2:
  • driverVersion: 8.15.10.2702
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'blocked', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Safe-mode is enabled', u'type': u'runtime'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable-no-angle', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable-no-angle', u'message': u'ANGLE is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'blacklisted', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP'}, {u'status': u'disabled', u'description': u'WebGPU', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'WEBGPU'}]}
  • info: {u'DisplayCount': 1, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'CMSOutputProfile': u'AAADjUxpbm8CIAAAbW50clJHQiBYWVogB9kAAwAbABEANAABYWNzcE1TRlQAAAAASFAAADIzVQMAAAAAAAAAAAAAAAAAAPbWAAEAAAAA0y1IUCAgAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAMZGVzYwAAARQAAACkZG1kZAAAAbgAAAB3ZG1uZAAAAjAAAACkclhZWgAAAtQAAAAUZ1hZWgAAAugAAAAUYlhZWgAAAvwAAAAUYmtwdAAAAxAAAAAUd3RwdAAAAyQAAAAUclRSQwAAAzgAAAAOZ1RSQwAAAzgAAAAOYlRSQwAAAzgAAAAOY3BydAAAA0gAAABFZGVzYwAAAAAAAAAYSFAgTEEyMjA1d2cgTENEIE1vbml0b3IAAAAAAAAAABn+/wBIAFAAIABMAEEAMgAyADAANQB3AGcAIABMAEMARAAgAE0AbwBuAGkAdABvAHIAAAAAGEhQIExBMjIwNXdnIExDRCBNb25pdG9yAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAABkZXNjAAAAAAAAAAlMQTIyMDV3ZwAAAAAAAAAACv7/AEwAQQAyADIAMAA1AHcAZwAAAAAJTEEyMjA1d2cAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAABkZXNjAAAAAAAAABhIZXdsZXR0LVBhY2thcmQgQ29tcGFueQAAAAAAAAAAGf7/AEgAZQB3AGwAZQB0AHQALQBQAGEAYwBrAGEAcgBkACAAQwBvAG0AcABhAG4AeQAAAAAYSGV3bGV0dC1QYWNrYXJkIENvbXBhbnkAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAFhZWiAAAAAAAAB7WwAAQCoAAAKTWFlaIAAAAAAAAFpQAACvAQAAGaNYWVogAAAAAAAAISsAABDVAAC29lhZWiAAAAAAAAAAAAAAAAAAAAAAWFlaIAAAAAAAAPNRAAEAAAABFsxjdXJ2AAAAAAAAAAECMwAAdGV4dAAAAABDb3B5cmlnaHQgKGMpIDIwMDkgSGV3bGV0dC1QYWNrYXJkIERldmVsb3BtZW50IENvbXBhbnksIExMUC4A', u'Display0': u'1680x1050@59Hz ', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: {u'key': u''}
  • numTotalWindows: 2
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • targetFrameRate: 60
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
RobertJ
  • Top 10 Contributor
141 個解決方法 1453 個答案

有幫助的回覆

Hello Tjeu, Try an easy fix first. On your local pdf file, change the Open With... to another app like Adobe Reader or Edge. Double-click the file to open in that app. Close the app and change the Open With... back to Firefox. Then, see if it opens in Firefox.

Hello Tjeu, Try an easy fix first. On your local pdf file, change the Open With... to another app like Adobe Reader or Edge. Double-click the file to open in that app. Close the app and change the Open With... back to Firefox. Then, see if it opens in Firefox.
這篇文章有幫助嗎? 1
引用

選擇的解決方法

RobertJ said

Hello Tjeu, Try an easy fix first. On your local pdf file, change the Open With... to another app like Adobe Reader or Edge. Double-click the file to open in that app. Close the app and change the Open With... back to Firefox. Then, see if it opens in Firefox.

Hi, Thank you for the response!

I changed it to microsoft edge in file properties, hit apply. tested it and opened in edge fine. then changed it back in file properties to open with firefox. Sadly after this i still have the same problem. I tried opening multiple different PDF files and they all suffer from this.

After this i started looking into the firefox settings and saw that under general>applications>content type: PDF was set to action: save file

I changed the action to "always ask" and then when opening the PDF selected "open with firefox", this caused an new tab to open that again downloaded another version of the file. then i changed action to preview in firefox. Then it does open fine.

So i think my problem is solved, thank you for the help!

''RobertJ [[#answer-1281224|said]]'' <blockquote> Hello Tjeu, Try an easy fix first. On your local pdf file, change the Open With... to another app like Adobe Reader or Edge. Double-click the file to open in that app. Close the app and change the Open With... back to Firefox. Then, see if it opens in Firefox. </blockquote> Hi, Thank you for the response! I changed it to microsoft edge in file properties, hit apply. tested it and opened in edge fine. then changed it back in file properties to open with firefox. Sadly after this i still have the same problem. I tried opening multiple different PDF files and they all suffer from this. After this i started looking into the firefox settings and saw that under general>applications>content type: PDF was set to action: save file I changed the action to "always ask" and then when opening the PDF selected "open with firefox", this caused an new tab to open that again downloaded another version of the file. then i changed action to preview in firefox. Then it does open fine. So i think my problem is solved, thank you for the help!
這篇文章有幫助嗎?
引用
RobertJ
  • Top 10 Contributor
141 個解決方法 1453 個答案

Well, you beat me to it. I was going to go there next.

I glad to hear you found it!

Browse Safe!

Well, you beat me to it. I was going to go there next. I glad to hear you found it! Browse Safe!
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題