X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox displays NYT website in single column on Surface Go

已張貼

I have Firefox installed on Win 8 and 10 desktops and Surface Go and Android 10 inch tablet. On all but the Surface the New York Times front page is rendered in multi-column format. On the Surface, I get a single column more apropos for a phone. I find no option to 'Display as Desktop'.

It renders my local paper and others on the Surface in multi-column format

I've asked NYT support to look into this, they, of course pointed fingers at Mozilla.

Could someone recommend a way I could figure out what's going on here?

Thanks,

Dan

I have Firefox installed on Win 8 and 10 desktops and Surface Go and Android 10 inch tablet. On all but the Surface the New York Times front page is rendered in multi-column format. On the Surface, I get a single column more apropos for a phone. I find no option to 'Display as Desktop'. It renders my local paper and others on the Surface in multi-column format I've asked NYT support to look into this, they, of course pointed fingers at Mozilla. Could someone recommend a way I could figure out what's going on here? Thanks, Dan

被選擇的解決方法

Firefox may be taking orders from Windows Tablet/Desktop Mode setting. This is in PC Settings but should have a switch in the Action Center in Notification Area.

To get the content window size: Menu → Web Developer → Toggle Responsive Design Mode. Drag to resize to fit the full content area if needed. Size is shown at top. This will probably give you a good idea of the size reported when the site queries the browser.

You can also look at this: https://www.infobyip.com/detectscreenresolution.php https://www.infobyip.com/detectdisplaysize.php

It's going to depend on the script any particular site uses, i might think, in calculating window or viewport size or resolution.

You might be able to mess with this by changing the about:config entry browser.viewport.desktopWidth but i don't imagine that being particularly helpful.

從原來的回覆中察看解決方案 0
引用
Wesley Branton
  • Top 10 Contributor
704 個解決方法 5588 個答案

You are probably being shown the mobile version of the website. Certain websites can detect your screen size and use that information to decide if you are on desktop or mobile.

If you have Firefox for Android installed as your browser, you can request the desktop version of the website instead (which most websites will honour).

Depending on your device layout, this option is likely in the upper-right corner of the screen if you click the three stacked dots. See How do I change to the desktop view in Firefox for Android? for more information.

Hope this helps.

You are probably being shown the mobile version of the website. Certain websites can detect your screen size and use that information to decide if you are on desktop or mobile. If you have Firefox for Android installed as your browser, you can request the desktop version of the website instead (which most websites will honour). Depending on your device layout, this option is likely in the upper-right corner of the screen if you click the three stacked dots. See [[How do I change to the desktop view in Firefox for Android?]] for more information. Hope this helps.
這篇文章有幫助嗎?
引用

提出問題者

I guessed I was getting a mobile version of the site. The question is why. I'm on a Surface Go running Win 10 with a 10 inch screen in landscape. I don't see an option to request a desktop version as there is on Android.

And no other site gives me a mobile version in the Surface.

Is there a way to check the screen dimensions Firefox is providing?

Thanks for reply,

Dan

I guessed I was getting a mobile version of the site. The question is why. I'm on a Surface Go running Win 10 with a 10 inch screen in landscape. I don't see an option to request a desktop version as there is on Android. And no other site gives me a mobile version in the Surface. Is there a way to check the screen dimensions Firefox is providing? Thanks for reply, Dan
這篇文章有幫助嗎?
引用
crankygoat
  • Top 25 Contributor
40 個解決方法 471 個答案

選擇的解決方法

Firefox may be taking orders from Windows Tablet/Desktop Mode setting. This is in PC Settings but should have a switch in the Action Center in Notification Area.

To get the content window size: Menu → Web Developer → Toggle Responsive Design Mode. Drag to resize to fit the full content area if needed. Size is shown at top. This will probably give you a good idea of the size reported when the site queries the browser.

You can also look at this: https://www.infobyip.com/detectscreenresolution.php https://www.infobyip.com/detectdisplaysize.php

It's going to depend on the script any particular site uses, i might think, in calculating window or viewport size or resolution.

You might be able to mess with this by changing the about:config entry browser.viewport.desktopWidth but i don't imagine that being particularly helpful.

Firefox may be taking orders from Windows Tablet/Desktop Mode setting. This is in PC Settings but should have a switch in the Action Center in Notification Area. To get the content window size: Menu → Web Developer → Toggle Responsive Design Mode. Drag to resize to fit the full content area if needed. Size is shown at top. This will probably give you a good idea of the size reported when the site queries the browser. You can also look at this: https://www.infobyip.com/detectscreenresolution.php https://www.infobyip.com/detectdisplaysize.php It's going to depend on the script any particular site uses, i might think, in calculating window or viewport size or resolution. You might be able to mess with this by changing the about:config entry browser.viewport.desktopWidth but i don't imagine that being particularly helpful.
這篇文章有幫助嗎?
引用

提出問題者

I went into Menu > Web Developer > Responsive Design Mode and toyed with it. I noticed the list of devices, unchecked most devices (left iPad, iPad Pro) and created an entry for Surface Go (1800x1200, didn't know what to put in Agent string). I went to NYT site and enabled RDM. It was in iPad mode and single column. I am not sure if this had been the previous default or resulted from my unchecking the phones around. I switched to Surface Go and viola, page appeared as it should.

Now the question is why I had to do this and what are the ramifications of my using my Custom Device with deficient Agent String?

Also, does this mean Firefox was reporting device specs incorrectly or is NYT getting specs incorrectly? NYT is somewhat Apple-centric.

Thanks for help. That was real interesting.

Dan

I went into Menu > Web Developer > Responsive Design Mode and toyed with it. I noticed the list of devices, unchecked most devices (left iPad, iPad Pro) and created an entry for Surface Go (1800x1200, didn't know what to put in Agent string). I went to NYT site and enabled RDM. It was in iPad mode and single column. I am not sure if this had been the previous default or resulted from my unchecking the phones around. I switched to Surface Go and viola, page appeared as it should. Now the question is why I had to do this and what are the ramifications of my using my Custom Device with deficient Agent String? Also, does this mean Firefox was reporting device specs incorrectly or is NYT getting specs incorrectly? NYT is somewhat Apple-centric. Thanks for help. That was real interesting. Dan
這篇文章有幫助嗎?
引用

提出問題者

So Maybe I spoke too soon. The rendering of the page still isn't right (see jpeg). Top shot is Firefox with my kludged Surface Go device and the bottom is Edge, which is now Chrome based. The Edge rendering is what I expect from NYT frontpage.

In the Responsive Designer toolkit, the Surface is still listed as a phone. I had set the Pixel Ratio to 1, as I don't know what it is and I said before, the User Agent String is fubar'd.

So, I feel I'm on right track, but haven't gotten there yet.

Edit: I set device to 'laptop with HiDPI screen', adjusted DPI to match Surface and rendering was correct.

thanks again for any help,

Dan

So Maybe I spoke too soon. The rendering of the page still isn't right (see jpeg). Top shot is Firefox with my kludged Surface Go device and the bottom is Edge, which is now Chrome based. The Edge rendering is what I expect from NYT frontpage. In the Responsive Designer toolkit, the Surface is still listed as a phone. I had set the Pixel Ratio to 1, as I don't know what it is and I said before, the User Agent String is fubar'd. So, I feel I'm on right track, but haven't gotten there yet. Edit: I set device to 'laptop with HiDPI screen', adjusted DPI to match Surface and rendering was correct. thanks again for any help, Dan

由 dlpalumbo 於 修改

這篇文章有幫助嗎?
引用
crankygoat
  • Top 25 Contributor
40 個解決方法 471 個答案

All i meant with the Responsive Design Mode is that if you drag to resize the Viewport (Never mind the device presets, they are just a couple random common sizes (?) / examples for web designers), you can see approximately what size Firefox thinks your content area of the window is.

Or you can check with the other links to see how your screen size and resolution might be reported.

In short, a website has some scripts that do math to try and figure out your viewport size. Then they have formatting rules which apply according to size. I have no idea why in Firefox this happens differently than the other browsers.

Does toggling the Windows Desktop/Tablet Mode change anything in Firefox's rendering of the page?

You mentioned the user agent string, though, which i had been thinking about. You might try toggling the preference general.useragent.compatMode.firefox in about:config and see if that changes the display for that page without unwanted effects elsewhere. Turn this off if it doesn't help.

A different option may be to try adding 2 preferences: general.useragent.site_specific_overrides (boolean, true) general.useragent.override.nytimes.com (string, insert here user agent stings from another browser or device which might work)

I have no advice for what browser/version would be good. For example you could try Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36

Maybe a newer string would be better, but the best place to find them is hibernating through a DoS attack.

All i meant with the Responsive Design Mode is that if you drag to resize the Viewport (Never mind the device presets, they are just a couple random common sizes (?) / examples for web designers), you can see approximately what size Firefox thinks your content area of the window is. Or you can check with the other links to see how your screen size and resolution might be reported. In short, a website has some scripts that do math to try and figure out your viewport size. Then they have formatting rules which apply according to size. I have no idea why in Firefox this happens differently than the other browsers. Does toggling the Windows Desktop/Tablet Mode change anything in Firefox's rendering of the page? You mentioned the user agent string, though, which i had been thinking about. You might try toggling the preference ''general.useragent.compatMode.firefox'' in about:config and see if that changes the display for that page without unwanted effects elsewhere. Turn this off if it doesn't help. A different option may be to try adding 2 preferences: general.useragent.site_specific_overrides (boolean, true) general.useragent.override.nytimes.com (string, insert here user agent stings from another browser or device which might work) I have no advice for what browser/version would be good. For example you could try Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36 Maybe a newer string would be better, but the best place to find them is hibernating through a DoS attack.
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題