X
點擊此處開啟此網站的行動版。

技術支援討論區

Content-Type “video/mp4” is not supported on website, but downloaded video plays fine (Linux/Fedora30)

Ran
已張貼

I cannot play mp4/h264 videos on websites, but I can download the file and play it in the browser just fine (ffmpeg is installed).

== From twitter web page: error in web console:

For example, on twitter i get a "the media could not be played" placeholder and this in the web console:

HTTP “Content-Type” of “video/mp4” is not supported. Load of media resource https://video.twimg.com/amplify_video/1149302678771683333/vid/1280x720/qFCcMLAnjR_MBans.mp4?tag=13 failed. home

The video on this page can’t be played. Your system may not have the required video codecs for: video/mp4; codecs="avc1.42E01E mp4a.40.2"

== Local file in firefox

When I put that mp4 link in the address bar, it gives me a download dialog, I can download that file, and play it in firefox from the command line:

firefox qFCcMLAnjR_MBans.mp4

== Local html file with control element:

The same file plays fine also when i open a local html file with the vide controls element. So why do I get those errors when this is viewed on the twitter website?

Any pointers appreciated.

Thanks!

I cannot play mp4/h264 videos on websites, but I can download the file and play it in the browser just fine (ffmpeg is installed). == From twitter web page: error in web console: For example, on twitter i get a "the media could not be played" placeholder and this in the web console: <i><b> HTTP “Content-Type” of “video/mp4” is not supported. Load of media resource https://video.twimg.com/amplify_video/1149302678771683333/vid/1280x720/qFCcMLAnjR_MBans.mp4?tag=13 failed. home The video on this page can’t be played. Your system may not have the required video codecs for: video/mp4; codecs="avc1.42E01E mp4a.40.2" </i></b> == Local file in firefox When I put that mp4 link in the address bar, it gives me a download dialog, I can download that file, and play it in firefox from the command line: firefox qFCcMLAnjR_MBans.mp4 == Local html file with control element: The same file plays fine also when i open a local html file with the vide controls element. So why do I get those errors when this is viewed on the twitter website? Any pointers appreciated. Thanks!

由 Ran 於 修改

引用

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

更多資訊

hellosct1 13 個解決方法 139 個答案

Hi,

it is possible to be active and see the HD by following the following link

https://support.mozilla.org/en-US/kb/firefox-4k-ultra-high-definition-youtube-videos

Hi, it is possible to be active and see the HD by following the following link https://support.mozilla.org/en-US/kb/firefox-4k-ultra-high-definition-youtube-videos
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17267 個解決方法 156061 個答案

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.


gvfs-mime --query video/mp4
Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution. *https://www.mozilla.org/en-US/firefox/all/ ---- gvfs-mime --query video/mp4
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題