Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How do I turn off pop-up blocker in Quantum 62.0.3 (64-bit)?

more options

I went into Options and confirmed that the pop-up blocker is not on (screenshot). But, even so, pop-ups are being blocked. However, when I use IE or Chrome at this same site, the pop-ups do appear. TIA.

I went into Options and confirmed that the pop-up blocker is not on (screenshot). But, even so, pop-ups are being blocked. However, when I use IE or Chrome at this same site, the pop-ups do appear. TIA.
附加的畫面擷圖

被選擇的解決方法

musicollector said

However, when I use IE or Chrome at this same site, the pop-ups do appear. TIA.

Hello musicollector,

When you're on that site click on the 'i' in a circle, next to the padlock at the left side of the address bar. That will take you to "Page Info". Then click on the little black arrow on the dropdown and then on "More Information". Click on the 'Permissions" tab and scroll down to "Open Pop-up Windows". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Do you see any pop-ups appearing now  ?

從原來的回覆中察看解決方案 👍 0

所有回覆 (6)

more options

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Now in the Reply Box on the forum page, do a right-click in the box and select Paste.

This will show us your system details. No Personal Information Is Collected.


Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

選擇的解決方法

musicollector said

However, when I use IE or Chrome at this same site, the pop-ups do appear. TIA.

Hello musicollector,

When you're on that site click on the 'i' in a circle, next to the padlock at the left side of the address bar. That will take you to "Page Info". Then click on the little black arrow on the dropdown and then on "More Information". Click on the 'Permissions" tab and scroll down to "Open Pop-up Windows". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Do you see any pop-ups appearing now  ?

more options

Wow! THANKS, McCoy! You rock! Who would have thought? When I went in the way you suggested, there was a check-mark next to Pop-up blocker.

This is very unintuitive. Not sure why Firefox is behaving this way. I mean, if I give the browser blanket permission to allow pop-ups, why is it over-riding it for individual sites? Doesn't make sense. :-(

But, anyway, I appreciate your help.

more options

Thanks, FredMcD for taking the time. McCoy's suggestion is the cat's meow! It worked very well.

more options

My pleasure, musicollector  !

In all honesty : I haven't a clue why you have to give per site permission, while you have unchecked that box in Privacy & Security ...... Maybe someone else can shine a light on it .....

more options

Thanks, McCoy. My sentiments, exactly. I mean when I go to Options the normal way, through Tools, I see that the pop-up blocker is disabled. Common sense dictates that that is all that should be needed.

At least, now I know how to fix it on a case-by-case basis, thanks to you. :-)