X
點擊此處開啟此網站的行動版。

技術支援討論區

Cookies Not Clearing

已張貼

When I select 'Clear All History' (with all items checked, and Time Range set to 'Everything'), and then open 'Manage Data' (under 'Cookies and Site Data'), all cookies are still present. This is a consistent issue; and multiple downloads, and fresh installs (including starting with a new Profile) have not changed the behavior.

When I select 'Clear All History' (with all items checked, and Time Range set to 'Everything'), and then open 'Manage Data' (under 'Cookies and Site Data'), all cookies are still present. This is a consistent issue; and multiple downloads, and fresh installs (including starting with a new Profile) have not changed the behavior.

被選擇的解決方法

Note that you probably need to reload the about:preferences page to get an updated view of the Cookie Manager window. Closing and reopening this window doesn't seem to work.

從原來的回覆中察看解決方案 0
FredMcD
  • Top 10 Contributor
4222 個解決方法 58924 個答案

If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted. http://kb.mozillazine.org/Cookies https://support.mozilla.org/kb/Deleting+cookies

If clearing cookies didn't help then it is possible that the '''cookies.sqlite''' file that stores the cookies got corrupted. Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like '''cookies.sqlite-journal''' in the Firefox profile folder in case the file cookies.sqlite got corrupted. http://kb.mozillazine.org/Cookies https://support.mozilla.org/kb/Deleting+cookies
cor-el
  • Top 10 Contributor
  • Moderator
17413 個解決方法 157286 個答案

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"
Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History). *https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history *Options/Preferences -> Privacy & Security<br>Firefox will: "Use custom settings for history" *remove checkmark: [ ] "Always use Private Browsing mode"

提出問題者

Thank you both for your replies; unfortunately, all cookies remain.

Thank you both for your replies; unfortunately, all cookies remain.
cor-el
  • Top 10 Contributor
  • Moderator
17413 個解決方法 157286 個答案

Is this about cookies or about local storage (cookies show a number under the Cookies column in manage data)?

Is this about cookies or about local storage (cookies show a number under the Cookies column in manage data)?

提出問題者

Thank you, cor-el, for your question. All cookies, as well as storage-items, remain.

Thank you, cor-el, for your question. All cookies, as well as storage-items, remain.
cor-el
  • Top 10 Contributor
  • Moderator
17413 個解決方法 157286 個答案

選擇的解決方法

Note that you probably need to reload the about:preferences page to get an updated view of the Cookie Manager window. Closing and reopening this window doesn't seem to work.

Note that you probably need to reload the about:preferences page to get an updated view of the Cookie Manager window. Closing and reopening this window doesn't seem to work.

有幫助的回覆

Thank you, cor-el, for the workaround! I hope this small bug can now be fixed – at least at some point in the future.

Thank you, cor-el, for the workaround! I hope this small bug can now be fixed – at least at some point in the future.