X
點擊此處開啟此網站的行動版。

技術支援討論區

After update to Quantum 60.0.1 pages with WebGL (tinkercad.com) doesn't work. Any help?

已張貼

After update to Quantum 60.0.1 pages with WebGL (tinkercad.com) doesn't work. I could not find anywhere on internet, how to enable or turn it on. Only something like this for older version:

"To enable WebGL, set webgl.force-enabled to true." Ok, but set how??? Where? Any help?

After update to Quantum 60.0.1 pages with WebGL (tinkercad.com) doesn't work. I could not find anywhere on internet, how to enable or turn it on. Only something like this for older version: "To enable WebGL, set webgl.force-enabled to true." Ok, but set how??? Where? Any help?
附加的畫面擷圖

由 magy357 於 修改

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 24.0 r0

應用程式

  • Firefox 60.0.1
  • 使用者代理:Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/60.0.1/WINNT/en-GB/

擴充套件

  • Firefox Pioneer 1.0 (pioneer-opt-in@mozilla.org)
  • Imagus 0.9.8.64 ({00000f2a-7cde-4f20-83ed-434fcb420d71})
  • Notifier for Gmail™ 0.9.3 (jid0-GjwrPchS3Ugt7xydvqVK4DQk8Ls@jetpack)
  • SearchPreview 11.0 ({EF522540-89F5-46b9-B6FE-1829E2B572C6})
  • uBlock Origin 1.16.6 (uBlock0@raymondhill.net)
  • Video Downloader professional 1.98.2 (ffext_basicvideoext@startpage24)
  • YouTube MP4 Downloader 2.0.9 (@youtube-mp4-downloader)
  • Download YouTube Videos as MP4 1.8.10 ({b9bfaf1c-a63f-47cd-8b9a-29526ced9060}) (Inactive)
  • FavIconReloader 0.8.1-signed (FavIconReloader@mozilla.org) (Inactive)
  • Google Docs Viewer 1.8.9.1-signed.1-signed (adonis.cuhk@gmail.com) (Inactive)
  • ReloadEvery 45.0.0 ({888d99e7-e8b5-46a3-851e-1ec45da1e644}) (Inactive)
  • SQLite Manager 0.8.3.1-signed.1-signed (SQLiteManager@mrinalkant.blogspot.com) (Inactive)
  • Troubleshooter 1.1a.1-signed.1-signed (troubleshooter@mozilla.org) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: ATI Mobility Radeon HD 4500/5100 Series
  • adapterDescription2:
  • adapterDeviceID: 0x9553
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterSubsysID: 02be1028
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22164
  • driverDate: 4-24-2013
  • driverDate2:
  • driverVersion: 8.970.100.0
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING', u'description': u'Compositing'}, {u'status': u'failed', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'failed', u'message': u'Failed to acquire a D3D11 device', u'type': u'runtime'}], u'name': u'D3D11_COMPOSITING', u'description': u'Direct3D11 Compositing'}, {u'status': u'unavailable', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'runtime'}], u'name': u'DIRECT2D', u'description': u'Direct2D'}, {u'status': u'disabled', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE', u'description': u'Direct3D11 hardware ANGLE'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'GPU_PROCESS', u'description': u'GPU Process'}, {u'status': u'unavailable', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER', u'description': u'WebRender'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP', u'description': u'Off Main Thread Painting'}, {u'status': u'unavailable', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'available', u'message': u'Enabled for Windows 7 via user-preference', u'type': u'user'}, {u'status': u'unavailable', u'message': u'Requires D3D11', u'type': u'runtime'}], u'name': u'ADVANCED_LAYERS', u'description': u'Advanced Layers'}]}
  • info: {u'AzureContentBackend (UI Process)': u'skia', u'AzureCanvasBackend (UI Process)': u'skia', u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'AzureFallbackCanvasBackend (UI Process)': u'cairo', u'ApzAutoscrollInput': 1, u'AzureCanvasAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 2
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 0
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL creation failed: * Error during ANGLE OpenGL init. * Exhausted GL driver caps.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL creation failed: * Error during ANGLE OpenGL init. * Exhausted GL driver caps.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
WestEnd 60 個解決方法 5387 個答案

What kinda JS API are you using? WebGL is javascript from what I can find.

What kinda JS API are you using? WebGL is javascript from what I can find.

提出問題者

WestEnd said

What kinda JS API are you using? WebGL is javascript from what I can find.

Speak with language I can understand :D WTH is JS API? I just update Mozilla Firefox because getting message I have to, and after that suddenly this page doesn't work. It's website, where you can made 3D design easily. I am not sure what I have to change. Oh, btw, I found how to set in about:config the webgl.force-enabled to TRUE value. but even that, same message as per picture.

''WestEnd [[#answer-1114800|said]]'' <blockquote> What kinda JS API are you using? WebGL is javascript from what I can find. </blockquote> Speak with language I can understand :D WTH is JS API? I just update Mozilla Firefox because getting message I have to, and after that suddenly this page doesn't work. It's website, where you can made 3D design easily. I am not sure what I have to change. Oh, btw, I found how to set in about:config the webgl.force-enabled to TRUE value. but even that, same message as per picture.
FredMcD
  • Top 10 Contributor
4310 個解決方法 60525 個答案

Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 29.0.0.171

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

'''Separate Security Issue:''' Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player Version: '''Version 29.0.0.171 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

提出問題者

Even I think this have nothing together with my issue, I did all those things.

Adobe flash uninstalled - no change. Installed back latest version - no change. Drivers - latest version installed and up to date. Still the same problem. So... any another idea or how to go to previous Firefox version where everything working?

Even I think this have nothing together with my issue, I did all those things. Adobe flash uninstalled - no change. Installed back latest version - no change. Drivers - latest version installed and up to date. Still the same problem. So... any another idea or how to go to previous Firefox version where everything working?
FredMcD
  • Top 10 Contributor
4310 個解決方法 60525 個答案

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}

提出問題者

Safe mode - no change. error page still appear.

no shield icon at all anywhere on tinkercad, so I guess tracking protection is not the issue.

Any another idea?

I am ready to cooperate with Teamviewer session, in case anybody can or want to do it this was, as I am using it when I helping to other people for many other problems, but this issue is far beyond my ability to solve it. Thx

Safe mode - no change. error page still appear. no shield icon at all anywhere on tinkercad, so I guess tracking protection is not the issue. Any another idea? I am ready to cooperate with Teamviewer session, in case anybody can or want to do it this was, as I am using it when I helping to other people for many other problems, but this issue is far beyond my ability to solve it. Thx

由 magy357 於 修改

Shadow110 1072 個解決方法 14836 個答案

Hi, sorry no Teamviewer. It is not how we can do things. As it is users helping other users is what Firefox Support is Volunteers all over the world.

I will say this much about OpenGL I almost never see it working or running in peoples info that gets sent . The best way to find out OpenGl is to google your Video card/chip driverDate: 4-24-2013 and put ATI Mobility Radeon HD 4500/5100 Series+openGL

Please use this URL to Auto Detect drivers for your card/chip : https://support.amd.com/en-us/download/auto-detect-tool

With all the errors you have nothing can be done for you until this is fixed.

Video Card/Chip Errors  : u'Failed - bad | u'unavailable = bad | disabled featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'name': u'HW_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'failed', u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'failed', u'message': u'Failed to acquire a D3D11 device', u'type': u'runtime'}]}, {u'status': u'unavailable', u'description': u'Direct2D', u'name': u'DIRECT2D', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'runtime'}]}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}]}, {u'status': u'available', u'description': u'GPU Process', u'name': u'GPU_PROCESS', u'log': [{u'status': u'available', u'Off Main Thread Painting', u'name': u'OMTP', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'unavailable', u'description': u'Advanced Layers', u'name': u'ADVANCED_LAYERS', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'available', u'message': u'Enabled for Windows 7 via user-preference', u'type': u'user'}, {u'status': u'unavailable', u'message': u'Requires D3D11', u'type': u'runtime'}]}]}

Please let us know if this solved your issue or if need further assistance.

Hi, sorry no Teamviewer. It is not how we can do things. As it is users helping other users is what Firefox Support is Volunteers all over the world. I will say this much about OpenGL I almost never see it working or running in peoples info that gets sent . The best way to find out OpenGl is to google your Video card/chip driverDate: 4-24-2013 and put ATI Mobility Radeon HD 4500/5100 Series+openGL Please use this URL to Auto Detect drivers for your card/chip : https://support.amd.com/en-us/download/auto-detect-tool With all the errors you have nothing can be done for you until this is fixed. Video Card/Chip Errors : u'Failed - bad | u'unavailable = bad | disabled featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'name': u'HW_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'failed', u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'failed', u'message': u'Failed to acquire a D3D11 device', u'type': u'runtime'}]}, {u'status': u'unavailable', u'description': u'Direct2D', u'name': u'DIRECT2D', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'runtime'}]}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}]}, {u'status': u'available', u'description': u'GPU Process', u'name': u'GPU_PROCESS', u'log': [{u'status': u'available', u'Off Main Thread Painting', u'name': u'OMTP', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'unavailable', u'description': u'Advanced Layers', u'name': u'ADVANCED_LAYERS', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'available', u'message': u'Enabled for Windows 7 via user-preference', u'type': u'user'}, {u'status': u'unavailable', u'message': u'Requires D3D11', u'type': u'runtime'}]}]} Please let us know if this solved your issue or if need further assistance.

提出問題者

OK, here is the situation: I already downgraded Mozilla Firefox to ver. 59 something. Page tinkercad immediately run without any problem. But as you suggest, I checked latest version of drivers and that auto detect tool want me to install another version of drivers. Ok, whatever... So I did, restarted laptop and checked tinkercad page with firefox ver.59. Working as usual. Then I upgraded MF to ver. 60 and voilá - page suddenly doesn't work, getting message as per picture on my first post.

So - if WebGL page working in ver. 59 but doesn't in ver. 60, issue have NOTHING to do with graphic card drivers or such things. Mozilla developers obviously must do some particular changes in newer version, that it causing this issue.

OK, here is the situation: I already downgraded Mozilla Firefox to ver. 59 something. Page tinkercad immediately run without any problem. But as you suggest, I checked latest version of drivers and that auto detect tool want me to install another version of drivers. Ok, whatever... So I did, restarted laptop and checked tinkercad page with firefox ver.59. Working as usual. Then I upgraded MF to ver. 60 and voilá - page suddenly doesn't work, getting message as per picture on my first post. So - if WebGL page working in ver. 59 but doesn't in ver. 60, issue have NOTHING to do with graphic card drivers or such things. Mozilla developers obviously must do some particular changes in newer version, that it causing this issue.

由 magy357 於 修改