X
點擊此處開啟此網站的行動版。

技術支援討論區

When using a corporate proxy via a .pac, why do I get an SEC_ERROR_UNKNOWN_ISSUER for every site outside the VPN?

已張貼

Switching from Safari to Firefox, I wanted to use the same proxy settings. My first try was to use the system's settings, as it gets automatic proxy configuration from the right URL. This worked alright for Safari! On Firefox however, if I'm connected to the VPN I can access all websites in our VPN, but none outside, as I get the SEC_ERROR_UNKNOWN_ISSUER (can't always add an exception) As soon as I exit the VPN, firefox is "unable to find the proxy server".

I've tried all other kinds of ways to connect via that proxy - manually connecting, by URL in firefox or by automatically detecting, but nothing solves my problem. The automatic configuration shouldn't be the problem as it works fine for Safari and shouldn't be any different for Firefox.

I'd really appreciate any help on the subject.

Switching from Safari to Firefox, I wanted to use the same proxy settings. My first try was to use the system's settings, as it gets automatic proxy configuration from the right URL. This worked alright for Safari! On Firefox however, if I'm connected to the VPN I can access all websites in our VPN, but none outside, as I get the SEC_ERROR_UNKNOWN_ISSUER (can't always add an exception) As soon as I exit the VPN, firefox is "unable to find the proxy server". I've tried all other kinds of ways to connect via that proxy - manually connecting, by URL in firefox or by automatically detecting, but nothing solves my problem. The automatic configuration shouldn't be the problem as it works fine for Safari and shouldn't be any different for Firefox. I'd really appreciate any help on the subject.

被選擇的解決方法

The trick was to import my company's CA certificate in Firefox, not just my keychain.

從原來的回覆中察看解決方案 0

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:59.0) Gecko/20100101 Firefox/59.0

更多資訊

選擇的解決方法

The trick was to import my company's CA certificate in Firefox, not just my keychain.

The trick was to import my company's CA certificate in Firefox, not just my keychain.