X
點擊此處開啟此網站的行動版。

技術支援討論區

Full screen HTML5 Video Stutters and Choppy - YouTube & Twitch - Firefox 55.0.3 (64-bit) EME Free

已張貼

Firefox version  : 55.0.3 (64-bit) EME Free Current addons / extensions : None - all removed

Problem: Full screen Video Stutters and Choppy - mainly on YouTube Html5 as well as on Twitch Html5. Occur only with Firefox on HTML5.

System Specs: OS  : Windows 10 Pro 64bit (OS Build 15063.463) CPU  : i7 3770S Mem  : 8Gb GPU  : nVidia 1030 GT

Firefox version : 55.0.3 (64-bit) EME Free Current addons / extensions : None - all removed Problem: Full screen Video Stutters and Choppy - mainly on YouTube Html5 as well as on Twitch Html5. Occur only with Firefox on HTML5. System Specs: OS : Windows 10 Pro 64bit (OS Build 15063.463) CPU : i7 3770S Mem : 8Gb GPU : nVidia 1030 GT

由 NeoTheOnne 於 修改

被選擇的解決方法

Issue remains with older Firefox too. i suspect Intel HD4000 driver (that is force installed by MS), might be messing up the graphics. although the main GPU used is nVidia GT 1030 with latest Aug 2017 driver (22.21.13.8541) . No way to disable the lousy HD4000 that i'm aware of or prevent MS driver force updates.

Either ways, i'll wait for Firefox 60, to return from Chrome.

Thanks for all your help guys. Really appreciated.

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 26.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

更多資訊

FredMcD
  • Top 10 Contributor
4246 個解決方法 59400 個答案
https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

提出問題者

Above solution does not work.

Uninstalled existing Firefox + deleted all Mozilla folders. installed standard English Firefox 55.0.3 64bit with no addons. Same Problem remains - full screen choppy videos, video stutters, frames skipped.

Please provide a real FIX.

I moved to Chrome and no more lags or frame drops. I'm still waiting for an effective Fix from you, to return to Firefox.

Above solution does not work. Uninstalled existing Firefox + deleted all Mozilla folders. installed standard English Firefox 55.0.3 64bit with no addons. Same Problem remains - full screen choppy videos, video stutters, frames skipped. Please provide a real FIX. I moved to Chrome and no more lags or frame drops. I'm still waiting for an effective Fix from you, to return to Firefox.

由 NeoTheOnne 於 修改

提出問題者

Still waiting for your response to above status ^

Still waiting for your response to above status ^
Josh Ross 12 個解決方法 143 個答案

I haven't been able to reproduce your issue with your configuration. Everything works as intended, and I have no stutters, makes me wonder for the underlying reason. Do you have any applications that might be interfering with Firefox?

Additionally, between removal and reinstallation, try restarting your PC.

Another alternative is to boot into Windows "Safe mode with networking" And try reinstallation there.

And finally, you can go to Win key + R, type "appdata" (without quotes), go to local and remove every single file related to Mozilla and Firefox.

I haven't been able to reproduce your issue with your configuration. Everything works as intended, and I have no stutters, makes me wonder for the underlying reason. Do you have any applications that might be interfering with Firefox? Additionally, between removal and reinstallation, try restarting your PC. Another alternative is to boot into Windows "Safe mode with networking" And try reinstallation there. And finally, you can go to Win key + R, type "appdata" (without quotes), go to local and remove every single file related to Mozilla and Firefox.

有幫助的回覆

When i noted fresh install, after existing Firefox was uninstalled + Mozilla folders deleted, i meant, all following folders deleted before new install: %AppData%\Local\Mozilla %AppData%\LocalLow\Mozilla %AppData%\Roaming\Mozilla

Still, even with zero add-ons on fresh Firefox install, the issue reproduces easily and every time. Firefox lost its charm. it's the HTML5 player of youtube that stutters and skips frames, but the best way to describe the issue, is a repeat of frames or range of frames back and forth twice or more, as if the video tries to play, but goes back few frames and then continues on, but this glitch repeats throughout the videos randomly.

Before the fresh install, on previous existing Firefox, while Flash enable add-on allowed to bypass the HTML5, all YouTube lags and stutters on Firefox were gone, but still, the add-on itself is not a Mozilla product and is not perfect, because with it, the videos on YouTube start after the beginning few seconds are played 3 times. Using the add-on to force Flash, and bypass HTML5, narrowed down the issue to Firefox performance and compatibility with YouTube HTML5 default player. Because with Flash forced player videos are smooth.

After moved to latest Chrome (60.0.3112.113 (Official Build) (64-bit) Videos are smooth, no performance issue with HTML5 on YouTube. It's kinda sad, cause i've been a loyal fan of Firefox for years, and i'm leaving because of YouTube HTML5 smoother on Chrome but choppy on Firefox :[ unless there's a fix. i'll come back to Firefox immediately.

The following video is example and a way to easily reproduce the issue at full screen, if you don't see it immediately, just go back and forth and you'll easily get the stutters, lags and frame skips in no time.

https://www.youtube.com/watch?v=LeiFF0gvqcc&t=175

When i noted fresh install, after existing Firefox was uninstalled + Mozilla folders deleted, i meant, all following folders deleted before new install: %AppData%\Local\Mozilla %AppData%\LocalLow\Mozilla %AppData%\Roaming\Mozilla Still, even with zero add-ons on fresh Firefox install, the issue reproduces easily and every time. Firefox lost its charm. it's the HTML5 player of youtube that stutters and skips frames, but the best way to describe the issue, is a repeat of frames or range of frames back and forth twice or more, as if the video tries to play, but goes back few frames and then continues on, but this glitch repeats throughout the videos randomly. Before the fresh install, on previous existing Firefox, while Flash enable add-on allowed to bypass the HTML5, all YouTube lags and stutters on Firefox were gone, but still, the add-on itself is not a Mozilla product and is not perfect, because with it, the videos on YouTube start after the beginning few seconds are played 3 times. Using the add-on to force Flash, and bypass HTML5, narrowed down the issue to Firefox performance and compatibility with YouTube HTML5 default player. Because with Flash forced player videos are smooth. After moved to latest Chrome (60.0.3112.113 (Official Build) (64-bit) Videos are smooth, no performance issue with HTML5 on YouTube. It's kinda sad, cause i've been a loyal fan of Firefox for years, and i'm leaving because of YouTube HTML5 smoother on Chrome but choppy on Firefox :[ unless there's a fix. i'll come back to Firefox immediately. The following video is example and a way to easily reproduce the issue at full screen, if you don't see it immediately, just go back and forth and you'll easily get the stutters, lags and frame skips in no time. https://www.youtube.com/watch?v=LeiFF0gvqcc&t=175

由 NeoTheOnne 於 修改

FredMcD
  • Top 10 Contributor
4246 個解決方法 59400 個答案

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See [[Flash Plugin - Keep it up to date and troubleshoot problems|this article]] for more information on using the Flash plugin in Firefox). To disable hardware acceleration in Flash Player: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.adobe.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. Does this solve the problem? Let us know.

提出問題者

FredMcD, You misread my reply from 3:55PM.

Flash player was the savior of the choppy HTML5 videos, with Flash - videos ran smooth, but the add-on that forces Flash has its own problems.

Bottom line: Firefox 55.0.3 64bit English - fresh setup - no add-ons Choppy videos on YouTube at full screen, video stutters, frames skipped Same issue on Twitch. Much more details on my reply from 3:55PM above.

Before existing fresh setup, while HTML5 player was bypassed and Flash was forced, the issue was Fixed, however, the add-on that forces Flash is not good.

Also, why would Firefox have performance and compatibility issues with HTML5 video players ?

Existing workaround: am using Chrome instead with no more issues. But looking for a fix to return to Firefox.

FredMcD, You misread my reply from 3:55PM. Flash player was the savior of the choppy HTML5 videos, with Flash - videos ran smooth, but the add-on that forces Flash has its own problems. Bottom line: Firefox 55.0.3 64bit English - fresh setup - no add-ons Choppy videos on YouTube at full screen, video stutters, frames skipped Same issue on Twitch. Much more details on my reply from 3:55PM above. Before existing fresh setup, while HTML5 player was bypassed and Flash was forced, the issue was Fixed, however, the add-on that forces Flash is not good. Also, why would Firefox have performance and compatibility issues with HTML5 video players ? Existing workaround: am using Chrome instead with no more issues. But looking for a fix to return to Firefox.

由 NeoTheOnne 於 修改

RexPrestige 1 個解決方法 7 個答案

Hey NeoTheOnne! If this community does not pull through, you might file a bug with the developers at https://bugzilla.mozilla.org/ .

While you are here, you might tinker with your 1030GT drivers and settings to see if by happenstance there is a wonky setting triggering for HTML5 but not flash.

Good luck!

Hey NeoTheOnne! If this community does not pull through, you might file a bug with the developers at https://bugzilla.mozilla.org/ . While you are here, you might tinker with your 1030GT drivers and settings to see if by happenstance there is a wonky setting triggering for HTML5 but not flash. Good luck!

提出問題者

RexPrestige thank you! for both pointing me to file a bug as well to check display driver settings. i hope there will be an easy fix for this issue. Although the issue does not exist on Chrome, i prefer to go back to Firefox.

RexPrestige thank you! for both pointing me to file a bug as well to check display driver settings. i hope there will be an easy fix for this issue. Although the issue does not exist on Chrome, i prefer to go back to Firefox.

由 NeoTheOnne 於 修改

Josh Ross 12 個解決方法 143 個答案

Interesting, does this issue remain in Incognito mode or a different version of Firefox? Maybe you can try a development build? Also, if it might be a problem with driver settings, try updating your drivers to the latest -> Booting Windows in "safe mode" -> Reinstalling Firefox could fix the issue.

Interesting, does this issue remain in Incognito mode or a different version of Firefox? Maybe you can try a development build? Also, if it might be a problem with driver settings, try updating your drivers to the latest -> Booting Windows in "safe mode" -> Reinstalling Firefox could fix the issue.

提出問題者

Josh Ross. Done all that. Firefox still performs badly on HTML5 while on Chrome the issues are gone. I want to return back to Firefox with either a fix or next gen build to hopefully solve existing 55.0.3 stutters and choppy performance on HTML5.

Josh Ross. Done all that. Firefox still performs badly on HTML5 while on Chrome the issues are gone. I want to return back to Firefox with either a fix or next gen build to hopefully solve existing 55.0.3 stutters and choppy performance on HTML5.
Josh Ross 12 個解決方法 143 個答案

I am running low on ideas. Can you try installing the latest beta version? I heard that it helped some people to deal with stutters. However, I cannot confirm that myself.

I am running low on ideas. Can you try installing the latest beta version? I heard that it helped some people to deal with stutters. However, I cannot confirm that myself.
FredMcD
  • Top 10 Contributor
4246 個解決方法 59400 個答案

You can also try reinstall v54.

https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

You can also try reinstall v54. https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here. If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues. You should also check out [https://www.mozilla.org/en-US/firefox/organizations/ Firefox; Extended Support Release] {web link} [https://www.mozilla.org/en-US/firefox/organizations/notes/ ESR Notes] [https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ System Requirements]

選擇的解決方法

Issue remains with older Firefox too. i suspect Intel HD4000 driver (that is force installed by MS), might be messing up the graphics. although the main GPU used is nVidia GT 1030 with latest Aug 2017 driver (22.21.13.8541) . No way to disable the lousy HD4000 that i'm aware of or prevent MS driver force updates.

Either ways, i'll wait for Firefox 60, to return from Chrome.

Thanks for all your help guys. Really appreciated.

Issue remains with older Firefox too. i suspect Intel HD4000 driver (that is force installed by MS), might be messing up the graphics. although the main GPU used is nVidia GT 1030 with latest Aug 2017 driver (22.21.13.8541) . No way to disable the lousy HD4000 that i'm aware of or prevent MS driver force updates. Either ways, i'll wait for Firefox 60, to return from Chrome. Thanks for all your help guys. Really appreciated.

由 NeoTheOnne 於 修改

sinisab89 0 個解決方法 1 個答案

Try this. It helped me. Go to about:config Find media.windows-media-foundation.allow-d3d11-dxva Set it to false.

Try this. It helped me. Go to about:config Find media.windows-media-foundation.allow-d3d11-dxva Set it to false.
Azure 2 個解決方法 24 個答案

有幫助的回覆

I have exactly the same problem. Brand new machine (AMD ThreadRipper 1920X.) Clean Windows install and clean FireFox 57.0 64-bit install. AMD Radeon R9 Fury X GPU. The problem occurs only with FireFox playing HTML5 video. Other browsers work fine. What's up, Mozilla?

I have exactly the same problem. Brand new machine (AMD ThreadRipper 1920X.) Clean Windows install and clean FireFox 57.0 64-bit install. AMD Radeon R9 Fury X GPU. The problem occurs only with FireFox playing HTML5 video. Other browsers work fine. What's up, Mozilla?

由 Azure 於 修改

FredMcD
  • Top 10 Contributor
4246 個解決方法 59400 個答案

Please go to the top of any support.mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new Select the product for what the problem is (Firefox or whatever).

Now select the category for the problem. At the bottom is Other.

Describe the problem in brief. Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; None Of These Solve My Problem.

Now enter all the relative information on the problem. At the bottom of this, you can Add Images.

Under this is Troubleshooting Information. Please press the Share Data button. This will let us look at your system details. No Personal Information Is Collected.

Please go to the top of any '''support.mozilla.org''' web page and use the '''Ask A Question link; https://support.mozilla.org/en-US/questions/new''' Select the product for what the problem is (Firefox or whatever). Now select the category for the problem. At the bottom is Other. Describe the problem in brief. Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; '''None Of These Solve My Problem.''' Now enter all the relative information on the problem. At the bottom of this, you can Add Images. Under this is '''Troubleshooting Information.''' Please press the '''Share Data button.''' This will let us look at your system details. '''No Personal Information Is Collected.'''