搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Our anti-virus program keeps coming up with a virus on files from Firefox. What can I do to avoid this?

  • 6 回覆
  • 2 有這個問題
  • 26 次檢視
  • 最近回覆由 FredMcD

more options

Our anti-virus program Bitdefender keeps coming up with files associated with Firefox that contain the virus Gen. Variant Adware Graftor 311830. What do I need to do to fix this? Or is this something Firefox needs to fix?

所有回覆 (6)

more options

A couple common situations with antivirus and Firefox files on Windows is it is making a fuss over something in the Cache (which is harmless while there) or it is a false positive. Another possibility is some malware is on your OS and has infected Firefox.

Though it this case it may be a PuP. https://malwaretips.com/blogs/gen-variant-adware-graftor-removal/

more options

We downloaded all the removal tools and ran them, but still have the problem. <grrr>

more options

Is this about the installed Firefox version or about updating Firefox or about files in the Firefox profile folder.

Does your anti-virus software provide any details like the file name or location?

Can you attach a screenshot?

  • use a compressed image type like PNG or JPG to save the screenshot
  • make sure you do not exceed the maximum size of 1 MB
more options

This is an installed version of Firefox. There are multiple virus messages, but they are always in Firefox and are the same virus Gen. Variant Adware Graftor 311830. I am including a screenshot.

more options

Those items are all about files in the Firefox cache and thus aren't harmful.

Firefox uses two locations for the Firefox profile folder. Location used for the main profile in "AppData\Roaming".

  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>\

Location used for the disk cache and other temporary files in "AppData\Local".

  • C:\Users\<user>\AppData\Local\Mozilla\Firefox\Profiles\<profile>\
more options

Type about:preferences#privacy<enter> in the address bar.

The button next to History, select Use Custom Settings.

Turn off Always use private browsing mode Turn on Remember my browsing and download history At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on Cache and Form And Search History