搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

YouTube.com (not the player) causes Firefox to become unresponsive

  • 7 回覆
  • 14 有這個問題
  • 210 次檢視
  • 最近回覆由 FredMcD

more options

When I try to view a video on YouTube.com, the website takes longer than usual to load (and sometimes causes Firefox to become unresponsive. Embedded videos on other sites (such as reddit.com) are immune to this problem somehow. On top of that, I found that the issue is only present when I am logged into my Google account.

Here are a few quick recordings I made:

https://gfycat.com/GloriousBriefCusimanse (Logged-in on YouTube.com) https://gfycat.com/NiftyRealisticBug (Logged-out on YouTube.com) https://gfycat.com/HandsomeSelfishGerenuk (random embedded video)

I've tried all of the basic refreshing, reinstalling, safe mode, etc., but nothing has worked (other than using another browser or being logged out of my Google account).

被選擇的解決方法

I was able to solve this issue by using the extension uBlock Origin to block the "#guide-subscriptions-section" element on the YouTube.com website.

A user on the Firefox subreddit tipped me off to this being an issue with a number of other people.

從原來的回覆中察看解決方案 👍 2

所有回覆 (7)

more options

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

more options

As far as I know, YouTube.com doesn't use Flash anymore? I just tried it again without Flash enabled and nothing changes.

Also, the video player itself is not the problem, embedded videos work fine. I'm pretty sure it is something else on YouTube.com causing the issue, not the videos themselves.

由 HmmmQuestionMark 於 修改

more options

Visit: https://www.youtube.com/html5 and check that everything is OK.

I've called the big guys to help you. Good luck.

more options

Everything is normal on that page besides the WebM VP9 (which from what I understand isn't supported in Firefox right now).

But as I said, the video player is not the problem, it is the YouTube.com website itself. Embedded videos work fine, and everything works perfectly when I am not logged into my Google account.

more options

This issue is still persisting after the update to Firefox 43.

I even tried restarting Firefox is safe mode (again), nothing changed.

由 HmmmQuestionMark 於 修改

more options

選擇的解決方法

I was able to solve this issue by using the extension uBlock Origin to block the "#guide-subscriptions-section" element on the YouTube.com website.

A user on the Firefox subreddit tipped me off to this being an issue with a number of other people.

more options

That was very good work. Well Done.