Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Maps zoom is staggered instead of smooth

  • 3 replies
  • 1 has this problem
  • 24 views
  • Last reply by irubnich

more options

I'm using Firefox 76 on Mac OS 10.15.4. This has been a problem for many years though, I'm just asking about it now cause it's been bothering me and it's the one reason I'm reluctant to switch to Firefox.

When I go to Google Maps on a fresh Firefox install, zooming is fine. Everything is smooth. It's like this on Chrome all the time.

GIF: https://gfycat.com/playfulsmoothbangeltiger

However, after using Firefox for a bit, at some point the zooming behavior becomes staggered.

GIF: https://gfycat.com/parallelquerulousanole

I have no idea what's going on or what's causing this transition between smooth and staggered to happen. I've seen this problem on multiple versions of Mac OS X and multiple versions of Firefox. I've seen it using multiple laptops with both discrete and integrated graphics cards and various CPUs and RAM sizes. I go back to Firefox occasionally to see if it's fixed but it hasn't been fixed in years.

Please help me regain my sanity.

Thanks!

All Replies (3)

more options

I think the difference is that you are missing the "transition" that creates the appearance of zooming. Instead of showing various sizes in between the beginning and ending size, it just shows the ending size right away. Is that it?

I don't know what would cause that, mainly because I don't know what Google's crazy-complicated scripts do when you zoom in or out.

Could you:

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like May2020, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do the problem site(s) work any better in the new profile?

Assuming so, could you display the Troubleshooting Information page (Help > Troubleshooting Information) and scroll down to the graphics section. Keep this window open and compare with the Troubleshooting Information page in Firefox in your regular profile. Any differences in what is enabled/disabled?

When you are done with the experiment, you can close the window from your new profile without affecting your main session. (May2020 will remain available for future testing.)

Note: Creating a new profile may change your default! On the about:profiles page, if you see a Set as Default Profile button for your regular profile, click that to set it back to normal.

more options

Could be that you have set prefers-reduced-motion in your OS.

You can create a new Integer pref on the about:config page and set its value to 0 if you want to see animations.

  • ui.prefersReducedMotion = 0 [disable animation]
  • ui.prefersReducedMotion = 1 [enable animation]
more options

jscher2000 said

I think the difference is that you are missing the "transition" that creates the appearance of zooming. Instead of showing various sizes in between the beginning and ending size, it just shows the ending size right away. Is that it? I don't know what would cause that, mainly because I don't know what Google's crazy-complicated scripts do when you zoom in or out. Could you: New Profile Test This takes about 3 minutes, plus the time to test your problem site(s). Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it. Click the "Create a New Profile" button, then click Next. Assign a name like May2020, ignore the option to relocate the profile folder, and click the Finish button. After creating the profile, scroll down to it and click the Launch profile in new browser button. Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test. Do the problem site(s) work any better in the new profile? Assuming so, could you display the Troubleshooting Information page (Help > Troubleshooting Information) and scroll down to the graphics section. Keep this window open and compare with the Troubleshooting Information page in Firefox in your regular profile. Any differences in what is enabled/disabled? When you are done with the experiment, you can close the window from your new profile without affecting your main session. (May2020 will remain available for future testing.) Note: Creating a new profile may change your default! On the about:profiles page, if you see a Set as Default Profile button for your regular profile, click that to set it back to normal.

Creating a new profile did fix smooth zooming, similarly to how it does on a clean Firefox install. I have not been able to get the new profile to not be broken yet, although it typically does after a while. I'll see how this goes.

The graphics info in the troubleshooting info was identical between my regular profile where zooming is staggered and the new profile where it's fine.

cor-el said

Could be that you have set prefers-reduced-motion in your OS. You can create a new Integer pref on the about:config page and set its value to 0 if you want to see animations.
  • ui.prefersReducedMotion = 0 [disable animation]
  • ui.prefersReducedMotion = 1 [enable animation]

This did not change anything.

Modified by irubnich