搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Plugin Status Check reports latest Java x64 as vulnerable

  • 2 回覆
  • 5 有這個問題
  • 10 次檢視
  • 最近回覆由 ADTC

more options

Last night I updated all plugins to show the green "Up to date" buttons in the Plugin Status Check website. However, this morning, it reports that the Java plugin is vulnerable (note: not 'out of date'). Is there a new revealed vulnerability in Java publicized in the last few hours?

There is no new version of Java as of now, as the latest is Java 8 Update 45, released on April 14, 2015. Although it may be of importance to note that I first installed 32-bit version of Java to get the green "Up to date" status, but later also installed the 64-bit version of Java (as I need it instead for my 64-bit Eclipse). Could this have caused the vulnerability flag to trigger? Is there a vulnerability in 64-bit Java that is not present in the 32-bit installation?

I saw a few similar questions on Flash plugin, but I already disabled Flash completely. This is concerning Java.

I am running 32-bit Firefox for Windows. I am on Windows 7.

附加的畫面擷圖

由 ADTC 於 修改

所有回覆 (2)

more options

選擇的解決方法

more options

Understood about 32-bit. It is as expected, so I suppose my 64-bit Java installation should not have done anything.

I gather that those articles are posted two days ago, so it should be as recent as it can get. And Oracle is still working on a fix, and that's why there's no new version of Java to update from the vulnerable latest version.

I think I will take the advice and disable Java completely. :)

I think the Plugin Check site has to be enhanced to notify its users that vulnerable plugins may not necessary be out of date. They could be up to date but open to a recently discovered vulnerability. And that it's recommended to keep them disabled until the vulnerability is fixed in a future release.

由 ADTC 於 修改