搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox crashes

  • 2 回覆
  • 1 有這個問題
  • 7 次檢視
  • 最近回覆由 erolozbek

more options

My Laptop (Asus N61VG) keeps giving the error "display driver stopped responding and recovered..." and after a while Firefox crashes (very often). I changed to Google Chrome and the "display driver stopped responding..." error occures less and the browser does not crash. My graphics adapter is Nvidia GeForce GT 220M and I have installed the latest driver.

被選擇的解決方法

If you haven't already, could you try disabling Firefox from using hardware acceleration? This is the usual workaround for incompatibility with your graphics card driver software.

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you exit Firefox and start it up again. Any difference?

If this problem seems to be associated with Flash media, there is a separate setting for that. More information in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

從原來的回覆中察看解決方案 👍 1

所有回覆 (2)

more options

選擇的解決方法

If you haven't already, could you try disabling Firefox from using hardware acceleration? This is the usual workaround for incompatibility with your graphics card driver software.

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you exit Firefox and start it up again. Any difference?

If this problem seems to be associated with Flash media, there is a separate setting for that. More information in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

more options

Thank you very much. Disabling hardware acceleration seems to have fix it. I had no crashes and display driver stops for over 5 hours.

I admit, I had heard earlier about this option, but had no luck earlier with a similar laptop (Asus N61JQ and ATI graphics) one year and it was solved only after a clean reinstall of Windows7. So I applied your suggestion without any real expectations :) Before, disabling all extensions helped but the extensions are most of the whistle and bells for which I prefer Firefox over IE and Chrome for a decade.

由 erolozbek 於 修改