搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox and Thunderbird do not communicate anymore : I can't open links from TB emails (<a href...>) and can't send mail from FF pages (mailto)

  • 13 回覆
  • 5 有這個問題
  • 2146 次檢視
  • 最近回覆由 mawy33

more options

Hi there, Please excuse me if a make a few mistakes, I am French ;)

I come here because firefox and thunderbird are not working together anymore. This is what happens : - Firefox and Thunderbird are opened - I click on a link in an email - A few seconds after that a Firefox windows pops up. The title is : "Close Firefox", the content is : "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system."

Second case : - Firefox is closed and Thunderbird is open - I click on a link in an email - A few seconds after that a Firefox windows pops up as expected. Firefox opens the link as expected but doesn't opens the other tabs as usual (when i start FF it re-opens previous tabs)

Third case : - Firefox and Thunderbird are opened - I click on a link to send an email (<a href="mailto:......@.....">) - A few seconds after that a Thunderbird windows pops up. The title is : "Close Thunderbird", the content is : "Thunderbird is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system."

As in the second case, if TB is closed when i click on the mailto, TB opens properly and send the email.

If Internet Explorer is set as my default browser, it works fine for "Thunderbird -> link -> IE" but the "IE-> mailto -> TB" still doesn't work.

I already looked up for some answers on google but can't find something which works.

Thank you in advance for your answers. Vincent

被選擇的解決方法

Check the target field in the Firefox desktop shortcut and make sure that you do not start Firefox with the -no-remote switch or have set the environment variable MOZ_NO_REMOTE=1 (Control Panel > System > Advanced > Environment variables).

Always make sure to start at least the default profile without the -no-remote command line switch. If you need to have more than one profile open at the same time then start subsequent instances with the -no-remote command line switch. You can not send links from other programs to a Firefox instance that is started with the -no-remote switch. In such a case you need to drag links in a Firefox window or paste the link in the location bar.

從原來的回覆中察看解決方案 👍 2

所有回覆 (13)

more options

Hi mawy33, I'm also french, and with my english speaking skills I would say that you didn't made mistakes :) . For your problem, it's just a suggestion but did you tried to reset firefox and fully uninstalled thunderbird and then made a clean reinstall ? Maybe it could be an idea.

more options

Thank you for you answer but I already uninstall - redownload - reinstall firefox and thunderbird properly. I've also reset Firefox settings but this doesn't help ...

more options

Ok, just another idea for the mailto link TB is well selected by default in the default programs ?

more options

Sorry, I think i made a mistake, this is not the problem

由 Romain 於 修改

more options

The mailto link works, but there is a message telling it's not responding, that's it ?

more options

Exactly. I join a screenshot of the message. Translated into English it says that TB is already running and not answering (but it is !) and that I must stop the process or reboot my computer to open a new window.

more options

Well, the message looks like to what I expected. Don't worry for translation, as I said, and as my username shows :) , i'm french. As I don't know exactly what is happening, i'm gonna launch a windows 8.1 VM on my computer to see if I've got the same problem, because on my windows 7 computer it didn't happened.

I'm currently at work. I keep you updated. It suits you ?

由 Romain 於 修改

more options

Yes but I don't think you will get the problem. I just got it a few weeks ago. Before that everything worked fine ... I translated it to allow other users to understand the problem ;)

more options

Yes you're right for other users (i've been a bit selfish there lol). You say this began few weeks ago that you got it. Something happened like an update or something else ?

由 Romain 於 修改

more options

No I don't think I have done any special thing at that moment ... I discovered another thing that may help to understand : when I try to open a new windows of FF by right click on a link -> open link a new windows, that works fine but if I try to open a new windows by right click on the FF icon of the task bar -> open a new window the same error message appears.

I also noticed that when I click on a link in TB it opens a new FF application and crashes (seen on the task-manager) whereas if I open a new windows by right click on a link -> open link a new windows it opens a new line on the same application and work.

more options

ok, this is weird. I try to see if I've got a solution but I'm really confused, I don't have any.

more options

選擇的解決方法

Check the target field in the Firefox desktop shortcut and make sure that you do not start Firefox with the -no-remote switch or have set the environment variable MOZ_NO_REMOTE=1 (Control Panel > System > Advanced > Environment variables).

Always make sure to start at least the default profile without the -no-remote command line switch. If you need to have more than one profile open at the same time then start subsequent instances with the -no-remote command line switch. You can not send links from other programs to a Firefox instance that is started with the -no-remote switch. In such a case you need to drag links in a Firefox window or paste the link in the location bar.

more options

Thank you very much ! I don't understand what this variable was, but removing it from "Control Panel > System > Advanced > Environment variables" solved the problem.

Thank you again

Vincent