Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox High CPU Usage due to "fontd" on MacOS

  • 4 tontu
  • 0 am na jafe-jafe bii
  • 2 views
  • i mujjee tontu mooy clayeddy00

more options

I'm using MacOS Sonoma 14.4.1 and recently, my browser has started freezing up for several minutes. It seems that the culprit is the "fontd" process because when I open Activity Manager that process spikes to %50 to %80 CPU usage. Killing the process does nothing and quitting out of Firefox does nothing either. I made sure Firefox is fully updated, but still nothing. I'm not sure whether it's a problem with my Macbook Pro's fonts or if it's a problem with Firefox, but I'd like my browser to be reliable.

Does anyone know what might be causing this issue or what I can do to resolve it?

I'm using MacOS Sonoma 14.4.1 and recently, my browser has started freezing up for several minutes. It seems that the culprit is the "fontd" process because when I open Activity Manager that process spikes to %50 to %80 CPU usage. Killing the process does nothing and quitting out of Firefox does nothing either. I made sure Firefox is fully updated, but still nothing. I'm not sure whether it's a problem with my Macbook Pro's fonts or if it's a problem with Firefox, but I'd like my browser to be reliable. Does anyone know what might be causing this issue or what I can do to resolve it?

All Replies (4)

more options

Does it still happen in Troubleshoot Mode?

Have you tried resetting your fonts to default in Font Book > Settings > Advanced > Reset?

Helpful?

more options

zeroknight said

Does it still happen in Troubleshoot Mode? Have you tried resetting your fonts to default in Font Book > Settings > Advanced > Reset?

I've never tried troubleshoot mode because it happens at random times (most frequently when I open Firefox for the first time after restarting my computer), and when it happens I am unable to interface with any aspect of the browser.

I have tried resetting my fonts and that changed nothing. I also tried deleting the FontRegistry plist in my preferences and the issue persists.

Helpful?

more options

See if it still happens with hardware acceleration disabled and your extensions disabled.

Helpful?

more options

zeroknight said

See if it still happens with hardware acceleration disabled and your extensions disabled.

Yes, it still happens with those setting changed.

If this helps, here is the Problem Report I get when Firefox is not responding: Problem Report

Helpful?

Laajal dara

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.