Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google often does not load

  • 2 tontu
  • 3 am na jafe-jafe bii
  • 1 view
  • i mujjee tontu mooy aysomcoa

more options

Often, when I try to search on Google using the search bar, Firefox will load and load and load... and then fail to actually load up Google and search my query.

It doesn't matter if I do this on a new tab or an existing one, it will load and load for probably about 15-20 seconds, and then acts as if I didn't try to do anything at all.

Once it's had it's moment, and successfully fails to load Google, I can try again and it will instantly load Google when I try again, and will continue to do so for a while.

While this issue is happening, I can load any other website just fine. It only affects Google searches using the address bar.

Any idea on a solution or anything I can try to stop this issue occuring?

Often, when I try to search on Google using the search bar, Firefox will load and load and load... and then fail to actually load up Google and search my query. It doesn't matter if I do this on a new tab or an existing one, it will load and load for probably about 15-20 seconds, and then acts as if I didn't try to do anything at all. Once it's had it's moment, and successfully fails to load Google, I can try again and it will instantly load Google when I try again, and will continue to do so for a while. While this issue is happening, I can load any other website just fine. It only affects Google searches using the address bar. Any idea on a solution or anything I can try to stop this issue occuring?

All Replies (2)

more options

This could be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data = false on the about:config page to disable this feature until this is fixed by Google or Mozilla to see if that helps.

See also:


You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet, try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

more options

Dropa said

Is this with Google. com as the homepage or you using the Firefox installed defaults? You didn't clarify this part. If you want a real search engine you should set your homepage as the search engine.

It happens whenever I try to access Google in any way. Whether that's through directly going to the website, or trying to search by typing my query into the address bar and pressing enter. The tab will load, and load, and load, before simply acting as if I never tried to navigate to Google at all.

And then, once that happens, Google loads immediately if I try to search again at that time.

After a while, the issue occurs again, and I have to wait for the loading to "fail" once more.

cor-el said

This could be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data = false on the about:config page to disable this feature until this is fixed by Google or Mozilla to see if that helps. ... If you do not need to use a proxy to connect to internet, try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

Tried both of these solutions. Neither solved the problem, unfortunately.